5 Replies Latest reply on Apr 26, 2005 12:36 AM by Slava Shelestyuk

    WebService ain't called on jdk5

    Slava Shelestyuk Newbie

      i have a web service that is called on client as:

      ServiceFactory serviceFactory = ServiceFactory.newInstance();
      Service service = serviceFactory.createService(
      new URL( "http://localhost:2000/ka-ls/LSService?WSDL" ),
      new QName( "http://webservice.ejb.ka.plesk.com", "LSEndpointService" ) );
      LSEndpoint endpoint = (LSEndpoint) service.getPort( LSEndpoint.class );

      AccountInfo accountInfo = endpoint.getAccountInfo( 0 );
      System.out.println( "AccountInfo: " + accountInfo.getName() );

      it works fine on jboss-4.0.2RC1+j2sdk1.4.2_05,
      but on jdk1.5.0_02 it throws:
      (while calling endpoint.getAccountInfo( 0 ))

      [java] KA console test started...
      [java] log4j:WARN No appenders could be found for logger (org.jboss.webservice.EngineConfigurationFinder).
      [java] log4j:WARN Please initialize the log4j system properly.
      [java] java.rmi.RemoteException: null; nested exception is:
      [java] java.lang.NullPointerException
      [java] at org.jboss.webservice.client.PortProxy.invoke(PortProxy.java:184)
      [java] at $Proxy1.getAccountInfo(Unknown Source)
      [java] at com.plesk.ka.util.test.ConsoleTest.testWS(ConsoleTest.java:263)
      [java] at com.plesk.ka.util.test.ConsoleTest.main(ConsoleTest.java:75)
      [java] Caused by: java.lang.NullPointerException
      [java] at java.util.Hashtable.put(Hashtable.java:396)
      [java] at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl.setProperty(SAXParserImpl.java:395)
      [java] at org.jboss.axis.encoding.DeserializationContextImpl.parse(DeserializationContextImpl.java:262)
      [java] at org.jboss.axis.MessagePart.getAsSOAPEnvelope(MessagePart.java:680)
      [java] at org.jboss.axis.Message.getSOAPEnvelope(Message.java:430)
      [java] at org.jboss.axis.Message.getContentType(Message.java:496)
      [java] at org.jboss.axis.transport.http.HTTPSender.writeToSocket(HTTPSender.java:386)
      [java] at org.jboss.axis.transport.http.HTTPSender.invoke(HTTPSender.java:126)
      [java] at org.jboss.axis.strategies.InvocationStrategy.visit(InvocationStrategy.java:73)
      [java] at org.jboss.axis.SimpleChain.doVisiting(SimpleChain.java:160)
      [java] at org.jboss.axis.SimpleChain.invoke(SimpleChain.java:123)
      [java] at org.jboss.webservice.client.ClientEngine.invoke(ClientEngine.java:126)
      [java] at org.jboss.axis.client.Call.invokeEngine(Call.java:3054)
      [java] at org.jboss.axis.client.Call.invoke(Call.java:3039)
      [java] at org.jboss.axis.client.Call.invoke(Call.java:2629)
      [java] at org.jboss.axis.client.Call.invoke(Call.java:2538)
      [java] at org.jboss.axis.client.Call.invokeInternal(Call.java:1976)
      [java] at org.jboss.axis.client.Call.invoke(Call.java:1914)
      [java] at org.jboss.webservice.client.CallImpl.invoke(CallImpl.java:265)
      [java] at org.jboss.axis.client.AxisClientProxy.invoke(AxisClientProxy.java:373)
      [java] at $Proxy0.getAccountInfo(Unknown Source)
      [java] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      [java] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      [java] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      [java] at java.lang.reflect.Method.invoke(Method.java:585)
      [java] at org.jboss.webservice.client.PortProxy.invoke(PortProxy.java:111)
      [java] ... 3 more

      does anybody know the reason? any ideas?