4 Replies Latest reply on Apr 28, 2005 2:43 PM by Tom Marrs

    Cannot find jaxrpc-mapping for generated type

    platinumdragon Newbie

      Hi,

      I have been following the "step-by-step" tutorials on JAX-RPC services. I have tried to be a good newbie and RTFM. In combination with the JAX-RPC 1.1 specification, I think I have most of the wrinkles worked out, except:

      When deploying, JBoss picks up the war and deploys it (successfully). There is just one warning though:

      WARN [JavaWsdlMapping] Cannot find jaxrpc-mapping for type: {http://com.company.project/service/types/arrays/com/company/project/commons}AliasArray

      This type has been generated (by wscompile) because of an endpoint interface method:
      Alias[] getAllAliases();

      How can this be missing if it was the same tool that created it in the first place? Indeed, looking in the jaxrpc-mapping.xml file, that type is missing, but I'm not exactly sure what to do about it. Should I put an entry in there for it (I don't know much about it, since it isn't one of my classes and I am unsure of what type of entry to put in there), or is this indicative of another problem?

      Thanks for any thoughts on this,
      Mike