2 Replies Latest reply on Apr 25, 2005 4:25 AM by Jon Finanger

    WSRPC Service step by step - and custom types

    Jon Finanger Newbie

      Since i dont need a session bean endpoint (only a JSE), i tried to generate my files using the wscompile tool. As the guide explain, it should be very easy... - not!

      I have a very simple interface:
      public interface Root extends Remote {
      public WSMyRoot getRoot() throws RemoteException;
      }

      WSMyRoot is also simple:
      public interface WSMyRoot extends Serializable {
      public String getName();
      }

      I have the config.xml file:


      <interface name=test."Root"/>



      I run: wscompile -cp output/classes -gen:server -f:rpcliteral -mapping jaxrpc-mapping.xml config.xml

      I get this error:
      error: invalid type for JAX-RPC structure: test.WSMyRoot

      Removing the WSMyRoot 'fixes' the problem.

      Is there any problems with wscompile and complex types? Or have i missed something?
      The step-by-step guide looked very promising... :)

      -Jon