• Two databases with two persistence units - tables are created in wrong database

    Hi everyone,   I got several applications with EJB, JPA and JSF in Wildfly 14.   I use 2 databases, processenginemysql and testprocessdb2. I configured two XA-Datasources. Here is my persistence.xml &...
    Profile Photo
    last modified by Nicole Müller
  • How to Reduce the Amount of Exception Data Transmitted

    Hello -   We've noticed that whenever we have a timeout exception (ISPN000476), this information gets sent to other nodes in the cluster who log it with the ISPN000217 code. Recently we experienced a flood of ti...
    Profile Photo
    last modified by Josh Harness
  • Wildfly 16 deployment timeout

    Getting following when the application deploys. it hangs following subdeployment of some application war files and then gets following   Timeout after [300] seconds waiting for service container stability. Operat...
    Profile Photo
    last modified by dan meredith
  • LDAP Issue WildFly 18.0.1

    Hi All,   I am in the process of upgrading from WF17 to WF18, and for some reason have run into an issue.   I run WF in a Clustered mode with a Domain Controller and several hosts.   On my WF18 d...
    Profile Photo
    last modified by Ian van der Bank
  • Unable to create service for 'HttpServerAuthenticationMechanismFactory.BEARER_TOKEN'

    Since we updated to WF 17 (from WF 15) we find lots of DEBUGs in our logfiles like this:   2019-07-17 13:55:48,432|DEBUG|               ...
    Profile Photo
    last modified by Markus Fried
  • Second level Cache: format of hibernate property expiration.lifespan for a entity in jar in ear. Prefix region_prefix

    Hi, how does the hibernate property hibernate.cache.infinispan.entity.expiration.lifespan look out in case of ear application ear and entity in jar in the ear (persistence.xml is in ear)? Some sources describe forma...
    Profile Photo
    created by serg_732173
  • Infinispan Jgroups Problems Over JBoss EAP 7.1 (Web Cache)

    I have this Jboss Configuration: 2 nodes instances of Jboss eap 7.1.6 on differente machine clustering (udp) each other on standalone mode. The first consideration that i'll do is the above similar configuration with ...
    Profile Photo
    last modified by Jo Derran
  • JSESSION ID is not changing after authentication

    Hi, I have an application running on wildfly 8.2.1Final and I added the below property to the standalone.xml   <system-properties>     <property name="org.apache.catalina.authenticator.A...
    Profile Photo
    last modified by Vineeth V Nair
  • Unable to deploy ear with unknown timeout and "severe" on CDI

    I'm using wildFly 17.0.1, below are the logs, here even unable to get any clue on timeout not sure "SEVERE" on CDI is relevant ?
    Profile Photo
    last modified by Rakesh Ranjan
  • How to disable TLSv1.1 and TLSv1.0

    Hello,   I have JBoss 8.2 with jdk1.8.0_85 ,I have only  enabled TLSv1.2 protocal. Third party vendor application where they have enabled all TLS1.0/1.1 which they are going to shutdown TLSv1.0/1.1
    Profile Photo
    last modified by m Prabhakar
  • Problem persisting data using Spring + Hibernate JPA

    Hello, I am getting the following exception when I try to insert a record into mysql. I am using Spring 2.03 with Hibernate JPA. I have pasted my code below and the config files. Any help would be greatly appreciate...
    Profile Photo
    last modified by null null
  • Can we compress cache entries, while putting them into the cluster?

    We are using a hotrod client and the infinispan clustered server which is on its own (standalone). Can we compress cache entries, while putting them into the cluster? What are the different options of compressing? ...
    Profile Photo
    last modified by Udit Mishra
  • Infinispan on Openshift: Hotrod Exception

    Hello,   Infinispan 9.4.11 has been deployed on Openshift 3.11.43 using Infinispan operator using minimal configuration yaml. Practically, default configuration. Two deployments available, one has a 2-node clus...
    Profile Photo
    last modified by Sameer Kaikini
  • Adding class loading lock to JBoss Modules

    We are running into https://bugs.openjdk.java.net/browse/JDK-8232997. In our case this results in a JVM crash when loading custom JFR event classes. The cause seems to be when multiple threads end up calling #defineCl...
    Profile Photo
    last modified by Philippe Marschall
  • BeanIO Reader with Validation

    My bean has annotations for a field to not be null. It works -   2019-11-11 14:38:41.860 jberet-1                   ...
    Profile Photo
    last modified by Richard Moore
  • Benchmark between different versions of Narayana JTA

    Hi, We have an application running using narayana 5.5.32.Final. We recently upgraded it to narayana 5.9.0.Final. We are seeing a 10% performance degradation. Is there any benchmark available for between versions?
    Profile Photo
    last modified by Venkatramanan Swaminathan
  • GC (Allocation Failure)

    Hi, I'm migrating Java 1.7 to 1.8 and JbossEAP6.1 to WildFly14.0.1. we are on AWS and we notice on the logs of the dockers that there are many errors of the type: [GC (Allocation Failure) 1085489K->562034K(1908224K...
    Profile Photo
    last modified by Mohamed Chaabani
  • Database connections locked in JBoss when trying to delete several million records

    Hi, I am using Jboss 7.1.6 with hibernate 5.1.17. I have a scheduler that deletes my older records every day. The problem is the transaction trying to time out after few minutes but i think the cancel transaction gets...
    Profile Photo
    last modified by Deivarayan Azhagappan
  • Messaging-activemq (resource definition)

    Hello there,   I am working on the creation of a new pooled-connection-factory (messaging-activemq) for a specific test I am doing. Within the definition of this resource I can see:   thread-pool-max-size:...
    Profile Photo
    last modified by Marcelo Leite
  • JDBC Authentication with salted-simple-digest-mapper, Invalid base 64 character

    Hi, I use Wildfly 16 and I want to deny the access to my webapp. I configured a jdbc realm with a simple-digest-mapper and it worked, but only if I put the encoded password into the password field.   I want t...
    Profile Photo
    last modified by Nicole Müller