This content has been marked as final.
Show 18 replies
-
15. Re: Eviction redesign
manik Aug 8, 2008 1:31 PM (in response to brian.stansberry)"bstansberry@jboss.com" wrote:
My only other comment on this is to make sure a richly configured cache config can be built up using an IOC framework; i.e. not just by custom java code that knows the rules. And preferably without requiring a lot of advanced IOC usage to do it; just straight injection of pojos into a tree structure. I *think* what you are proposing does that, but it's lunch time, and I'm lazy, so I'm not sure. ;)
I think it does that too. I guess lets get this into Beta1 and give it a whirl with JBoss MC, etc. and that will tell us for sure. :-) -
16. Re: Eviction redesign
mircea.markus Aug 13, 2008 11:40 AM (in response to brian.stansberry)Re: XML configuration, I also propose dropping defaultPolicyClass and defaultEventQueueSize from the eviction element since there is a default element within the eviction element to denote settings for the default region
defaultPolicyClass and defaultEventQueueSize are a convenient way of specifying default values for subregions, i.e. if a region is missing "policyClass" attribute. which is mandatory, then it would take the value from "defaultPolicyClass".
On the other hand, the "" region is a syntactic sugar for "" which doesn't have to do with specifying default values (it might not even be present). -
17. Re: Eviction redesign
mircea.markus Aug 13, 2008 11:54 AM (in response to brian.stansberry)Perhaps a different name for "EvictionPolicy", maybe "EvictionActionPolicy" or something. Using the same term for a different thing will be confusing.
I think that the Policy and Algorithm are a not very meaningful terms for describing the responsibility of these classes; also the terms overlap. What about some other names?EvictionAlgorithm - how are nodes selected for eviction
EvictionOrderingPolicyEvictionPolicy - what happens when nodes are evicted
+1 for EvictionActionPolicy -
18. Re: Eviction redesign
manik Aug 14, 2008 3:16 AM (in response to brian.stansberry)"mircea.markus" wrote:
Perhaps a different name for "EvictionPolicy", maybe "EvictionActionPolicy" or something. Using the same term for a different thing will be confusing.
I think that the Policy and Algorithm are a not very meaningful terms for describing the responsibility of these classes; also the terms overlap. What about some other names?EvictionAlgorithm - how are nodes selected for eviction
EvictionOrderingPolicyEvictionPolicy - what happens when nodes are evicted
+1 for EvictionActionPolicy
I agree that EvictionPolicy is too abstract/too much of a catch-all to be meaningful, but I think EvictionAlgorithm is pretty clear and makes sense. EvictionOrderingPolicy isn't quite right either since the algo doesn't exactly order stuff, but selects stuff for eviction. Perhaps EvictionSelectionAlgorithm if you think EvictionAlgorithm is too general.