1 2 Previous Next 22 Replies Latest reply on Jan 25, 2012 4:36 AM by Michael Heß Go to original post
      • 15. Re: Problem running ejb3 tutorial examples
        eivind hognestad Newbie

        I attached the file classes.txt Jaikiran, and also printed output below:

         

        [INFO] Scanning for projects...
        WAGON_VERSION: 1.0-beta-2
        [INFO] ------------------------------------------------------------------------
        [INFO] Building EJB3.0 Stateless Bean Tutorial
        [INFO]    task-segment: [clean, install]
        [INFO] ------------------------------------------------------------------------
        [INFO] artifact org.apache.maven.plugins:maven-enforcer-plugin: checking for updates from jboss
        [INFO] [clean:clean]
        [INFO] Deleting directory D:\development\tutorials\ejb3\source\stateless\target
        [INFO] [enforcer:enforce {execution: enforce-banned-dependencies}]
        [INFO] [resources:resources]
        [INFO] Using default encoding to copy filtered resources.
        [INFO] [compiler:compile]
        [INFO] Compiling 5 source files to D:\development\tutorials\ejb3\source\stateless\target\classes
        [INFO] [resources:testResources]
        [INFO] Using default encoding to copy filtered resources.
        [INFO] [compiler:testCompile]
        [INFO] No sources to compile
        [INFO] [surefire:test]
        [INFO] No tests to run.
        [INFO] [jar:jar]
        [INFO] Building jar: D:\development\tutorials\ejb3\source\stateless\target\jboss-ejb3-tutorial-stateless.jar
        [INFO] Preparing source:jar
        [WARNING] Removing: jar from forked lifecycle, to prevent recursive invocation.
        [INFO] [enforcer:enforce {execution: enforce-banned-dependencies}]
        [INFO] [source:jar {execution: attach-sources}]
        [INFO] Building jar: D:\development\tutorials\ejb3\source\stateless\target\jboss-ejb3-tutorial-stateless-sources.jar
        [INFO] [enforcer:enforce {execution: enforce-property}]
        [INFO] [jboss-as-control:start {execution: start-jbossas}]
        Starting server "all", with command (start timeout is 120 seconds ):
        C:\java\jdk1.5.0_17\bin\java -cp D:\development\jboss-5.1.0.GA\bin\run.jar;C:\java\jdk1.5.0_17\lib\tools.jar -Xmx512m -Dsun.rmi.dgc.client.gcInterval=3600000 -Xms128m -Dsun.rmi.dgc.server.gcInterval=3600000 -XX:MaxPermSize=256m -Dorg.jboss.resolver.warning=true -Dxb.builder.useUnorderedSequence=true  org.jboss.Main -c all -b localhost -g DefaultPartition
        [INFO] [jboss-as-control:deploy {execution: deploy-tutorial}]
        [INFO] ------------------------------------------------------------------------
        [ERROR] BUILD ERROR
        [INFO] ------------------------------------------------------------------------
        [INFO] Could not deploy D:\development\tutorials\ejb3\source\stateless\target\jboss-ejb3-tutorial-stateless.jar

         

        no protocol: and
        [INFO] ------------------------------------------------------------------------
        [INFO] For more information, run Maven with the -e switch
        [INFO] ------------------------------------------------------------------------
        [INFO] Total time: 9 minutes 37 seconds
        [INFO] Finished at: Thu Jul 29 19:27:07 CEST 2010
        [INFO] Final Memory: 47M/63M
        [INFO] ------------------------------------------------------------------------
        Shutting down server: all
        Writing server thread dump to D:\development\jboss-5.1.0.GA\server\all\log\threadDump.log

        • 16. Re: Problem running ejb3 tutorial examples
          Jaikiran Pai Master

          Hmm, that attached log file is missing the logs that I was looking for. Did you forget to edit the pom.xml to add that additional -verbose:class property:

          <properties>
              <ejb3.tutorial.client>org.jboss.tutorial.stateless.client.Client</ejb3.tutorial.client>
              <jboss.ejb3.tutorial.client.jvmargs>-verbose:class</jboss.ejb3.tutorial.client.jvmargs>
            </properties>
          
          • 17. Re: Problem running ejb3 tutorial examples
            Jaikiran Pai Master

            I think I might know what's wrong. Please post the output of:

             

            echo %PATH%
            

             

            from the command prompt from where you are running this tutorial.

             

            (I hope the issue is what I think it is).

            • 18. Re: Problem running ejb3 tutorial examples
              eivind hognestad Newbie
              D:\development\tutorials\ejb3\source\stateless>echo %PATH%
              C:\java\jdk1.5.0_17\bin;C:\Arquivos de programas\PC Connectivity Solution\;C:\java\javafx\javafx-sdk1.2\bin;C:\java\javafx\javafx-sdk1.2\emulator\bin;C:\Arquivos de programas\PHP\;C:\Arquivos de programas\Windows Resource Kits\Tools\;C:\Arq
              uivos de programas\CSL Arm Toolchain\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Arquivos de programas\Intel\Wireless\Bin\;C:\Arquivos de programas\Arquivos comuns\Lenovo;D:\development\ant\bin;C:\Arquivos de programas\Ar
              quivos comuns\DivX Shared\;C:\Arquivos de programas\IDM Computer Solutions\UltraEdit-32;C:\Arquivos de programas\QuickTime\QTSystem\;D:\development\apache-maven-2.0.9\bin;C:\Sun\jwsdp-2.0\jwsdp-shared\bin

              D:\development\tutorials\ejb3\source\stateless>
              • 19. Re: Problem running ejb3 tutorial examples
                eivind hognestad Newbie

                This is my entire pom.xml in the stateless dir:

                 

                <?xml version="1.0" encoding="UTF-8"?>

                 

                <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">

                 

                  <!-- Model Version -->
                  <modelVersion>4.0.0</modelVersion>

                 

                  <parent>
                    <groupId>org.jboss.ejb3</groupId>
                    <artifactId>jboss-ejb3-tutorial-common</artifactId>
                    <version>1.1.1</version>
                    <relativePath>../common/</relativePath>
                  </parent>

                 

                  <properties>
                    <ejb3.tutorial.client>org.jboss.tutorial.stateless.client.Client</ejb3.tutorial.client>
                    <jboss.ejb3.tutorial.client.jvmargs>-verbose:class</jboss.ejb3.tutorial.client.jvmargs>
                  </properties>

                 


                  <artifactId>jboss-ejb3-tutorial-stateless</artifactId>
                  <version>1.1.1-SNAPSHOT</version>
                  <packaging>jar</packaging>
                  <name>EJB3.0 Stateless Bean Tutorial</name>
                  <url>http://labs.jboss.com/jbossejb3/</url>
                  <description>
                    Tutorial for Stateless EJB 3.0
                  </description>
                 
                  <repositories>
                    <repository>
                      <id>Maven EJB3</id>
                      <url>http://repository.jboss.org/maven2/</url>
                    </repository>
                  </repositories>
                </project>

                • 20. Re: Problem running ejb3 tutorial examples
                  eivind hognestad Newbie

                  Hi Jaikiran, I don't know if you discovered any possible solutions to my problem, but I tried to run the tutorials with ant, and THAT worked, so it seems like there is something wrong with the maven way of running the examples (in my computer that is).

                   

                  Maybe that helps in trying to find the problem?

                   

                  Eivind

                  • 21. Re: Problem running ejb3 tutorial examples
                    Jaikiran Pai Master

                    eivind hognestad wrote:

                     

                    Hi Jaikiran, I don't know if you discovered any possible solutions to my problem, but I tried to run the tutorials with ant, and THAT worked,

                    I thought I had discovered the issue but the output you posted earlier proves otherwise. Yes, running from Ant directly will get you going. Sorry, I thought you already knew that, so I didn't mention it earlier.

                     

                    eivind hognestad wrote:

                     

                    so it seems like there is something wrong with the maven way of running the examples (in my computer that is).

                     

                    Yes, it's definitely Maven (plugin) which is causing the problem. And I do see where it's coming from, the missing part is why it's running into this issue. I would definitely like to get to the bottom of this and before I ask for some more output logs from your system, I would like to (locally) see how the Maven plugin is interacting with the classpath for loading the jars.

                    • 22. Re: Problem running ejb3 tutorial examples
                      Michael Heß Newbie

                      Hi,

                       

                      sorry for grave digging, but I am stuck with the exact same problem right now.

                      Was this issue chased any further, or are the maven examples considered disfunctional right now?

                       

                      bye, Michael

                      1 2 Previous Next