2 Replies Latest reply on Jan 27, 2011 2:34 AM by Dimitris Andreadis

    issue with deploy directory under NFS

    Shawn Tan Newbie

      Hi all,

       

      I've got an issue with "deploy" directory under NFS.

       

      What I extactly did is I moved "deploy" directory out of application folder and made it sharable under NFS mounted from an nfs server on this windows server by a change in jboss-service.xml.

       

      I've tried windows 2003 with SFU 3.0 and windows 2008 with SUA to mount that nfs node.

       

      It can be run very well if I start JBossAS through command-line (not as adminitrator but as normal user), but i can't run as a windows service even i tried run as system/as same user/as administrator.

       

      In log file, i got the error:

       

      2011-01-26 14:46:01,700 WARN  [org.jboss.deployment.scanner.URLDeploymentScanner] Scan URL, caught java.io.FileNotFoundException: Not pointing to a directory, url: file:/N:/test/jboss-4.2.3.GA/server/default/deploy/

       

      I know it's probably not a bug of Jboss AS as long as it can run through command-line and it looks like a privilege issue. But I still can't figure it out after I spent hours of time. I think it would be better to ask people here if someone has experience running jboss with NFS.

       

       

      I'm using jboss-4.2.3 GA

      platform windows 2003 32bit with SFU3.0 /Windows 2008 64bit with SUA

      Java SE6 u23

      NFS protocol version: V3

       

      Many thanks.