1 2 3 Previous Next 34 Replies Latest reply on Feb 3, 2011 5:36 AM by Igor JStarter Go to original post
      • 30. Failure during invoke: Unspecified
        Igor JStarter Novice

        I'm on a workshop too... so I'll try it tomorrow morning...

        You now I have a running server...  no problems expected moving riftsaw to 2.2 ?

         

        So... it's 100%...  RiftSaw2.1 client cannot call .NET web service !

        Need to use a more recent version ...

        • 31. Failure during invoke: Unspecified
          Igor JStarter Novice

          Wow... helloworld works!

           

          On my JBoss5.1 I updated:

          • JBossESB4.8 to JBossESB4.9
          • Riftsaw2.1.0 to RiftSaw2.2.0.Final  (with ws.stack=native & ws.version=3.2.2.GA)

           

          Thanks .... Gary and Marek...

           

          Let's try to call a more complex web service ...

          • 32. Failure during invoke: Unspecified
            Igor JStarter Novice

            Everything works great...

             

            One more question not related to .NET service...

             

            I've got 10 input parameters in my BPEL process and I'm testing it with SoapUI. If I don't set a string parameter value, SoapUI(and probably others) don't sent the parameter in the xml at all.

             

            My question is:  How can I check that parameter in BPEL ???

            if the IP was empty -> log error

            if IP is filled              -> call WS

             

            In my BPEL i have the next condition:

            [CDATA[$input.payload/tns:arrSubscriber/tns:User[round($iterator)]/tns:sMultimediaIP=""

             

            Which doesn't work because it wasn't sent at all ... And it goes to bpel:else where i'm trying to copy the MultimediaIP -> ERROR...

            • 33. Failure during invoke: Unspecified
              Gary Brown Master

              Hi Igor

               

              Igor JStarter wrote:

               

              Everything works great...

               

              One more question not related to .NET service...

               

               

              Should be a new thread then

               

               

              Igor JStarter wrote:

               

              I've got 10 input parameters in my BPEL process and I'm testing it with SoapUI. If I don't set a string parameter value, SoapUI(and probably others) don't sent the parameter in the xml at all.

               

              My question is:  How can I check that parameter in BPEL ???

              if the IP was empty -> log error

              if IP is filled              -> call WS

               

              In my BPEL i have the next condition:

              [CDATA[$input.payload/tns:arrSubscriber/tns:User[round($iterator)]/tns:sMultimediaIP=""

               

              Which doesn't work because it wasn't sent at all ... And it goes to bpel:else where i'm trying to copy the MultimediaIP -> ERROR...

               

              Have you tried the 'exists' xpath2 function? So something like:

               

              [CDATA[exists($input.payload/tns:arrSubscriber/tns:User[round($iterator)]/tns:sMultimediaIP)

               

               

              Regards

              Gary

              1 2 3 Previous Next