1 2 Previous Next 20 Replies Latest reply: Sep 5, 2011 12:53 PM by Tom Jenkinson Go to original post RSS
      • 15. Re: TransactionManager failed to deploy
        Tom Jenkinson Master

        Hi Steve,

         

        Sorry for the late response to this! Glad to hear that you managed to get BlackTie working.

         

        The error message you mentioned regarding the "Error [orb]" is not an issue.

         

        btadmin startup relies on your btconfig.xml for your *server* having machine configuration for a machine with a hostname the same as running the "hostname" command:

         

        [tom@toms-thinkpad ~]$ hostname
        toms-thinkpad

         

        In that example I need:

         

        <MACHINE id="fooapp1" hostname="toms-thinkpad"
        pathToExecutable="${BLACKTIE_HOME}/quickstarts/xatmi/fooapp/server"
        workingDirectory="${BLACKTIE_HOME}/quickstarts/xatmi/fooapp"
        serverId="1" />

         

        Tom

        • 16. Re: TransactionManager failed to deploy
          Steve Venable Newbie

          Added 'ipAddress="{ip}' per Michaels' suggestion and 'btadmin startup' works just fine now.  That attribute wasn't in the btconfig file so didn't know it was available.  Not sure why the value HOSTNAME doesn't have domain (result of shell command 'hostname') yet btadmin was looking for 'hostxyz.domain' - guess that's why it didn't match.

          • 17. Re: TransactionManager failed to deploy
            Steve Venable Newbie

            Similar reply to Tom.

             

            $> hostname

            hostxyz

            $> echo $HOSTNAME

            hostxyz

            $> grep hostname btconfig.xml

                             <MACHINE id="fooapp1" hostname="${HOSTNAME}"

                             <MACHINE id="fooapp2" hostname="${HOSTNAME}"

             

            So why was 'btadmin' looking for 'hostxyz.domain'?

             

            Anyway, per Michael's suggestion, the grep now reports:

            $> grep hostname btconfig.xml

                             <MACHINE id="fooapp1" hostname="${HOSTNAME}" ipAddress="10.65.225.81"

                             <MACHINE id="fooapp2" hostname="${HOSTNAME}" ipAddress="10.65.225.81"

             

            and btadmin finds a match and thus it works

            • 18. Re: TransactionManager failed to deploy
              Michael Musgrove Master

              Blacktie is looking for hostxyz.domain because you haven't configured your host name correctly. The .domain suffix is normally a placeholder. I would check /etc/hosts or /etc/sysconfig/network (I assume you are not using DNS)

              • 19. Re: TransactionManager failed to deploy
                Steve Venable Newbie

                I do not control the host configuration (alas).  /etc/sysconfig/network has 'HOSTNAME=hostxyz' while /etc/hosts has 'hostxyz.domain' as the first (preferred) entry.

                 

                The other way I found that could "fix" this problem was to change the value of envar HOSTNAME (e.g. in 'setenv.sh' use 'export HOSTNAME=`/bin/hostname -f` ') so that it includes the fully qualified name (with domain).

                 

                So yes it too is a local configuration matter; never meant that any of these were actual BT issues but you'll have to admit there isn't much documentation that I can reference

                • 20. Re: TransactionManager failed to deploy
                  Tom Jenkinson Master

                  Steve Venable wrote:

                   

                  So yes it too is a local configuration matter; never meant that any of these were actual BT issues but you'll have to admit there isn't much documentation that I can reference

                   

                  Hi Steve,

                   

                  The beauty of open source is we are very happy to have you help us fix this

                   

                  If you find you like what you see with BlackTie (and who wouldn't), I am very happy to give you commit rights to the repo so you would be able to help us with filling out the docs (or even code).

                   

                  Please do let us know either way, and do raise further issues here on the forum or over in Jira (preferably, if its a bug or missing documentation). For example, if you spot there is something in our docs/scripts, it would be perfect if you could jira it over at: https://jira.jboss.org/jira/browse/BLACKTIE

                   

                  Thanks,

                  Tom

                  1 2 Previous Next