1 Reply Latest reply: Oct 11, 2011 1:10 PM by Amber Jboss RSS

    DEPLOYMENTS MISSING DEPENDENCIES

    Roxana Quiroga Sollinger Newbie

      Hello,

       

      Can anyone help me out with the following issue?  I'm working with:

      - JBoss AS 6 Final


      When I run the application I'm getting the following error:

      DEPLOYMENTS MISSING DEPENDENCIES:

        Deployment "jboss-switchboard:appName=wsrgiva,module=wsrgiva" is missing the following dependencies:

          Dependency "jboss.jca:name=internal/wsrgiva/wsrgiva/env/jdbc/wsrgiva,service=DataSourceBinding" (should be in state "Installed", but is actually

      in state "** NOT FOUND Depends on 'jboss.jca:name=internal/wsrgiva/wsrgiva/env/jdbc/wsrgiva,service=DataSourceBinding',whenRequired=MapControllerSt

      ateModel$ControllerStateWrapper@1ab5957{Installed},dependentState=MapControllerStateModel$ControllerStateWrapper@1ab5957{Installed} **")

        Deployment "jboss.web.deployment:war=/wsrgiva" is missing the following dependencies:

          Dependency "jboss-switchboard:appName=wsrgiva,module=wsrgiva" (should be in state "Installed", but is actually in state "Deploy")

       

      DEPLOYMENTS IN ERROR:

        Deployment "jboss.jca:name=internal/wsrgiva/wsrgiva/env/jdbc/wsrgiva,service=DataSourceBinding" is in error due to the following reason(s): ** NOT

      FOUND Depends on 'jboss.jca:name=internal/wsrgiva/wsrgiva/env/jdbc/wsrgiva,service=DataSourceBinding',whenRequired=MapControllerStateModel$Controll

      erStateWrapper@1ab5957{Installed},dependentState=MapControllerStateModel$ControllerStateWrapper@1ab5957{Installed} **

       

          at org.jboss.deployers.plugins.deployers.DeployersImpl.checkComplete(DeployersImpl.java:1228) [:2.2.0.GA]

          at org.jboss.deployers.plugins.main.MainDeployerImpl.checkComplete(MainDeployerImpl.java:905) [:2.2.0.GA]

          at org.jboss.system.server.profileservice.deployers.MainDeployerPlugin.checkComplete(MainDeployerPlugin.java:87) [:6.0.0.Final]

          at org.jboss.profileservice.deployment.ProfileDeployerPluginRegistry.checkAllComplete(ProfileDeployerPluginRegistry.java:107) [:0.2.2]

          at org.jboss.system.server.profileservice.bootstrap.BasicProfileServiceBootstrap.start(BasicProfileServiceBootstrap.java:135) [:6.0.0.Final]

          at org.jboss.system.server.profileservice.bootstrap.BasicProfileServiceBootstrap.start(BasicProfileServiceBootstrap.java:56) [:6.0.0.Final]

          at org.jboss.bootstrap.impl.base.server.AbstractServer.startBootstraps(AbstractServer.java:827) [jboss-bootstrap-impl-base.jar:2.1.0-alpha-5]

          at org.jboss.bootstrap.impl.base.server.AbstractServer$StartServerTask.run(AbstractServer.java:417) [jboss-bootstrap-impl-base.jar:2.1.0-alpha-5]

          at java.lang.Thread.run(Thread.java:732) [:1.7.0-ea]

       

      The error is correct because I didn't define the datasource as "internal/wsrgiva/wsrgiva/env/jdbc/wsrgiva", but I do not  understand why I'm getting this datasource when it should be another.

       

      The configuration regarding the datasource is the following:

       

      Inside the web.xml I added:

          <resource-ref>

              <description>datasource</description>

              <res-ref-name>oracleDS</res-ref-name>

              <res-type>javax.sql.DataSource</res-type>

              <res-auth>Application</res-auth>

          </resource-ref>

       

       

      Inside the jboss-web.xml I added:

          <resource-ref>

              <res-ref-name>oracleDS</res-ref-name>

              <res-type>javax.sql.DataSource</res-type>

              <jndi-name>java:jdbc/oracle</jndi-name>

          </resource-ref>

       

      In $JBOSS_HOME/server/default/deploy I add the oracle-ds.xml with the following configuration:

      <datasources>

        <local-tx-datasource>

          <jndi-name>jdbc/oracle</jndi-name>

          <connection-url>jdbc:oracle:thin:@99.99.99.95:1521:TEST</connection-url>

          <driver-class>oracle.jdbc.driver.OracleDriver</driver-class>

          <user-name>XXXX</user-name>

          <password>XXXX</password>

          <exception-sorter-class-name>org.jboss.resource.adapter.jdbc.vendor.OracleExceptionSorter</exception-sorter-class-name>

          <metadata>

             <type-mapping>Oracle9i</type-mapping>

          </metadata>

        </local-tx-datasource>

      </datasources>

       

       

      The error says that the dependency "jboss.jca:name=internal/oracle/oracle/env/jdbc/oracle,service=DataSourceBinding" is not found which is correct because when the AS starts I get the following lines:

       

      16:14:46,218 INFO  [ConnectionFactoryBindingService] Bound ConnectionManager 'jboss.jca:service=DataSourceBinding,name=jdbc/oracle' to JNDI name 'java:jdbc/oracle'

       

      As I read in other posts, they recommend to remove the resource-ref from the web.xml and everything works fine, but when I add the annotation @Resource(name="java:jdbc/oracle") the same error appears.