1 2 3 Previous Next 33 Replies Latest reply on Nov 7, 2011 3:59 PM by Ronnie Downing Go to original post
      • 30. Re: problem about running jbpm5
        Billy Bartels Newbie

        Kris,

         

        I found out that after I removed file "jndi.properties", which contains "java.naming.factory.initial=bitronix.tm.jndi.BitronixInitialContextFactory", it started to work! Thanks so much for providing the instructions!

         

        Now I've got a new issue -- how can I have a fresh installation? I tried to delete the JBoss server folder and the H2 database files (test.h2.db, etc.). After a new installation, I still can see all the previous processes in jbpm-console.

         

        I searched the former related posts and didn't find how to do it. Someone said doing it in code:

        GraphSession graphSession=jbpmContext.getGraphSession();

        ProcessDefinition processDefinition=graphSession.getProcessDefinition(id);

        graphSession.deleteProcessDefinition(processDefinition);

         

        I didn't try it as I'm not sure if it's the way to go. What would be the best way to wipe out all the installed processes as well as the database so as to have a clean installation again?

         

        Thanks!

        • 31. Re: problem about running jbpm5
          Michael Wagner Newbie

          Hi,

           

          the same here. While playing with the tools I lost the process "evaluation" and dont see it any more within the console. "ant clean.demo" followed by a "ant install.demo" does not help. I still se no process in the console. So I delete the whole installer directory again, copied my backup and started "ant install.demo" again. Now the process "evaluation" is there again.

          Please tell me, where exactly this processes seen in the BPM Console are stored. It cant be in the DB, since the "clean" task deletes the repository directory.

           

          Michael

          • 32. Re: problem about running jbpm5
            Chris Melas Apprentice

            Hello,

            The process evaluation has the following three parts,

            1. The process file (evaluation.bpmn) located inside the installer directory under the folder sample, within the resources folder.

            2. The process image file (com.sample.evaluation.png) located in the jbpm-gwt-graph-5.1xx.jar which is inside the jbpm-gwt-console-server war file

            3. The process human task files (com.sample.evaluation.ftl and Performance Evaluation.ftl) which are located in the jbpm-gwt-form-5.1xx.jar which is also inside the jbpm-gwt-console-server war file

            • 33. Re: problem about running jbpm5
              Ronnie Downing Newbie

              I'm having a very difficult time deploying a process to the server. Like many on this post or others, I was able to run a process standalone without issue, but deploying to the server (5.1) continues to be a challenge. I even made a copy of evaluation and tried to deploy that via guvnor and was getting complaints about the xml schema.

               

              What I would like to be able to do is take a .bpmn file that has some script tasks (this rules out using the guvnor builder, I believe) and deploy it to the server. I don't really need a process diagram, although I have achieved this (in-line in the .bpmn file) via reverse engineering using the eclipse plugin. I'd like to do this without the .png file that one of Kris' videos shows. I assume the .png file isn't required for deployment(?)

               

              Anyhow, I would appreciate some direction. It appears Billy has had success but only after doing more than I would expect him to do. Meanwhile I will continue to look into what I'm doing wrong.

               

              Thanks!

              1 2 3 Previous Next