1 2 3 Previous Next 31 Replies Latest reply: Mar 27, 2012 4:43 PM by John Liptak Go to original post RSS
      • 15. Re: JBoss AS7 and activemq connector
        jaikiran pai Master

        Ed Keen wrote:

         

        OK, I have posted this as an issue to the ActiveMQ forum mailing list:  http://activemq.2283324.n4.nabble.com/ActiveMQEndpointWorker-run-method-cannot-be-synchronized-td4330542.html

        That post/mail still hasn't been accepted in the mailing list (probably because it was done via nabble?). You might want to bring it to their attention some other way (maybe not use nabble and register to the list and post the message?).

        • 16. Re: JBoss AS7 and activemq connector
          Ed Keen Newbie

          I registered for the ActiveMQ mailing list several days ago and still have not been accepted to participate in it.  If someone else already belongs to the mailing list, please post the above nabble posting directly to the mailing list.

           

          Thanks,

          Ed

          • 17. Re: JBoss AS7 and activemq connector
            Ed Keen Newbie

            Finally got added to the ActiveMQ mailing list.  Here is the posting that has been accepted:  http://activemq.2283324.n4.nabble.com/ActiveMQEndpointWorker-run-method-cannot-be-synchronized-td4352334.html

            • 18. Re: JBoss AS7 and activemq connector
              Thorsten Hoeger Newbie

              Hi!

               

              I raised a JIRA issue with the ActiveMQ guys to have this bug fixed before the 5.6 release.

               

              https://issues.apache.org/jira/browse/AMQ-3748

               

              Regards,

              Thorsten

               

              EDIT: Ticket is resolved, so this is working now.

              • 19. Re: JBoss AS7 and activemq connector
                Kumaran Raj Newbie

                We are using mdb with Jboss6. But when migrating to Jboss7 I am having a lot of problems.

                 

                I copied the same activemq-ra.rar which I used with Jboss6 in to the standalone/deploy folder of Jboss7

                 

                But I am gretting the following message when starting the jboss

                service jboss.ra.activemq-ra (missing) dependents: ....................................

                 

                please help me to sortout this problem.

                • 20. Re: JBoss AS7 and activemq connector
                  Kumaran Raj Newbie

                  here I have done the activemq source code fix specified here https://community.jboss.org/message/624774#624774

                  • 21. Re: JBoss AS7 and activemq connector
                    Thorsten Hoeger Newbie

                    In this post I uploaded my configuration which works perfectly

                     

                    https://community.jboss.org/message/723928#723928

                    • 22. Re: JBoss AS7 and activemq connector
                      Kumaran Raj Newbie

                      Thanks for your replay. I used the attached activemq-ra-5.4.rar , but I am getting

                       

                      Caused by: org.jboss.msc.service.DuplicateServiceException: Service jboss.connector.connection-factory.java:jboss/activemq/QueueConnection is already registered

                       

                      should I fix the activemq sourcecode here?

                      • 23. Re: JBoss AS7 and activemq connector
                        Kumaran Raj Newbie

                        I extracted the rar and deployed then it is deployed.

                         

                        But when deploying my ear file I am getting the same error I got previously.

                         

                        service jboss.naming.context.java.jboss.java:activemq.QueueConnectionFactory (missing)

                        service jboss.ra."activemq-rar-5.4" (missing) dependents:

                         

                        Should I do any change on my MDB configs? or anotation jndi name etc??

                        • 24. Re: JBoss AS7 and activemq connector
                          Jesper Pedersen Master

                          You are hitting JBJCA-766, which is fixed in 1.0.10-SNAPSHOT. Watch AS7-4188

                          • 25. Re: JBoss AS7 and activemq connector
                            Jean-Pierre RIO Newbie

                            Hi all,

                            Got it working with an oob amq rar (5.6-SNAPSHOT) in 7.1.1.Final (standalone-full profile) !

                            Just drop the rar (zipped) in "deployments" (by default, the adapter points to a broker on localhost:61616). Deploy a mdb like this one :

                             

                            @MessageDriven(name = "MDB", activationConfig = {

                                                @ActivationConfigProperty(propertyName = "destinationType", propertyValue = "javax.jms.Queue"),

                                                @ActivationConfigProperty(propertyName = "destination", propertyValue = "zeQueue"),

                                                @ActivationConfigProperty(propertyName = "acknowledgeMode", propertyValue = "Auto-acknowledge")

                            })

                             

                             

                            @ResourceAdapter("activemq-rar-5.6-SNAPSHOT.rar")

                            public class ActiveMQMDB implements MessageListener {

                             

                                  public void onMessage(Message message) {

                                          System.out.println(((TextMessage)message));

                                  }

                             

                            Start a broker on your box. Now you can go to the broker console (http://localhost:8161/admin), click on "Queues", and send a message to "zeQueue". You should see a log in the jboss console like this :

                             

                            16:51:06,687 INFO  [stdout] (default-short-running-threads-threads - 4) ActiveMQTextMessage {commandId = 5, responseRequired = false, messageId = ID:s-activemq-qua-42810-1331912897530-1:4:1:

                            1:1, originalDestination = null, originalTransactionId = null, producerId = ID:s-activemq-qua-42810-1331912897530-1:4:1:1, destination = queue://zeQueue, transactionId = null, expiration = 0

                            , timestamp = 1331913066386, arrival = 0, brokerInTime = 1331913066387, brokerOutTime = 1331913066403, correlationId = , replyTo = null, persistent = false, type = , priority = 0, groupID =

                            null, groupSequence = 0, targetConsumerId = null, compressed = false, userID = null, content = null, marshalledProperties = null, dataStructure = null, redeliveryCounter = 0, size = 0, prope

                            rties = null, readOnlyProperties = true, readOnlyBody = true, droppable = false, text = Enter some text here for the message body...}

                             

                            You can configure the broker url (and user/pwd) in jboss console in Profile>Resources Adapters>activemq-rar-5.6-SNAPSHOT>serverUrl (by the way, i had to remove/add the property, did not find a way to modify it )

                             

                            JP

                            • 26. Re: JBoss AS7 and activemq connector
                              John Liptak Newbie

                              Perhaps I'm getting a different version from my snapshot, but I get an error.

                               

                              1. If I don't use the ironjacamer directions specified here https://community.jboss.org/message/723928#723928 I don't get the broker to start up (it deploys but does not start).  I'm using the ra.xml and ironjacamer.xml in that thread.

                               

                              2. Regardless of what I do in step #1, I get the following error when I deploy the MDB:

                              10:59:34,260 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-4) MSC00001: Failed to start service jboss.deployment.unit."JbossMDB.jar".PARSE: org.jboss.msc.service.StartException in service jboss.deployment.unit."JbossMDB.jar".PARSE: Failed to process phase PARSE of deployment "JbossMDB.jar"

                              at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:119) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

                              at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                              at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                              at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.7.0_03]

                              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.7.0_03]

                              at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_03]

                              Caused by: org.jboss.msc.service.ServiceNotFoundException: Service service jboss.ejb.default-resource-adapter-name-service not found

                              at org.jboss.msc.service.ServiceContainerImpl.getRequiredService(ServiceContainerImpl.java:447) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                              at org.jboss.as.ejb3.deployment.processors.MessageDrivenComponentDescriptionFactory.getDefaultResourceAdapterName(MessageDrivenComponentDescriptionFactory.java:273)

                              at org.jboss.as.ejb3.deployment.processors.MessageDrivenComponentDescriptionFactory.processMessageBeans(MessageDrivenComponentDescriptionFactory.java:153)

                              at org.jboss.as.ejb3.deployment.processors.MessageDrivenComponentDescriptionFactory.processAnnotations(MessageDrivenComponentDescriptionFactory.java:81)

                              at org.jboss.as.ejb3.deployment.processors.AnnotatedEJBComponentDescriptionDeploymentUnitProcessor.processAnnotations(AnnotatedEJBComponentDescriptionDeploymentUnitProcessor.java:58)

                              at org.jboss.as.ejb3.deployment.processors.AbstractDeploymentUnitProcessor.deploy(AbstractDeploymentUnitProcessor.java:81) at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:113) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final] ... 5 more

                               

                              I'm not sure how the jboss.ejb.default-resource-adapter-name-service isn't deployed since the rar deployed correctly.

                               

                              I'm using 7.1.1-Final and activemq 5.6 snapshot from yesterday.  Any ideas?

                               

                              John

                              • 27. Re: JBoss AS7 and activemq connector
                                Jean-Pierre RIO Newbie

                                John,

                                Can you post the code of your mdb ?

                                • 28. Re: JBoss AS7 and activemq connector
                                  Kumaran Raj Newbie

                                  I found that when addding the following line this error disappeared

                                   

                                  <subsystem xmlns="urn:jboss:domain:ejb3:1.2">

                                            <mdb>

                                                  <resource-adapter-ref resource-adapter-name="activemq-rar-5.4"/>

                                                  <bean-instance-pool-ref pool-name="mdb-strict-max-pool"/>

                                              </mdb>

                                  ------------------

                                  ----------------

                                  • 29. Re: JBoss AS7 and activemq connector
                                    John Liptak Newbie

                                    package com.ctl.jboss.mdb;
                                    
                                    import javax.jms.Message;
                                    import javax.jms.MessageListener;
                                    import javax.jms.TextMessage;
                                    import javax.ejb.MessageDriven;
                                    import javax.ejb.*;
                                    
                                    import org.jboss.ejb3.annotation.ResourceAdapter;
                                    
                                    
                                    @MessageDriven(name = "MDB", activationConfig = {
                                            @ActivationConfigProperty(propertyName = "destinationType", propertyValue = "javax.jms.Queue"),
                                            @ActivationConfigProperty(propertyName = "destination", propertyValue = "zeQueue"),
                                            @ActivationConfigProperty(propertyName = "acknowledgeMode", propertyValue = "Auto-acknowledge")
                                    }) 
                                    @ResourceAdapter("activemq-rar.rar")
                                    public class TestEjb implements MessageListener {
                                    
                                         @Override
                                         public void onMessage(Message message) {
                                              System.out.println(((TextMessage)message));
                                    
                                    
                                         }
                                    
                                    }