4 Replies Latest reply: Feb 13, 2012 4:20 AM by Dmitri Voronov RSS

    Third party libraries are not loaded

    Dmitri Voronov Novice

      Hi all,

       

      I have a JCA resource adapter which is using third party libraries. RA implamentation' JAR as well as thisrd party JARs are packaged into RAR file, deployed in <AS7>/standalone/deployments directory. But on bootstrapping of RA the thirdparty classes cannot be found.

      java.lang.ClassNotFoundException: com.iona.corba.art.artimpl.ORBImpl from [Module "org.jboss.as.connector:main" from local module loader @19eda2c (roots: C:\eplatform\jboss\AS-7.1\modules)]
      

      whereby com.iona.corba.art.artimpl.ORBImpl is in a jar on the root of RAR.

       

      Did anybody face a similar problem?

      Does anybody have a dummy sample RA for testing?

       

      I think it's a bug.

        • 1. Re: Third party libraries are not loaded
          Jesper Pedersen Master

          Seriously ?

           

          There are plenty of test cases in the AS7 test suite, and forum threads about deployments - WebSphereMQ, ActiveMQ, ...

           

          You need to actually do some work yourself

           

          • Try the latest nightly snapshot
          • Verify that your deployment is correctly setup
          • That your archive comforms to the JCA standard
          • Look for differences against successful deployments; why not start with deploying ActiveMQ ?
          • Deploy on IronJacamar/Standalone
          • Actually post your full configuration (standalone.xml)
          • Show the content of your archive
          • Read the documentation about resource adapters in AS7
          • Read the documentation about classloading in AS7
          • Check *ALL* classloading done within the resource adapter

           

          Saying "It doesn't work" isn't going to help you.

           

          If you don't want to go through the above, then buy a subscription and have support help you.

          • 2. Re: Third party libraries are not loaded
            Dmitri Voronov Novice

            Please believe what I did is not only putting RAR to deployments directory and said "it doesn't work"

             

            Let me see what I've already done:

            • Try the latest nightly snapshot

            I didn't

             

            • Verify that your deployment is correctly setup

            I did: by means of ironjacamar-1.1.0.Alpha5\doc\as>rar-info.bat and validator.bat:

            C:\OS\ironjacamar-1.1.0.Alpha5\doc\validator>validator.bat jp-infra-corba-resourceadapter.rar
            
            C:\OS\ironjacamar-1.1.0.Alpha5\doc\validator>java -classpath ..\..\lib\ironjacamar-validator-cli.jar;..\..\lib\ironjacamar-common-spi.jar;..\..\lib\jb
            oss-logging.jar;..\..\lib\jboss-common-core.jar;..\..\lib\ironjacamar-spec-api.jar;..\..\lib\papaki-core.jar;..\..\lib\javassist.jar;..\..\lib\ironjac
            amar-common-impl.jar;..\..\lib\ironjacamar-common-impl-papaki.jar;..\..\lib\ironjacamar-common-api.jar;..\..\lib\ironjacamar-validator.jar org.jboss.j
            ca.validator.cli.Main jp-infra-corba-resourceadapter.rar
            Validation sucessful
            

            looks good.

            • That your archive comforms to the JCA standard

            It is, at least to the documentation http://docs.jboss.org/ironjacamar/userguide/1.0/en-US/html_single/#packagingrequirements. Moreover it was runing well on JBoss 4.2.3

            • Look for differences against successful deployments; why not start with deploying ActiveMQ ?

            I'm appreciate every deployable RA sample. Unfortunately I've never heard about that. Please write where can I find it?

            • Deploy on IronJacamar/Standalone

            Tried:

             

             

            15:39:52,069 WARNUNG [Fungal] Deployment file:/C:/OS/ironjacamar-1.1.0.Alpha5/deploy/jp-infra-corba-resourceadapter.rar failed: com.github.fungal.spi.
            deployers.DeployException: Deployment file:/C:/OS/ironjacamar-1.1.0.Alpha5/deploy/jp-infra-corba-resourceadapter.rar failed
                    at org.jboss.jca.deployers.fungal.RAActivator.deploy(RAActivator.java:560)
                    at org.jboss.jca.deployers.fungal.RAActivator.postDeploy(RAActivator.java:180)
                    at com.github.fungal.impl.KernelImpl.postDeploy(KernelImpl.java:1554)
                    at com.github.fungal.impl.KernelImpl.startup(KernelImpl.java:594)
                    at org.jboss.jca.sjc.Main.boot(Main.java:112)
                    at org.jboss.jca.sjc.Main.main(Main.java:289)
            Caused by: java.io.IOException: Could not delete C:\OS\ironjacamar-1.1.0.Alpha5\tmp\jp-infra-corba-resourceadapter.rar\art-1.3.jar
                    at com.github.fungal.api.util.FileUtil.delete(FileUtil.java:378)
                    at com.github.fungal.api.util.FileUtil.extract(FileUtil.java:179)
                    at org.jboss.jca.deployers.fungal.RAActivator.deploy(RAActivator.java:495)
                    ... 5 more
            
            15:39:52,089 INFO  [Main] Server started in 10406ms
            

            ?

            • Read the documentation about resource adapters in AS7
            • Read the documentation about classloading in AS7

            If you means these then yes:

             

            • Check *ALL* classloading done within the resource adapter

            I would realy like to know how. I spent hours on debugging, but didn't notice that modules CL "org.jboss.as.connector" has any hints to load classes from RAR except those of (managed) connection factory.

            • 3. Re: Third party libraries are not loaded
              Dmitri Voronov Novice

              Jesper Pedersen wrote:

              • Look for differences against successful deployments; why not start with deploying ActiveMQ ?

              Regarding Active MQ what I found are two "Not Answered" forum topics.

              https://community.jboss.org/thread/172319

              https://community.jboss.org/message/648940#648940

               

              Could you provide any successful deployments of ActiveMQ?

              • 4. Re: Third party libraries are not loaded
                Dmitri Voronov Novice

                Jesper Pedersen wrote:

                 

                If you don't want to go through the above, then buy a subscription and have support help you.

                BTW we have support subscription, we are even included into the EA program. That's why we are trying to test JBoss AS 7.