7 Replies Latest reply: Apr 23, 2012 6:11 AM by tono jacob RSS

    EJB Deployment Issue

    tono jacob Newbie

      Hello All,

       

      Following is the configuration

       

      Java: jdk1.5.0_21

      JBOSS: jboss-4.2.2.GA

       

      I have a ejb(with webservice) that gets deployed on my personal system without any issues but when deploying the server(where it is required), the deployment fails. The configuration is same across the systems being used. To confirm whether its application install, I copied over the entire Jboss install from my system to the server, but still the ejb did not get deployed.

       

      My System Log

       

      2012-04-17 11:03:44,915 DEBUG [org.jboss.deployment.MainDeployer] found 1 subpackages of file:/D:/Tools/jboss-4.2.2.GA/server/default/deploy/Documents.ear

      2012-04-17 11:03:44,915 DEBUG [org.jboss.deployment.MainDeployer] Starting deployment (init step) of package at: file:/D:/Tools/jboss-4.2.2.GA/server/default/tmp/deploy/tmp3907885556060189984Documents.ear-contents/Documents_EJB.jar

      2012-04-17 11:03:44,960 DEBUG [org.jboss.deployment.MainDeployer] using deployer MBeanProxyExt[jboss.ejb:service=EJBDeployer]

      2012-04-17 11:03:44,960 DEBUG [org.jboss.ejb.EJBDeployer] init, Documents_EJB.jar

      2012-04-17 11:03:44,983 DEBUG [org.jboss.ejb.EJBDeployer] looking for nested deployments in : file:/D:/Tools/jboss-4.2.2.GA/server/default/tmp/deploy/tmp3907885556060189984Documents.ear-contents/Documents_EJB.jar

      2012-04-17 11:03:44,986 DEBUG [org.jboss.mx.loading.RepositoryClassLoader] Added url: file:/D:/Tools/jboss-4.2.2.GA/server/default/tmp/deploy/tmp3907885556060189984Documents.ear-contents/Documents_EJB.jar, to ucl: org.jboss.mx.loading.UnifiedClassLoader3@1ce56f8{ url=file:/D:/Tools/jboss-4.2.2.GA/server/default/tmp/deploy/tmp3907885556060189984Documents.ear ,addedOrder=47}

       

       

       

      Server Log

       

      2012-04-17 11:13:01,086 DEBUG [org.jboss.deployment.MainDeployer] found 1 subpackages of file:/C:/jboss-4.2.2.GA_Tono/server/default/deploy/Documents.ear

      2012-04-17 11:13:01,086 DEBUG [org.jboss.deployment.MainDeployer] Starting deployment (init step) of package at: file:/C:/jboss-4.2.2.GA_Tono/server/default/tmp/deploy/tmp1476459450364089724Documents.ear-contents/Documents_EJB.jar

      2012-04-17 11:13:01,101 DEBUG [org.jboss.deployment.JARDeployer] Found entry: 'META-INF/ejb-jar.xml', matching: 'ejb-jar.xml', rejecting jar

      2012-04-17 11:13:01,101 DEBUG [org.jboss.deployment.MainDeployer] No deployer found for url: file:/C:/jboss-4.2.2.GA_Tono/server/default/tmp/deploy/tmp1476459450364089724Documents.ear-contents/Documents_EJB.jar

      2012-04-17 11:13:01,101 DEBUG [org.jboss.deployment.MainDeployer] deployment waiting for deployer: file:/C:/jboss-4.2.2.GA_Tono/server/default/tmp/deploy/tmp1476459450364089724Documents.ear-contents/Documents_EJB.jar

      2012-04-17 11:13:01,101 DEBUG [org.jboss.deployment.MainDeployer] Watching new file: file:/C:/jboss-4.2.2.GA_Tono/server/default/deploy/Documents.ear

      2012-04-17 11:13:01,101 DEBUG [org.jboss.deployment.MainDeployer] create step for deployment file:/C:/jboss-4.2.2.GA_Tono/server/default/deploy/Documents.ear

      2012-04-17 11:13:01,101 DEBUG [org.jboss.deployment.MainDeployer] create step for deployment file:/C:/jboss-4.2.2.GA_Tono/server/default/tmp/deploy/tmp1476459450364089724Documents.ear-contents/Documents_EJB.jar

      2012-04-17 11:13:01,101 DEBUG [org.jboss.deployment.MainDeployer] Still no deployer for package in create step: Documents_EJB.jar

      2012-04-17 11:13:01,101 DEBUG [org.jboss.system.ServiceController] Creating service jboss.j2ee:service=EARDeployment,url='Documents.ear'

      2012-04-17 11:13:01,101 DEBUG [org.jboss.deployment.EARDeployment] Creating jboss.j2ee:service=EARDeployment,url='Documents.ear'

      2012-04-17 11:13:01,101 DEBUG [org.jboss.deployment.EARDeployment] Created jboss.j2ee:service=EARDeployment,url='Documents.ear'

      2012-04-17 11:13:01,101 DEBUG [org.jboss.system.ServiceController] Creating dependent components for: jboss.j2ee:service=EARDeployment,url='Documents.ear' dependents are: []

      2012-04-17 11:13:01,101 DEBUG [org.jboss.deployment.MainDeployer] Done with create step of deploying Documents.ear

      2012-04-17 11:13:01,101 DEBUG [org.jboss.deployment.MainDeployer] Begin deployment start file:/C:/jboss-4.2.2.GA_Tono/server/default/deploy/Documents.ear

      2012-04-17 11:13:01,101 DEBUG [org.jboss.deployment.MainDeployer] Begin deployment start file:/C:/jboss-4.2.2.GA_Tono/server/default/tmp/deploy/tmp1476459450364089724Documents.ear-contents/Documents_EJB.jar

      2012-04-17 11:13:01,101 DEBUG [org.jboss.deployment.MainDeployer] Still no deployer for package in start step: Documents_EJB.jar

      2012-04-17 11:13:01,101 DEBUG [org.jboss.system.ServiceController] starting service jboss.j2ee:service=EARDeployment,url='Documents.ear'

      2012-04-17 11:13:01,101 DEBUG [org.jboss.deployment.EARDeployment] Starting jboss.j2ee:service=EARDeployment,url='Documents.ear'

      2012-04-17 11:13:01,101 DEBUG [org.jboss.deployment.EARDeployment] Started jboss.j2ee:service=EARDeployment,url='Documents.ear'

      2012-04-17 11:13:01,101 DEBUG [org.jboss.system.ServiceController] Starting dependent components for: jboss.j2ee:service=EARDeployment,url='Documents.ear' dependent components: []

      2012-04-17 11:13:01,101 INFO  [org.jboss.deployment.EARDeployer] Started J2EE application: file:/C:/jboss-4.2.2.GA_Tono/server/default/deploy/Documents.ear

      2012-04-17 11:13:01,101 DEBUG [org.jboss.deployment.MainDeployer] End deployment start on package: Documents.ear

      2012-04-17 11:13:01,101 DEBUG [org.jboss.deployment.MainDeployer] Deployed package: file:/C:/jboss-4.2.2.GA_Tono/server/default/deploy/Documents.ear

      2012-04-17 11:13:01,101 DEBUG [org.jboss.deployment.scanner.URLDeploymentScanner] Watch URL for: file:/C:/jboss-4.2.2.GA_Tono/server/default/deploy/Documents.ear -> file:/C:/jboss-4.2.2.GA_Tono/server/default/deploy/Documents.ear

      2012-04-17 11:13:01,101 ERROR [org.jboss.deployment.scanner.URLDeploymentScanner] Incomplete Deployment listing:

       

       

      Any help in understanding the issue would be great

       

      Regards


        • 1. Re: EJB Deployment Issue
          Stephen Coy Master

          Can you confirm that your server contains the file C:/jboss-4.2.2.GA_Tono/server/default/deploy/ejb-deployer.xml and that it has not been changed from the default distribution?

           

          Additionally, can you confirm that the server starts up cleanly with no errors? (Check the logs)

          • 2. Re: EJB Deployment Issue
            tono jacob Newbie

            Hello Stephen,

             

            As you would note in the original issue, the ejb gets deployed on my system but not on the server intended to be. To zero down the issue, I copied over my entire JBoss install over to the server and tried to deploy in the copied install. So ideally everything is same in my system and server(except that the environments are different, mine being a personal system). But still the deploy failed.

             

            So the log that is there is about the issue that I identified where the EAR is success in my system but fails in the server.

             

            2012-04-17 11:13:01,101 DEBUG [org.jboss.deployment.JARDeployer] Found entry: 'META-INF/ejb-jar.xml', matching: 'ejb-jar.xml', rejecting jar

            2012-04-17 11:13:01,101 DEBUG [org.jboss.deployment.MainDeployer] No deployer found for url: file:/C:/jboss-4.2.2.GA_Tono/server/default/tmp/deploy/tmp1476459450364089724Documents.ear-contents/Documents_EJB.jar

            • 3. Re: EJB Deployment Issue
              Stephen Coy Master

              I'm trying to work out why you have no EJB Deployer. Please zip up the server.log and add it as an attachment.

              • 4. Re: EJB Deployment Issue
                tono jacob Newbie

                Hello Stephen,

                 

                Please find the zip.

                • 5. Re: EJB Deployment Issue
                  Stephen Coy Master

                  You have a TCP port conflict on port 8083. This prevents the WebService service from starting, which in turn prevents the EJB Deployer service from starting.

                  • 6. Re: EJB Deployment Issue
                    tono jacob Newbie

                    Thanks Stephen,

                     

                    I figured it out when trying to free out all the port issues. Still the ejb is not getting deployed. Thanks for all your help :-) .

                    I would keep you posted on the outcome

                    • 7. Re: EJB Deployment Issue
                      tono jacob Newbie

                      Hello Stephen,

                       

                      Finally started the application. The issue was all around ports. Even after shutting the app server, the ports still were in listening mode. As such I released all the ports which made all the deployment to start working. There were some issue around messaging for which I deleted the localdb files. Thanks for all the help.

                       

                      Regards