13 Replies Latest reply: Jul 3, 2014 11:39 AM by Tom Jenkinson RSS

    btadmin startup checking blocked with blacktie 5.0.2

    emmanuel petremann Newbie

      Hi,

       

      I have a bug with the 5.0.2 final version with the little quickstart xatmi/fooapp.

       

      I seems blocked when is checking host (I wait a long time)  :

      Capture.JPG

       

      If I change only %BLACKTIE_HOME% in 5.0.0.final and redeploy the admin service with 5.0.0.final version it's OK.

       

      Have you got an idea ?

       

      Best regards

       

      Emmanuel

        • 1. Re: btadmin startup checking blocked with blacktie 5.0.2
          Amos Feng Newbie

          Hi,

           

          which version of the jboss-as you used and can you provide the server.log ? Do you have any other blacktie.log ?

           

          Thanks,

          Amos

          • 2. Re: Re: btadmin startup checking blocked with blacktie 5.0.2
            emmanuel petremann Newbie

            Hi Amos,

             

            I use WildFly 8.0.0 final

            I send all logs I have.

             

            The error of timer in server.log is on 5.0.0 and 5.0.2 version of blacktie.

             

            Best regards,

             

            Emmanuel

            • 3. Re: Re: btadmin startup checking blocked with blacktie 5.0.2
              Tom Jenkinson Master

              Hi,

               

              I can see in your blacktie-J log it has got past the check for the host:

               

              2014-06-11 11:10:52,144 [main]           INFO  (conf.Server              :51  ) - Checking for host: LT-PETREMANN or ip: 172.16.13.137

              2014-06-11 11:10:52,144 [main]           DEBUG (conf.Server              :55  ) - Checking against: LT-PETREMANN or ip: null

              2014-06-11 11:10:52,144 [main]           DEBUG (conf.Server              :55  ) - Checking against: LT-PETREMANN or ip: null

              2014-06-11 11:10:52,144 [main]           DEBUG (commands.Startup         :90  ) - Found machine

              2014-06-11 11:10:52,205 [main]           DEBUG (commands.Startup         :115 ) - Launched server: ./server -i 1 -s fooapp  -p 12341 -t 127.0.0.1:8881

               

              You could try to execute the command by hand:

               

              ./server -i 1 -s fooapp  -p 12341 -t 127.0.0.1:8881

               

              I can confirm that we aren't seeing this in CI:

              [exec] Checking for host: WIN-5GKPEREVUOO or ip: 172.17.131.21

                [exec] 19:26:46,013 INFO [org.hornetq.core.server] (ServerService Thread Pool -- 74) HQ221003: trying to deploy queue jms.queue.BTR_.fooapp1

                [exec] 19:26:46,029 INFO [org.jboss.as.messaging] (ServerService Thread Pool -- 74) WFLYMSG0002: Bound messaging object to jndi name /queue/BTR_.fooapp1

                [exec] 2014-06-10 19:26:46,076 [0x000008e8] INFO (AtmiBrokerServer :938 ) - advertised service .fooapp1

                [exec]

                [exec] 2014-06-10 19:26:46,077 [0x000008e8] ERROR (symbolLoaderLogger :57 ) - lookup_symbol: FOOAPP dlsym error

                [exec]

                [exec] 2014-06-10 19:26:46,077 [0x000008e8] WARN (AtmiBrokerServer :512 ) - can not find FOOAPP in server.exe

                [exec]

                [exec] 2014-06-10 19:26:46,077 [0x000008e8] INFO (AtmiBrokerServer :243 ) - Server 1 Running

               

              Its maybe something environmental. Are the right settings in the environment I wonder. If you execute the command by hand it will probably help by complaining about some missing dll.

               

              Also, you do have to recompile the fooapp example with 5.0.2 I would guess - not sure if you tried that?

               

              Tom

              • 4. Re: btadmin startup checking blocked with blacktie 5.0.2
                Amos Feng Newbie

                Hi,

                 

                I checked the jboss-as server.log and it looks like the blacktie server has not started yet. I also think it might be something wrong with the environments.

                 

                Amos

                • 5. Re: btadmin startup checking blocked with blacktie 5.0.2
                  Tom Jenkinson Master

                  I think it looks like it did start, at least I see:

                   

                  2014-06-11 11:08:48,500 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 32) JBAS018559: Deployed "blacktie-admin-services-ear-5.0.2.Final.ear" (runtime-name : "blacktie-admin-services-ear-5.0.2.Final.ear")

                   

                  And:

                  2014-06-11 11:08:48,525 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015874: WildFly 8.0.0.Final "WildFly" started in 17099ms - Started 403 of 462 services (107 services are lazy, passive or on-demand)

                   

                  Maybe I miss something though?

                  • 6. Re: btadmin startup checking blocked with blacktie 5.0.2
                    Tom Jenkinson Master

                    Hi Emmanuel,


                    Just wondered if you can confirm you did try to rebuild the quickstart with 5.0.2?

                     

                    Thanks,

                    Tom

                    • 7. Re: btadmin startup checking blocked with blacktie 5.0.2
                      Amos Feng Newbie

                      Tom,

                       

                      I mean that the blacktie C++ server does not start and there is no any blacktie.log or blacktie-C.log.

                       

                      Amos

                      • 8. Re: btadmin startup checking blocked with blacktie 5.0.2
                        Tom Jenkinson Master

                        Ah yes, I see what you mean now. I think it is probably an unsatisfied linkage error in the built quickstart binaries, presumably they are bound the 5.0.0.Final version that can't be found because Emmanuel is pointing at 5.0.2.Final now.

                         

                        I am not sure why that output isn't printed on linux, on Windows there is usually a dialog that pops up to say that it can't find foo.dll or whatever. Anyway, Emmanuel the thing to do is make sure you have rebuilt with 5.0.2 and then run ./server.exe -i  1 -s fooapp  -p 12341 -t 127.0.0.1:8881

                         

                        Hope it helps,

                        Tom

                        • 9. Re: btadmin startup checking blocked with blacktie 5.0.2
                          johann Le Biannic Newbie

                          Hi,

                          I'm on Windows 7 64 bits and i have the same problem: "Checking for host: LT-JLEBIANNIC or ip: 172.16.13.168" and blocked ...

                          When i run "server.exe -i  1 -s fooapp  -p 12341 -t 127.0.0.1:8881" i have a pop up which says MSVCP100D.dll is missing !

                          It's very strange because MSVCP100D.dll is a part of the Microsoft Visual Studio 2010 install ...

                          Furthermore, It seems blacketie-core.dll is compiled in debug mode and debug dll of microsoft are non redistribuable ...

                          With dependency walker software i see that in blacktie 5.0.0, blacktie-core.dll depends of MSVCP90D.DLL but in blacktie 5.0.2, blacktie-core.dll depends of MSVCP100D.DLL, is it normal ?

                           

                           

                          I use Microsoft Visual Studio 9 Express edition 32 bits to set the compilation environment.

                           

                           

                          I tried to install Microsoft Visual Studio Express edition 2010 to get MSVCP100D.dll but now the server crashes when i launch "server.exe -i  1 -s fooapp  -p 12341 -t 127.0.0.1:8881" or "btadmin startup" :

                           

                           

                          Signature du problème :

                            Nom d’événement de problème: APPCRASH

                            Nom de l’application: server.exe

                            Version de l’application: 0.0.0.0

                            Horodatage de l’application: 53b3db82

                            Nom du module par défaut: MSVCP100D.dll

                            Version du module par défaut: 10.0.30319.1

                            Horodateur du module par défaut: 4ba1dbdf

                            Code de l’exception: c0000005

                            Décalage de l’exception: 00013b27

                            Version du système: 6.1.7601.2.1.0.256.4

                            Identificateur de paramètres régionaux: 1036

                            Information supplémentaire n° 1: 0a9e

                            Information supplémentaire n° 2: 0a9e372d3b4ad19135b953a78882e789

                            Information supplémentaire n° 3: 0a9e

                            Information supplémentaire n° 4: 0a9e372d3b4ad19135b953a78882e789

                           

                           

                          Any idea ?

                           

                           

                          Regards.

                          • 10. Re: btadmin startup checking blocked with blacktie 5.0.2
                            Tom Jenkinson Master

                            Hi,

                             

                            The blocking is because the Java process exec'd the server process and the server process failed to start due to the unsatisfied link. btadmin is provided as a convenience so I would stick to trying to debug the issue with just: server.exe -i  1 -s fooapp  -p 12341 -t 127.0.0.1:8881

                             

                            Is there anything in the server log when you run with that one?

                             

                            I will try to re-upload with the MSVCP90D.DLL dependencies. We must have used a different machine to build it on.

                             

                            Sorry about that,

                            Tom

                            • 11. Re: Re: btadmin startup checking blocked with blacktie 5.0.2
                              johann Le Biannic Newbie

                              Hi,

                              thanks for your answer, i join in this post the "server.log" after the run of the "server.exe -i  1 -s fooapp  -p 12341 -t 127.0.0.1:8881" command.

                              I run 2 times this command so it can appears in the file server.log.

                               

                              Johann.

                              • 12. Re: btadmin startup checking blocked with blacktie 5.0.2
                                johann Le Biannic Newbie

                                I have build 5.0.2 Blacktie's sources (i have juste changed property jboss-as.version from 9.0.0.Alpha1-SNAPSHOT to 8.1.0.Final in the narayana's pom.xml ) and now the blacktie-core.dll depends only from MSVCP90D.DLL and the quickstart xatmi/fooapp run correctly !

                                 

                                Summary of my problems:

                                     - Missing standalone-blacktie.xml in blacktie-5.0.2.Final-vc9x32-bin.zip (i took the linux version)

                                     - Problem with Blacktie dll files (depend from MSVCP100.DLL)   

                                     - In file blacktie\test\initializeBlackTie.xml which i used to configure my environment, i had backslash  after ${BT_HOME} line 25 : <echo message="${BT_HOME}\" file="bthome.tmp.file"/>

                                • 13. Re: btadmin startup checking blocked with blacktie 5.0.2
                                  Tom Jenkinson Master

                                  Hi,

                                   

                                  I have literally just re-uploaded the binary of 5.0.2.Final. I checked in there and its definitely got the standalone-blacktie.xml. I think I built with the wrong toolchain before but again I have verified that I was using VC9 this time so that should be good too.

                                   

                                  In terms of the "\", perhaps you could raise a PR with the fix in it over here: jbosstm/quickstart · GitHub (you need to sign the CLA over here https://cla.jboss.org/ for "JBoss Transactions" before I can merge it but feel free to raise the PR now and it can be CI'ing).

                                   

                                  Thanks for the report,

                                  Tom