13 Replies Latest reply on Nov 18, 2011 6:52 AM by Piotr Klimczak

    java.lang.ClassNotFoundException: org.hibernate.MappingException not found

    Piotr Klimczak Newbie

      Hi All!


      Today i have faced a problem, which seems to be specific to FUSE ESB only.


      The problem shows as:

      java.lang.ClassNotFoundException: org.hibernate.MappingException not found by com.springsource.org.hibernate.annotations

      and it is all around exporting "org.hibernate" by 2 bundles:


      JBoss Hibernate Annotations (3.4.0.GA)

                                             Hosts: 235

      JBoss Hibernate Object-Relational Mapper (3.3.2.GA)

                                             Fragments: 233,234


      I believe that the problem occurs because of "org.hibernate" being exported by 2 bundles (host and it's fragment):


      exports | grep "org.hibernate;"

         233 org.hibernate; version=3.4.0.GA        

         235 org.hibernate; version=3.3.2.GA        

         235 org.hibernate; version=3.4.0.GA


      Then i have noticed that same feature installed on my 1 month old servicemix build (from trunk) works perfect, as well as newly builded one (checked out from trunk today).

      Exports looks a little different on SMX builded from trunk:


      exports | grep "org.hibernate;"

         541 org.hibernate; version=3.3.2.GA        

         541 org.hibernate; version=3.4.0.GA


      JBoss Hibernate Annotations (3.4.0.GA)

                                             Hosts: 541

      JBoss Hibernate Object-Relational Mapper (3.3.2.GA)

                                             Fragments: 539,540


      Unfortunately i do not have time for looking for a bug inside FUSE ESB. So now it is your turn.

      If you need more informations, then give me a sign...


      Piotr Klimczak