0 Replies Latest reply on Jul 15, 2017 3:21 AM by Vaibhav Dhingra

    Issue while migrating from Weblogic12 to EAP6.4

    Vaibhav Dhingra Newbie

      Hi All,

       

       

      Can anyone help on below error while .ear deployment:

       

      13:23:48,225 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-5) MSC000001: Failed to start service jboss.deployment.unit."My.ear".WeldStartService: org.jboss.msc.service.StartException in service jboss.deployment.unit."My.ear".WeldStartService: Failed to start service

              at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1936) [jboss-msc-1.1.5.Final-redhat-1.jar:1.1.5.Final-redhat-1]

              at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_21]

              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_21]

              at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_21]

      Caused by: org.jboss.weld.exceptions.UnproxyableResolutionException: WELD-001437 Normal scoped bean class com.google.gwt.user.server.rpc.RemoteServiceServlet is not proxyable because the type is final or it contains a final method public final com.google.gwt.user.server.rpc.SerializationPolicy com.google.gwt.user.server.rpc.RemoteServiceServlet.getSerializationPolicy(java.lang.String,java.lang.String) - Managed Bean [class xx.xx.xx.xx.server.service.RESTService] with qualifiers [@Any @Default].

       

      We are using GWT2.6.1 for client code. The same is working fine without any error in weblogic12c but while migrating the same application to Jboss EAP6.4, above error is noticed.

       

      Somewhere we can see that WELD version should be upgraded, but we already are using below versions available with installed EAP:

       

      ./modules/system/layers/base/org/jboss/weld/api/main/weld-api-1.1.0.Final-redhat-6.jar

      ./modules/system/layers/base/org/jboss/weld/spi/main/weld-spi-1.1.0.Final-redhat-6.jar

      ./modules/system/layers/base/org/jboss/weld/core/main/weld-core-1.1.28.Final-redhat-1.jar

      ./modules/system/layers/base/org/jboss/as/weld/main/jboss-as-weld-7.5.0.Final-redhat-21.jar

       

      Could anyone have any idea to get this resolved. This is something blocking us for further progressing on weblogic to Jboss migration activity.

       

       

      Thanks in advance !