3 Replies Latest reply on Feb 3, 2020 3:08 AM by ehugonnet

    can not deploy activemq-rar-5.10.0.rar in JBOSS 7.0

    Aldi Yudhapradipta Newbie

      Hi i want to install activemq as external broker. I followed this step Integrate ActiveMQ with WildFly

      but when i tried this step i got this error

      Failed to start service jboss.ra.deployment."activemq-rar-5.10.0.rar_activemq": org.jboss.msc.service.StartException in service jboss.ra.deployment."activemq-rar-5.10.0.rar_activemq": WFLYJCA0046: Failed to start RA deployment [activemq-rar-5.10.0.rar]

      at org.jboss.as.connector.services.resourceadapters.deployment.AbstractResourceAdapterDeploymentService$2.run(AbstractResourceAdapterDeploymentService.java:318)

      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)

      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)

      at java.lang.Thread.run(Thread.java:748)

      at org.jboss.threads.JBossThread.run(JBossThread.java:320)

      Caused by: org.jboss.jca.deployers.common.DeployException: IJ020056: Deployment failed: file:/home/redhat/TAFJR19/TAFJ/3rdParty/AS/jboss-eap-7.0/standalone/tmp/vfs/temp/temp86d092ecf61750a6/content-4662c45c386b520b/contents/

      at org.jboss.jca.deployers.common.AbstractResourceAdapterDeployer.createObjectsAndInjectValue(AbstractResourceAdapterDeployer.java:2036)

      at org.jboss.as.connector.services.resourceadapters.deployment.ResourceAdapterXmlDeploymentService$WildFlyRaXmlDeployer.doDeploy(ResourceAdapterXmlDeploymentService.java:173)

      at org.jboss.as.connector.services.resourceadapters.deployment.ResourceAdapterXmlDeploymentService.start(ResourceAdapterXmlDeploymentService.java:116)

      at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1948)

      at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1881)

      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)

      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)

      at java.lang.Thread.run(Thread.java:748)

      Caused by: org.jboss.msc.service.DuplicateServiceException: Service jboss.naming.context.java.ConnectionFactory is already registered

      at org.jboss.msc.service.ServiceRegistrationImpl.setInstance(ServiceRegistrationImpl.java:158)

      at org.jboss.msc.service.ServiceControllerImpl.startInstallation(ServiceControllerImpl.java:235)

      at org.jboss.msc.service.ServiceContainerImpl.install(ServiceContainerImpl.java:768)

      at org.jboss.msc.service.ServiceTargetImpl.install(ServiceTargetImpl.java:223)

      at org.jboss.msc.service.ServiceControllerImpl$ChildServiceTarget.install(ServiceControllerImpl.java:2401)

      at org.jboss.msc.service.ServiceBuilderImpl.install(ServiceBuilderImpl.java:317)

      at org.jboss.as.connector.services.resourceadapters.deployment.AbstractResourceAdapterDeploymentService$AbstractWildFlyRaDeployer.bindConnectionFactory(AbstractResourceAdapterDeploymentService.java:439)

      at org.jboss.jca.deployers.common.AbstractResourceAdapterDeployer.createObjectsAndInjectValue(AbstractResourceAdapterDeployer.java:1790)

      ... 7 more

       

       

       

       

      WFLYCTL0186:   Services which failed to start:      service jboss.ra.deployment."activemq-rar-5.10.0.rar_activemq"

      Here is my resources-adapter <subsystem xmlns="urn:jboss:domain:resource-adapters:4.0"> :

      <resource-adapters>

                      <resource-adapter id="activemq">

                          <archive>

                              activemq-rar-5.10.0.rar

                          </archive>

                          <transaction-support>XATransaction</transaction-support>

                          <config-property name="ServerUrl">

                              tcp://localhost:61616

                          </config-property>

                          <config-property name="UserName">

                              defaultUser

                          </config-property>

                          <config-property name="UseInboundSession">

                              false

                          </config-property>

                          <config-property name="Password">

                              defaultPassword

                          </config-property>

                          <connection-definitions>

                              <connection-definition class-name="org.apache.activemq.ra.ActiveMQManagedConnectionFactory" jndi-name="java:/ConnectionFactory" enabled="true" pool-name="ConnectionFactory">

                                  <xa-pool>

                                      <min-pool-size>1</min-pool-size>

                                      <max-pool-size>20</max-pool-size>

                                      <prefill>false</prefill>

                                      <is-same-rm-override>false</is-same-rm-override>

                                  </xa-pool>

                              </connection-definition>

                          </connection-definitions>

                          <admin-objects>

                              <admin-object class-name="org.apache.activemq.command.ActiveMQTopic" jndi-name="java:jboss/activemq/topic/TestTopic" use-java-context="true" pool-name="TestTopic">

                                  <config-property name="PhysicalName">

                                      activemq/topic/TestTopic

                                  </config-property>

                              </admin-object>

                              <admin-object class-name="org.apache.activemq.command.ActiveMQQueue" jndi-name="java:jboss/activemq/queue/TestQueue" use-java-context="true" pool-name="TestQueue">

                                  <config-property name="PhysicalName">

                                      activemq/queue/TestQueue

                                  </config-property>

                              </admin-object>

                          </admin-objects>

                      </resource-adapter>

                  </resource-adapters>

      Any step that i'm missing from that tutorial? there is a different about resource-adapters:4.0 and resource-adapters:2.0?

       

      Thank you.

      Best regards,

      Aldi Yudha Pradipta