1 2 Previous Next 19 Replies Latest reply on Mar 20, 2008 10:22 PM by Simon Su

    console url changed to http://localhost:8080/jbpm-console

    Tom Baeyens Master

      in versions up to 3.1.x, the console URL was htp://localhost:8080/jbpm

      since 3.2.GA, the url has become http://localhost:8080/jbpm-console

        • 1. Re: console url changed to http://localhost:8080/jbpm-consol
          jean-luct Newbie

          Thanks for the info. This is true as URL in the getting started but it seems to be true also when deploying from Eclipse IDE : you have to enter jbpm-console.
          Still I'm not able to get displayed my new process in the console.

          Any idea ?

          • 2. Re: console url changed to http://localhost:8080/jbpm-consol
            Georgios Diamantopoulos Newbie

            I can get it running and I will login fine but I get an error when I try and start a process:

            javax.faces.FacesException: Stream error while reading XML: Connection refused: connect
            at com.ctc.wstx.sr.StreamScanner.throwFromIOE(StreamScanner.java:522)
            at com.ctc.wstx.sr.WstxStreamReader.next(WstxStreamReader.java:978)
            at org.jbpm.webapp.tag.jbpm.ui.XmlPrinter.encodeBegin(XmlPrinter.java:113)
            at org.jbpm.webapp.tag.jbpm.ui.ComponentBase.doEncode(ComponentBase.java:31)
            at org.jbpm.webapp.tag.jbpm.ui.ComponentBase.doEncode(ComponentBase.java:58)
            at org.jbpm.webapp.tag.jbpm.ui.Tab.encodeChildren(Tab.java:112)
            at javax.faces.component.UIComponent.encodeAll(UIComponent.java:884)
            at javax.faces.component.UIComponent.encodeAll(UIComponent.java:890)
            at javax.faces.component.UIComponent.encodeAll(UIComponent.java:890)
            at com.sun.facelets.FaceletViewHandler.renderView(FaceletViewHandler.java:578)
            at org.jbpm.webapp.application.JbpmViewHandler.renderView(JbpmViewHandler.java:58)
            at com.sun.faces.lifecycle.RenderResponsePhase.execute(RenderResponsePhase.java:106)
            at com.sun.faces.lifecycle.LifecycleImpl.phase(LifecycleImpl.java:248)
            at com.sun.faces.lifecycle.LifecycleImpl.render(LifecycleImpl.java:144)
            at javax.faces.webapp.FacesServlet.service(FacesServlet.java:245)
            at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFi


            Any ideas?

            • 3. Re: console url changed to http://localhost:8080/jbpm-consol
              fulig jimmy Newbie

              Yes, i have the same problem. I tried many JRE versions and a Linux too, but the problem was just the same.
              I dont't know what could I do yet.
              Please help!
              Thanks!

              • 4. Re: console url changed to http://localhost:8080/jbpm-consol
                Ronald van Kuijk Master

                please try and use a sniffer to see what connections are being made. I cannot reproduce this

                • 5. Re: console url changed to http://localhost:8080/jbpm-consol
                  fulig jimmy Newbie

                  I think, i found the problem. In the websale example the first task' source is form.create.xhtml. In this file the second line is "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd" and when your computer has no internet connection, this is unreachable.

                  Any idea to solve this problem?
                  Thanks!

                  • 6. Re: console url changed to http://localhost:8080/jbpm-consol
                    Georgios Diamantopoulos Newbie

                    Are you sure? I have Internet here and I don't think that's actually accessed...

                    • 7. Re: console url changed to http://localhost:8080/jbpm-consol
                      fulig jimmy Newbie

                      I think, yes. When I use it with internet connection, works fine, but when without internet, there is an error.

                      • 9. Re: console url changed to http://localhost:8080/jbpm-consol
                        Alexandre Del Puppo Newbie

                        Actually, if your internet connection is active, maybe you need to configure the right proxy settings to startup your Application Server.

                        In this page, there's a list of options showing how to setup the proxy settings for some Server Applications like JBoss, Tomcat, Orion and WebLogic: http://confluence.atlassian.com/display/DOC/Configure+Web+Proxy+Support+for+Confluence

                        Particularly, to run the sample application under JBoss application server bundled with jBPM-suite 3.2, I did the following:

                        -Edited the file "jbpm-jpdl-3.2.GA\server\bin\run.bat"
                        -Searched for JAVA_OPTS. Changed the line
                        "set JAVA_OPTS=%JAVA_OPTS% -Xms128m -Xmx512m -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000"

                        to

                        "set JAVA_OPTS=%JAVA_OPTS% -Dhttp.proxyHost=192.168.10.254 -Dhttp.proxyPort=3128 -Xms128m -Xmx512m -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000"

                        Where 192.168.10.254 is my proxy server and 3128 is the port for connection.

                        Hope this works for you as worked for me!!

                        Best regards,

                        Alexandre

                        • 10. Re: console url changed to http://localhost:8080/jbpm-consol
                          Akarapob Chaiyoung Newbie

                          Hi All,

                          I can't login jbpm-conlose from http://localhost:8080/jbpm-console.
                          I copy jbpm-console.war from jbpm-jpdl-3.2 GA to server\default\deploy and change hibernate config from HSQL to MySQL

                          <property name="hibernate.dialect">org.hibernate.dialect.MySQLInnoDBDialect</property>
                           <property name="hibernate.connection.datasource">java:/jdbc/JbpmDS</property>
                          
                           <property name="hibernate.cache.provider_class">org.hibernate.cache.HashtableCacheProvider</property>


                          in MySQL i have one user(ernie) but loginpage is show 4 users

                          Username Password Roles
                          ernie ernie participant, manager, administrator
                          bert bert participant
                          cookie monster cookie monster participant
                          grover grover participant


                          on start up no error when i login console is show error

                          [UsersRolesLoginModule] Failed to load users/passwords/role files
                          java.io.IOException: No properties file: users.properties or defaults: defaultUsers.properties found
                           at org.jboss.security.auth.spi.Util.loadProperties(Util.java:315)
                           at org.jboss.security.auth.spi.UsersRolesLoginModule.loadUsers(UsersRolesLoginModule.java:186)
                           at org.jboss.security.auth.spi.UsersRolesLoginModule.createUsers(UsersRolesLoginModule.java:200)
                           at org.jboss.security.auth.spi.UsersRolesLoginModule.initialize(UsersRolesLoginModule.java:127)
                           at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                           at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
                           at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
                           at java.lang.reflect.Method.invoke(Unknown Source)
                           at javax.security.auth.login.LoginContext.invoke(Unknown Source)
                           at javax.security.auth.login.LoginContext.access$000(Unknown Source)
                           at javax.security.auth.login.LoginContext$4.run(Unknown Source)
                           at java.security.AccessController.doPrivileged(Native Method)
                           at javax.security.auth.login.LoginContext.invokePriv(Unknown Source)
                           at javax.security.auth.login.LoginContext.login(Unknown Source)
                           at org.jboss.security.plugins.JaasSecurityManager.defaultLogin(JaasSecurityManager.java:601)
                           at org.jboss.security.plugins.JaasSecurityManager.authenticate(JaasSecurityManager.java:535)
                           at org.jboss.security.plugins.JaasSecurityManager.isValid(JaasSecurityManager.java:344)
                           at org.jboss.web.tomcat.security.JBossSecurityMgrRealm.authenticate(JBossSecurityMgrRealm.java:491)
                           at org.apache.catalina.authenticator.FormAuthenticator.authenticate(FormAuthenticator.java:257)
                           at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:416)
                           at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:74)
                           at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
                           at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
                           at org.jboss.web.tomcat.tc5.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:156)
                           at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
                           at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
                           at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)
                           at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:664)
                           at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
                           at org.apache.tomcat.util.net.MasterSlaveWorkerThread.run(MasterSlaveWorkerThread.java:112)


                          I don't know, step to deploy is correct ?????
                          Any one have step by step to deploy jbpm-console.war, please advise.


                          Best Regard,

                          AkikoFukuoka

                          • 11. Re: console url changed to http://localhost:8080/jbpm-consol
                            Ronald van Kuijk Master

                            look at the wiki page on how to configure your jboss AS instance when not using the starterkit... it's all in there

                            • 12. Re: console url changed to http://localhost:8080/jbpm-consol
                              Prabhakar Newbie

                              Hi Alexandre,

                              You are correct, after setting the proxy details it is working.

                              Thanks
                              Prabhakar N.

                              • 13. Re: console url changed to http://localhost:8080/jbpm-consol
                                David Latham Newbie

                                i have the same error. i'm trying this on a LAN that is not connected to the internet and getting the same XML:www.w3.org stream error. work-around?

                                • 14. Re: console url changed to http://localhost:8080/jbpm-consol
                                  Ronald van Kuijk Master

                                  yes, did you look at the other posts in this topic? Another option is to make sure your parser can find the relevant dtd/xsd in another way than via the internet

                                  1 2 Previous Next