5 Replies Latest reply on Jun 21, 2007 1:36 PM by Antoine Herzog

    initial default page not displayed from source build

    Scrooge McDuck Newbie

      Hi there,

      I cannot get the full start page of the portal server to be displayed.

      I have build the AS 4.2.0GA from the source and the portal 2.6.0 CR 2 from source as well, and am able to start the portal server, but only get a very minimal page.
      Neither the CMS nor the greetings portlet are displayed. If I log in as admin, I am able to manage users, but none of the other elements are shown. Logged in users are able to edit their profile including changing the theme.

      I have started with the Jboss-jsf implementation, but also tried with myfaces as described on the wiki for running portal 2.6 on as-4.2, deleting the contents of the data directory inbetween.

      I haved compared the default-object.xml from the portal-as binary bundle and cannot find any differences.

      Other than the configuration for myfaces, I have not made any changes from the source bundle.

      Any help?

      Summary:
      AS: jboss-4.2.0.GA-src/ portal: jboss-portal-2.6-CR2-src/ java: sun-1.5.0_08 OS: Linux 2.6.18.2-34

      mfg lutz

        • 1. Re: initial default page not displayed from source build
          Thomas Heute Master

          Don't try 4.2 at the moment we are working on a solution that would make JBoss Portal binaries work on JBoss AS 4.0 *and* JBoss AS 4.2

          It's still a challenge

          • 2. Re: initial default page not displayed from source build
            Scrooge McDuck Newbie

            Hmmm... I need to use ejb 3.0. How else than AS 4.2 can I get the portal to work on a ejb3 environment?

            What is the timeframe on the solution on this problem? Days, weeks, months? Should I wait or look for a different solution?

            mfg lutz

            • 3. Re: initial default page not displayed from source build
              Thomas Heute Master

              ejb3 works fine on 4.0 you will need to use the JEMS installer (with the ejb3 profile) then upgrade JBoss Portal

              http://labs.jboss.com/jemsinstaller/downloads

              • 4. Re: initial default page not displayed from source build
                Antoine Herzog Master

                Hello,

                I got the same problem : minimal portal
                but with JBoss AS 4.0.5 and the nightly build of portal (of june 20th).

                I took the JBoss Portal bundled with JBoss AS (4.0.5), installed it.
                After, I took the nightly build of portal and did the "build deploy" in the build folder.
                I got a new jboss-portal.sar, in the deploy folder.
                but :
                - only 4.9 Mo instead of about 12Mo
                - a lot of war and sar were missing inside it (no portal-admin.sar, as an example).
                - only the "minimal portal" : login page, userportlet, like you

                So it is not because of JSF !
                It is because the war and sar are not there...
                I thaught I had missed something in deploying the nigthly build, so I went back to the regular release package.
                So it seem there is a problem there.
                May be the way I did the deploy : the doc may lack something ? an option ?

                About EJB3 :
                My portal is working with EJB3, with jboss 4.0.4GA and JBP 2.4.1SP1.
                I did the installation of jboss 4.0.4GA and JBP XXX (I don't remember which one it was) with the jems installer
                note : ask for the option of EJB3 when installing.
                Then I updated the portal with JBP 2.4.1SP1 (when it was released).
                it works fine.

                I remember also I added the latest Hibernate version (that was 3.2.3ga) with also the jars for annotation and persistence manager etc... to use annotation in the EJB3 way.
                All worked fine.

                And with MyFace 1.1.5.

                So : jboss 4.0.4GA and JBP 2.4.1SP1 and MyFace 1.1.5 are ok with EJB3
                after : I am now upgrading with JBP 2.6... don't know yet. It should be ok for EJB3, as this is quiet separate from the way the portal run.
                But there are still some little things that may be a problem with JBP2.6 (like the myface stuff... that will be resolved soon I hope...).

                Hope it helps...

                • 5. Re: initial default page not displayed from source build
                  Antoine Herzog Master

                  I just got the answer from another post :

                  build deploy : deploy only the minimal thing of the portal

                  build deploy-all : deploy all the stuff

                  chris.laprun@jboss.com said he will update the wiki...