6 Replies Latest reply on Jun 21, 2007 1:30 PM by Chris Laprun

    JBP 2.6 RC2 : Pb starting service portal.wsrp:service=Consum

    Antoine Herzog Master

      Hello,

      with JBP 2.6RC2 out of the box (bundle package, with jboss as 4.0.5), I get an Exception at start up :

      22:44:03,375 WARN [ServiceController] Problem starting service portal.wsrp:service=ConsumerRegistry
      java.lang.IllegalArgumentException: Activating a Consumer requires a non-null, non-empty Consumer identifier
       at org.jboss.portal.common.util.ParameterValidation.throwIllegalArgExceptionIfNullOrEmpty(ParameterValidation.java:36)
       at org.jboss.portal.wsrp.consumer.ConsumerRegistryService.org$jboss$portal$wsrp$consumer$ConsumerRegistryService$activateConsumerWit
      h$aop(ConsumerRegistryService.java:214)
       at org.jboss.portal.wsrp.consumer.ConsumerRegistryService$activateConsumerWith_2644041892217903609.invokeNext(ConsumerRegistryServic
      e$activateConsumerWith_2644041892217903609.java)
       at org.jboss.aspects.tx.TxPolicy.invokeInCallerTx(TxPolicy.java:126)
       at org.jboss.aspects.tx.TxInterceptor$Required.invoke(TxInterceptor.java:195)
       at org.jboss.portal.wsrp.consumer.ConsumerRegistryService$activateConsumerWith_2644041892217903609.invokeNext(ConsumerRegistryServic
      e$activateConsumerWith_2644041892217903609.java)
       at org.jboss.aspects.tx.TxPolicy.invokeInCallerTx(TxPolicy.java:126)
       at org.jboss.aspects.tx.TxInterceptor$Required.invoke(TxInterceptor.java:195)
       at org.jboss.portal.wsrp.consumer.ConsumerRegistryService$activateConsumerWith_2644041892217903609.invokeNext(ConsumerRegistryServic
      e$activateConsumerWith_2644041892217903609.java)
       at org.jboss.portal.wsrp.consumer.ConsumerRegistryService.activateConsumerWith(ConsumerRegistryService.java)
       at org.jboss.portal.wsrp.consumer.ConsumerRegistryService.org$jboss$portal$wsrp$consumer$ConsumerRegistryService$startService$aop(Co
      nsumerRegistryService.java:199)
       at org.jboss.portal.wsrp.consumer.ConsumerRegistryService$startService_N522319811864268586.invokeNext(ConsumerRegistryService$startS
      ervice_N522319811864268586.java)
       at org.jboss.aspects.tx.TxPolicy.invokeInCallerTx(TxPolicy.java:126)
       at org.jboss.aspects.tx.TxInterceptor$Required.invoke(TxInterceptor.java:195)
       at org.jboss.portal.wsrp.consumer.ConsumerRegistryService$startService_N522319811864268586.invokeNext(ConsumerRegistryService$startS
      ervice_N522319811864268586.java)
       at org.jboss.aspects.tx.TxPolicy.invokeInOurTx(TxPolicy.java:79)
       at org.jboss.aspects.tx.TxInterceptor$Required.invoke(TxInterceptor.java:191)
       at org.jboss.portal.wsrp.consumer.ConsumerRegistryService$startService_N522319811864268586.invokeNext(ConsumerRegistryService$startS
      ervice_N522319811864268586.java)
       at org.jboss.portal.wsrp.consumer.ConsumerRegistryService.startService(ConsumerRegistryService.java)
       at org.jboss.system.ServiceMBeanSupport.jbossInternalStart(ServiceMBeanSupport.java:289)
      ....
      


      Any idea where it is coming from ?

      I remember I had suppressed the WSRP (sar or war) feature in my former 2.4.1, to avoid a problem with it (and because I don't use it).
      Could be the same ?
      I don't remember what was the problem, but does not seem to be the same...

      Thanks

        • 1. Re: JBP 2.6 RC2 : Pb starting service portal.wsrp:service=Co
          Chris Laprun Master

          If you don't use WSRP, yes, please remove it from the Portal SAR. As far as the error goes, I will look into it but it's very likely that it's already been fixed in subversion. We have a new release coming up soon. Could you please try it when it's ready and let us know if you have any issues with it?

          • 2. Re: JBP 2.6 RC2 : Pb starting service portal.wsrp:service=Co
            Antoine Herzog Master

            ok
            thanks
            I'll tell you if it comes again with the final release

            by the way : I tried the nigthly build (not subversion, but the yet built version).
            I did like in the documentation (the 2.6DR) : "build deploy"

            I got a jboss-portal.sar built and deployed in the jboss deploy folder.
            but inside, there was only the minimum component to run a portal :
            - the portal was running but :
            - default page with only a userportlet and login feature
            - a lot of "sub war and sar" were missing in jboss-portal.sar, like portal-admin.sar, etc...

            normal ? did I missed something ?
            Is there a wiki about "how to deploy from nigthly build" ?
            As I wanted to go further, I went back to the regular 2.6CR2 package.
            I am waiting for the next release... but would like to be able to get the last nightly build...

            Thanks again

            • 3. Re: JBP 2.6 RC2 : Pb starting service portal.wsrp:service=Co
              Antoine Herzog Master

              I have retried it to check if the problem still show up.
              (I had a doubt that the problem always occur a each server launch).
              so : yes it show up again.

              As it is a jdbc mysql problem : I use the latest version of Hibernate, ie 3.2.4sp1.
              see this post : http://www.jboss.com/index.html?module=bb&op=viewtopic&t=111530

              And also : here some more information about the error, that may help you.

              The "caused by" second exception is:

              18:32:28,796 WARN [ServiceController] Problem starting service portal.wsrp:service=ConsumerRegistry
              org.hibernate.exception.GenericJDBCException: could not execute query using iterate
               at org.hibernate.exception.SQLStateConverter.handledNonSpecificException(SQLStateConverter.java:103)
               at org.hibernate.exception.SQLStateConverter.convert(SQLStateConverter.java:91)
              ....
              ....
              Caused by: java.sql.SQLException: Invalid value for getLong() - 'self'
               at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:910)
               at com.mysql.jdbc.ResultSet.getLong(ResultSet.java:2768)
               at com.mysql.jdbc.ResultSet.getLong(ResultSet.java:2666)
               at com.mysql.jdbc.ResultSet.getLong(ResultSet.java:2791)
               at org.jboss.resource.adapter.jdbc.WrappedResultSet.getLong(WrappedResultSet.java:718)
               at org.hibernate.type.LongType.get(LongType.java:28)
               at org.hibernate.type.NullableType.nullSafeGet(NullableType.java:163)
               at org.hibernate.type.NullableType.nullSafeGet(NullableType.java:154)
               at org.hibernate.type.ManyToOneType.hydrate(ManyToOneType.java:103)
               at org.hibernate.type.EntityType.nullSafeGet(EntityType.java:204)
               at org.hibernate.impl.IteratorImpl.postNext(IteratorImpl.java:93)
               at org.hibernate.impl.IteratorImpl.<init>(IteratorImpl.java:58)
               at org.hibernate.loader.hql.QueryLoader.iterate(QueryLoader.java:405)
               ... 132 more
              18:32:29,828 INFO [NamingHelper] JNDI InitialContext properties:{}
              18:32:29,843 INFO [DatasourceConnectionProvider] Using datasource: java:PortalDS
              18:32:29,843 INFO [SettingsFactory] RDBMS: MySQL, version: 5.0.19-nt
              18:32:29,859 INFO [SettingsFactory] JDBC driver: MySQL-AB JDBC Driver, version: mysql-connector-java-5.0.4 ( $Date: 2006-10-19 17:47:48 +02
              00 (Thu, 19 Oct 2006) $, $Revision: 5908 $ )
              18:32:29,859 INFO [Dialect] Using dialect: org.hibernate.dialect.MySQLDialect
              18:32:29,875 INFO [TransactionFactoryFactory] Transaction strategy: org.hibernate.transaction.JTATransactionFactory
              18:32:29,875 INFO [NamingHelper] JNDI InitialContext properties:{}
              18:32:29,875 INFO [TransactionManagerLookupFactory] instantiating TransactionManagerLookup: org.hibernate.transaction.JBossTransactionManag
              ....
              


              and at the end of starting process :
              18:33:32,656 INFO [TomcatDeployer] deploy, ctxPath=/jmx-console, warUrl=.../deploy/jmx-console.war/
              18:33:32,859 ERROR [URLDeploymentScanner] Incomplete Deployment listing:
              
              --- MBeans waiting for other MBeans ---
              ObjectName: portal.wsrp:service=ConsumerRegistry
               State: FAILED
               Reason: org.hibernate.exception.GenericJDBCException: could not execute query using iterate
               I Depend On:
               portal:service=Hibernate,type=WSRPConsumer
               portal:service=PortletInvoker,type=Federating
               portal:service=ListenerRegistry
               Depends On Me:
               portal.wsrp:service=WSRPDeployer
              
              --- MBEANS THAT ARE THE ROOT CAUSE OF THE PROBLEM ---
              ObjectName: portal.wsrp:service=ConsumerRegistry
               State: FAILED
               Reason: org.hibernate.exception.GenericJDBCException: could not execute query using iterate
               I Depend On:
               portal:service=Hibernate,type=WSRPConsumer
               portal:service=PortletInvoker,type=Federating
               portal:service=ListenerRegistry
               Depends On Me:
               portal.wsrp:service=WSRPDeployer
              
              
              18:33:32,984 INFO [Http11BaseProtocol] Starting Coyote HTTP/1.1 on http-0.0.0.0-8080
              18:33:33,093 INFO [ChannelSocket] JK: ajp13 listening on /0.0.0.0:8009
              18:33:33,109 INFO [JkMain] Jk running ID=0 time=0/63 config=null
              18:33:33,140 INFO [Server] JBoss (MX MicroKernel) [4.0.5.GA (build: CVSTag=Branch_4_0 date=200610162339)] Started in 1m:47s:812ms
              
              



              • 4. Re: JBP 2.6 RC2 : Pb starting service portal.wsrp:service=Co
                Chris Laprun Master

                 

                "Antoine_h" wrote:

                I got a jboss-portal.sar built and deployed in the jboss deploy folder.
                but inside, there was only the minimum component to run a portal :
                - the portal was running but :
                - default page with only a userportlet and login feature
                - a lot of "sub war and sar" were missing in jboss-portal.sar, like portal-admin.sar, etc...

                normal ? did I missed something ?
                Is there a wiki about "how to deploy from nigthly build" ?


                Yes, this is normal. Portal has been modularized so the default deploy task doesn't deploy everything. There's a deploy-all task that does that. I will update the wiki.

                • 5. Re: JBP 2.6 RC2 : Pb starting service portal.wsrp:service=Co
                  Antoine Herzog Master

                  Thanks a lot !

                  I thaught : they have done it so we have a "barely naked portal" : good for prod installation !

                  update the documentation also ?
                  (I looked there...)

                  • 6. Re: JBP 2.6 RC2 : Pb starting service portal.wsrp:service=Co
                    Chris Laprun Master

                     

                    "Antoine_h" wrote:

                    As it is a jdbc mysql problem : I use the latest version of Hibernate, ie 3.2.4sp1.
                    The "caused by" second exception is:

                    18:32:28,796 WARN [ServiceController] Problem starting service portal.wsrp:service=ConsumerRegistry
                    org.hibernate.exception.GenericJDBCException: could not execute query using iterate
                     at org.hibernate.exception.SQLStateConverter.handledNonSpecificException(SQLStateConverter.java:103)
                     at org.hibernate.exception.SQLStateConverter.convert(SQLStateConverter.java:91)
                    ....
                    ....
                    Caused by: java.sql.SQLException: Invalid value for getLong() - 'self'
                     at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:910)
                     at com.mysql.jdbc.ResultSet.getLong(ResultSet.java:2768)
                     at com.mysql.jdbc.ResultSet.getLong(ResultSet.java:2666)
                     at com.mysql.jdbc.ResultSet.getLong(ResultSet.java:2791)
                     at org.jboss.resource.adapter.jdbc.WrappedResultSet.getLong(WrappedResultSet.java:718)
                     at org.hibernate.type.LongType.get(LongType.java:28)
                     at org.hibernate.type.NullableType.nullSafeGet(NullableType.java:163)
                     at org.hibernate.type.NullableType.nullSafeGet(NullableType.java:154)
                     at org.hibernate.type.ManyToOneType.hydrate(ManyToOneType.java:103)
                     at org.hibernate.type.EntityType.nullSafeGet(EntityType.java:204)
                     at org.hibernate.impl.IteratorImpl.postNext(IteratorImpl.java:93)
                     at org.hibernate.impl.IteratorImpl.<init>(IteratorImpl.java:58)
                     at org.hibernate.loader.hql.QueryLoader.iterate(QueryLoader.java:405)
                     ... 132 more
                    



                    Yes, this has been fixed. See: http://viewvc.jboss.org/cgi-bin/viewvc.cgi/portal?view=rev&revision=7351. This is due to a problem with Hibernate 3.2.3 and above. Note that you'll need to wipe out the WSRP-related tables in your DB when you upgrade to a version containing the fix as one table field has been renamed.