7 Replies Latest reply on Nov 16, 2007 2:17 PM by Chris Laprun

    Getting NullPointerException when starting up JBoss Portal..

    Andreas Ruland Newbie

      Hi there!

      Im currently using JBoss Portal 2.6.2 GA on Mac OS X (10.5 Leopard).

      The following happens during the startup of JBoss Portal:

      Macintosh:bin z00k$ sh run.sh
      run.sh: line 89: ulimit: open files: cannot modify limit: Invalid argument
      run.sh: Could not set maximum file descriptor limit: unlimited
      =========================================================================
      
       JBoss Bootstrap Environment
      
       JBOSS_HOME: /Users/z00k/basement/appz/jboss/jboss-portal-2.6.2.GA
      
       JAVA: /System/Library/Frameworks/JavaVM.framework/Home/bin/java
      
       JAVA_OPTS: -Dprogram.name=run.sh -Xms128m -Xmx512m -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000
      
       CLASSPATH: /Users/z00k/basement/appz/jboss/jboss-portal-2.6.2.GA/bin/run.jar
      
      =========================================================================
      
      Failed to boot JBoss:
      java.lang.NullPointerException
       at java.util.Properties$LineReader.readLine(Properties.java:365)
       at java.util.Properties.load(Properties.java:293)
       at org.jboss.Version.loadProperties(Version.java:291)
       at org.jboss.Version.<init>(Version.java:72)
       at org.jboss.Version.getInstance(Version.java:84)
       at org.jboss.system.server.ServerImpl.<init>(ServerImpl.java:89)
       at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
       at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
       at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
       at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
       at java.lang.Class.newInstance0(Class.java:350)
       at java.lang.Class.newInstance(Class.java:303)
       at org.jboss.system.server.ServerLoader.createServer(ServerLoader.java:289)
       at org.jboss.system.server.ServerLoader.load(ServerLoader.java:268)
       at org.jboss.Main.boot(Main.java:194)
       at org.jboss.Main$1.run(Main.java:508)
       at java.lang.Thread.run(Thread.java:613)
      


      Does anybody know why I'm getting a NullPointerException ?

      Thanks!

      greetings

      z00k