2 Replies Latest reply on Nov 13, 2009 5:52 PM by Andy Pemberton

    Beginer Porblem with a portlet deployment

    Damien Chauvet Newbie

      Hello,

      I am new at using JBoss Portal and I am facing a problem using one of the Portlet of the Portlet Swap Community.
      I'd like to use the Image Gallery portlet.
      When I add the ear file into the Deploy folder and start the server I have this trace in the logs :

      2009-11-11 10:26:31,572 ERROR [org.jboss.deployment.MainDeployer] Could not create deployment: file:/C:/java/jboss-epp-4.3/jboss-as/server/production/tmp/deploy/tmp65483portal-imagegallery.ear-contents/portal-imagegallery.sar
      org.jboss.deployment.DeploymentException: No ClassLoaders found for: org.jboss.portal.core.hibernate.SessionFactoryBinder; - nested throwable: (java.lang.ClassNotFoundException: No ClassLoaders found for: org.jboss.portal.core.hibernate.SessionFactoryBinder)
       at org.jboss.system.ServiceConfigurator.install(ServiceConfigurator.java:196)
       at org.jboss.system.ServiceController.install(ServiceController.java:226)
       at sun.reflect.GeneratedMethodAccessor19.invoke(Unknown Source)
       at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
       at java.lang.reflect.Method.invoke(Method.java:585)
       at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:155)
       at org.jboss.mx.server.Invocation.dispatch(Invocation.java:94)
       at org.jboss.mx.server.Invocation.invoke(Invocation.java:86)
       at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:264)
       at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:659)
       at org.jboss.mx.util.MBeanProxyExt.invoke(MBeanProxyExt.java:210)
       at $Proxy4.install(Unknown Source).
      


      Of course I can not use the portlet afterwards. All other portlets work fine.

      JBoss Portal : jboss-portal-2.7.2 which I downloaded from the Portal web site : http://www.jboss.org/jbossportal/download/index.html
      On Windows XP. I haven’t set the database yet as I believe I don’t need it for such a basic test.


      Can anybody help me on that.

      Thank you.