6 Replies Latest reply on Jun 18, 2007 7:11 AM by Carsten Hoehne

    SeamPDF and generating tables fails after some iterations

    Carsten Hoehne Master

      Hello,
      we have to generate PDF pages for fieldplans. The application can be found here:
      http://bazdm.bafz.de/aveqtest/

      The app shows the fieldplans in html and it can generate pdf documents for it.
      Software:
      JBoss Seam 1.2.1GA with JBoss AS 4.0.5GA

      Our problem: You can view the fieldplans (A table with variable Columns) correctly, but after some time you see only one row with one column. This problem stays until a restart of the jboss server.
      Is this problem already known?
      Here comes our facelets code (for the PDF pages):

      <p:table headerRows="1" widthPercentage="100" horizontalAlignment="left">
       <f:facet name="defaultCell">
       <p:cell horizontalAlignment="center" grayFill="1.0" borderWidth="0" />
       </f:facet>
      <p:cell horizontalAlignment="left">
      <p:font size="18">
      <p:paragraph spacingAfter="10" >
       <p:text value="Fieldplan" />
       <p:text
       value="  ExperimentId: #{experimentSiteList.selExperimentSite.experiment.experimentId}" />
       </p:paragraph>
      </p:font>
      </p:cell>
       <ui:repeat value="#{expFieldplanList.printPlotlist}" var="print">
       <ui:repeat value="#{expFieldplanList.printPlotlist}" var="print">
       <p:cell>
      
       <p:table columns="#{print.columnIndex}" headerRows="1"
       widthPercentage="95" horizontalAlignment="left"
       widths="#{print.columnwidth}" >
       <f:facet name="defaultCell">
       <p:cell horizontalAlignment="center" grayFill="1.0">
       </p:cell>
       </f:facet>
       <p:cell alignment="center">Lanes>
      Plots V</p:cell>
       <ui:repeat value="#{print.plothead}" var="head">
       <p:cell>
       <p:text value="#{head}" />
       </p:cell>
       </ui:repeat>
       <ui:repeat value="#{print.plotlist}" var="lanes">
      
       <p:cell>
       <p:text value="#{lanes.lineIndex}" />
       </p:cell>
       <ui:repeat value="#{lanes.line}" var="plot">
      
       <p:cell>
       <p:table columns="1">
       <f:facet name="defaultCell">
       <p:cell horizontalAlignment="center" grayFill="1.0"
       borderWidth="0" />
       </f:facet>
      
       <p:cell>
       <p:paragraph>
       <p:text value="#{plot.treatmentCode}" />
       </p:paragraph>
       </p:cell>
      
       <p:cell>
       <p:paragraph>
       <p:text
       value="#{plot.holderFaocode} #{plot.accessionNumber}" />
       </p:paragraph>
       </p:cell>
      
       <p:cell>
       <p:paragraph>
       <p:text value="#{plot.accessionName}" />
       </p:paragraph>
       </p:cell>
      
       <p:cell>
       <p:font size="8" style="italic">
      
       <p:paragraph>
       <p:text
       value="A. #{plot.species} #{plot.subspecies} #{plot.varietas}" />
      
       </p:paragraph>
      
       </p:font>
       </p:cell>
       </p:table>
       </p:cell>
       </ui:repeat>
       <p:cell colspan="#{expFieldplanList.columnIndex}"></p:cell>
       </ui:repeat>
      
       </p:table>
       </p:cell>
       </ui:repeat>
       </p:table>
      
      

      I ommit the code for the html page sibnce this page is similar. It constructs the table out of HTML tags(tr,td,table).
      We have no idea where this problem comes from.
      Ciao,
      Baz