3 Replies Latest reply on Sep 24, 2007 12:07 PM by nathan dennis

    s:link id assignment not working as expected Seam 2 CR1

    nathan dennis Expert

      it would seem that s:link id assignment is still not working as expected Seam 2 CR1.
      i first discovered the problem in 2 beta version download from csv around 081707. i found one tread that was discussing a simular issue with commandLink and JIRA issue said it was fixed for 2 CR1... so i upgraded.... but still having the same problem.

      the problem is that the id for the s:link within a column of a dynamic table that contains multiple rows is a duplicate. if i try to pass the id a unique value using EL it returns a null... end result is my page works,, but doesnt validate... a real pain for us perfectionist.....
      here an example of some code...


       <rich:dataTable var="blogEntry"
       value="#{bloggerList.resultList}"
       rendered="#{not empty bloggerList.resultList}"
       style=" border-right-width: 0px;
       border-bottom-width: 0px;
       border-left-width: 0px;
       border-top-width: 0px;">
       <rich:column valign="top" id="a#{blogEntry.id}">
       <div class="blogEntry" align="left">
       <h3>#{blogEntry.title}</h3>
       #{blogEntry.blog}
       <s:link view="/#{empty from ? 'Blog' : from}.xhtml"
       value="More">
       <f:param name="bloggerId"
       value="#{blogEntry.id}"/>
       </s:link>
       <p>
       [Posted on
      
       #{blogEntry.listdate}]
       </p>
       </div>
       <div style="padding-top:5px;">
       <hr align="left" width="500"/>
       </div>
       </rich:column>
       </rich:dataTable>
      
      


      if im missing something i apologize,,,, but im pretty sure this worked in seam 1.2.1

      any enlightenment would be greatly appreciated.