1 2 Previous Next 21 Replies Latest reply on Apr 3, 2007 12:58 PM by Daniel LaChance

    Could not create deployment....

    Josh Hepworth Newbie

      Hi,

      Ive just done a fresh install of JBoss AS 4.0.5.GA and downloaded the JBoss ESB 4.0.GA (WinXP). My configuration file looks like:

      org.jboss.esb.dist.lib=../lib
      org.jboss.esb.appserver.home=/jboss-4.0.5.GA
      org.jboss.esb.appserver.config=default


      Im deploying the ESB using the AS. I typed 'ant' in the the esb/product/install directory and that worked fine.

      Now when I start the Application Server I get this error:

      ERROR [MainDeployer] Could not create deployment: file:/C:/jboss-4.0.5.GA/server/default/deploy/jbossesb-dependencies.sar/


      ..and then some more similar errors, which i presume have spawned from this error. The path: C:/jboss-4.0.5.GA/server/default/deploy/jbossesb-dependencies.sar is correct, and the files exist (except, being on a windows machine the 'slashes' should be the other way).

      Any suggestions?

        • 1. Re: Could not create deployment....
          Kurt Stam Master

          Hi Josh,

          I can't see where you go wrong. Can you check that it created a
          C:\jboss-4.0.5.GA\server\default\deploy\jbossesb-dependencies.sar
          and if you do, can you list the file names in there?

          --Kurt

          • 2. Re: Could not create deployment....
            Mark Little Master

            Have you tried the pre-configured bundle instead?

            • 3. Re: Could not create deployment....
              Josh Hepworth Newbie

              Yes Kurt, the jbossesb-dependencies.sar folder is there, the contents are:

              Yes Kurt, the jbossesb-dependencies.sar is there, the contents are:

              -META-INF
              --jboss-service.xml

              -antlr-2.7.6.jar
              -antlr-3.0ea8.jar
              -commons-jci-core-1.0.406301.jar
              -commons-jci-janino-2.4.3.jar
              -commons-lang-2.1.jar
              -drools-compiler-3.0.4.jar
              -drools-core-3.0.4.jar
              -edftfpj.jar
              -groovy-all-1.0.jar
              -janino-2.4.3.jar
              -juddi-1.0-SNAPSHOT.jar
              -juddi-client-1.0-SNAPSHOT.jar
              -milyn-commons-0.8.jar
              -milyn-edisax-0.1-SNAPSHOT.jar
              -milyn-smooks-core-0.8.jar
              -milyn-smooks-csv-0.1.jar
              -milyn-smooks-edi-0.1.jar
              -milyn-smooks-javabean-0.2.jar
              -milyn-smooks-misc-0.2.jar
              -milyn-smooks-scripting-0.1-SNAPSHOT.jar
              -milyn-smooks-templating-0.2.jar
              -milyn-tinak-0.7.1.jar
              -ognl-2.6.9.jar
              -opencsv-1.6.jar
              -smooks-cdr.lst
              -stax-api-1.0.1.jar
              -stringtemplate-2.3b6.jar
              -xbean.jar
              -xmlpublic.jar


              I'll try the preconfigured bundle today, I presume when you run 'ant' in the install folder it will overwrite any files in the jbossAS folder which were created by the previous esb.

              • 4. Re: Could not create deployment....
                Tom Fennelly Master

                Josh... by any chance, was the AS running when you ran "ant" from the install folder? This is a bit of a long shot for sure, but it may be worth trying to rerun that with the AS stopped. A rerun will overwrite.

                Tom.

                • 5. Re: Could not create deployment....
                  Josh Hepworth Newbie

                  No, the AS was not running when I ran 'ant'.

                  I have just used the bundled-esb and everything seems to be working OK.

                  However, I have one question... I already had jboss-4.0.5.GA installed, and there is a zipped version of this in the bundled-esb package (which is unzipped when you type 'ant'). What effect does this file have on your existing installation of the AS?

                  Josh

                  • 6. Re: Could not create deployment....
                    Tom Fennelly Master

                    Sorry Josh - Kurt will need to answer that one. Perhaps you've encountered an issue there :-)

                    • 7. Re: Could not create deployment....
                      Kurt Stam Master

                      Hi Josh,

                      1. You are missing a jbossesb-dependency.jar in your sar file. I just downloaded the jbossesb-4.0GA.zip and ran 'ant' from the install dir and it worked just fine for me. However, maybe you downloaded the *src* version. In that case the directory struture is a little different, so will have to:
                      rename the product/install/deployment.properties-example to deployment.properties
                      change to org.jboss.esb.dist.lib=../build/jbossesb/lib
                      run 'ant dist' from the product directory to build jbossesb to build the product
                      then run 'ant' from you product/install directory
                      now check that you have the jbossesb-dependency.jar in that jbossesb-dependencies.sar, and you should should be good.


                      2. If you run 'ant' from the bundle it will unzip an new jboss-4.0.5.GA, and it will install that to /jboss-4.0.5.GA, so yes you would be better off removing the existing one if you go that route. However this is by far the easiest way to go.


                      Hope this helps,

                      --Kurt

                      • 8. Re: Could not create deployment....
                        Josh Hepworth Newbie

                        Thanks Kurt. I managed to get the ESB working in the end using the pre-configured bundle, and the getting started - HelloWorld worked fine.

                        Moving onto the trailblazer... im getting the following error:

                        2007-02-04 19:41:30,625 ERROR [org.jboss.soa.esb.samples.trailblazer.loanbroker.LoanBroker] exception occured: org.jboss.soa.esb.services.registry.RegistryException: Could not find service with category=tbCreditAGency and serviceName=creditagency

                        Any suggestions here? I thought it was a little weird that 'tbCreditAGency' had the capitol 'G' - as the normal style would be 'tbCreditAgency', but I am unsure of how to locate/fix this problem.

                        Cheers

                        Josh

                        • 9. Re: Could not create deployment....
                          Daniel Brum Novice

                          Hi Josh.

                          That is strange to be seeing that. It means:

                          a - the service is not deployed to the registry. This registration takes place during the service startup. From the tb dir, when you run "ant runESB" it deploys the services configured in the tb/esb/conf/jbossesb.xml. You can see the service name/categories there.

                          b - the web service uses the property manager to externalize the name of the service/category to find. Look in the tb/jbossesb-properties.xml and there is a "trailblazer" section I added there which gets referenced when the ws tries to invoke the registry and do a lookup for the listening service mentioned in step 1 above.

                          What's in file tb/esb/conf/jbossesb.xml and tb/jbossesb-properties.xml should sync up in terms of name/categories for the service(s).

                          Can you check those 2 files on your system?

                          • 10. Re: Could not create deployment....
                            Josh Hepworth Newbie

                            Hi Daniel,

                            tb/jbossesb-properties.xml contains:



                            tb/esb/conf/jbossesb.xml contains:



                            -Do you need any of the other information from these files? I havnt edited them at all.

                            I looked through the output from 'ant runESB' but not sure what im looking for... there was no direct reference to a Credit Agency Service though.

                            • 11. Re: Could not create deployment....
                              Josh Hepworth Newbie

                              Hi Daniel,

                              tb/jbossesb-properties.xml contains:



                              tb/esb/conf/jbossesb.xml contains:



                              -Do you need any of the other information from these files? I havnt edited them at all.

                              I looked through the output from 'ant runESB' but not sure what im looking for... there was no direct reference to a Credit Agency Service though.

                              • 12. Re: Could not create deployment....
                                Josh Hepworth Newbie

                                *argh - hopefully done it right this time...*

                                Hi Daniel,

                                tb/jbossesb-properties.xml contains:

                                <property name="org.jboss.soa.esb.trailblazer.request.service.category" value="tbCreditAGency"/>


                                tb/esb/conf/jbossesb.xml contains:

                                <service category="tbCreditAGency" name="creditagency" description="Credit Agency Service">


                                -Do you need any of the other information from these files? I havnt edited them at all.

                                I looked through the output from 'ant runESB' but not sure what im looking for... there was no direct reference to a Credit Agency Service though.

                                • 13. Re: Could not create deployment....
                                  Daniel Brum Novice

                                  Well, it's correct in both places, which is good.

                                  The only thing I can think of, is that the war side of the TB, which does a lookup on the service, is somehow failing to get a connection to the service that is deployed.

                                  Can you paste the contents of "ant runESB" in here so that I can see if anything failed? There is a "trailblazer.log" file which gets generated in the TB root directory you can paste or attach here. Please delete it and restart the esb before, so we get a clean log file.

                                  thanks

                                  • 14. Re: Could not create deployment....
                                    Josh Hepworth Newbie

                                    The log file can be found:

                                    http://www.students.ncl.ac.uk/j.f.hepworth-smith/trailblazer.txt

                                    I ran the 'ant runESB' and the 'ant runJMS' and then filled out a 'loan request'.

                                    Thanks

                                    1 2 Previous Next