1 2 Previous Next 20 Replies Latest reply on Mar 6, 2008 4:32 AM by Mark Little

    Problems with CP1

    Haagen Hasle Novice

      I'm having some problems running the ESB with code I've gotten from SVN. I update from http://anonsvn.jboss.org/repos/labs/labs/jbossesb/branches/JBESB_4_2_1_GA_CP

      I've tried the quickstarts helloworld and exception_faults.

      At first I got an exception that seemed to imply a lack of a Security Manager, so I googled a bit and hacked the test-classes to contain code like this:

      System.setProperty("java.security.policy", "client.policy");
       if (System.getSecurityManager() == null)
       System.setSecurityManager(new RMISecurityManager());
      
      

      And then I added a client.policy-file that gave me all permissions.

      I then got a new exception:
      [echo] Runs Test ESB Message Sender
       [java] 15:01:47,951 WARN [main][MarshalFactory] Found marshaller fully qualified class name within
       locator parameters, but was unable to load class: org.jboss.jms.wireformat.JMSWireFormat
      

      I haven't figured that one out yet..

      Anything I should know about, when it comes to configuring the ESB in the CP1-version? I've installed it in an environment equal to the one I've used with 4.2.1.GA, is that correct? Or should I change appserver version og JMS version or..?

      Regards, Haagen

        • 1. Re: Problems with CP1
          Kevin Conner Master

          It sounds as if your configuration is forcing the client to download classes over RMI, this should not be necessary.

          What environment are you using?

          • 2. Re: Problems with CP1
            Haagen Hasle Novice

            JBoss AS 4.2.1.GA
            JBoss Messaging 1.4.0.SP1
            Patched jboss-remoting.jar: JBoss Remoting 2.2.2.SP1-brew
            JBossWS 2.0.0

            (The same as I have for JBossESB 4.2.1.GA)

            Regards, Haagen

            • 3. Re: Problems with CP1
              Kevin Conner Master

              It looks like there may be a compatibility issue with some of the libraries used, possibly with JBM. Can you try using the esb server instead of installing into the appserver?

              We will shortly be moving this branch back into trunk and will revalidate it against the app server at that time.

              • 4. Re: Problems with CP1
                Haagen Hasle Novice

                I'll be glad to, but I'm not really sure how to do that.. I thought the esb-server was just a stripped down version of the application server, where you removed EJB and some other things? (Or are you talking about something else?)

                Can you point me in the right direction?

                Regards, Haagen

                • 5. Re: Problems with CP1
                  Kurt Stam Master

                  Kevins means just to get the jbossesb-server download, where everything is installed.

                  So get jbossesb-server-4.2.1GA.zip from here

                  http://labs.jboss.com/jbossesb/downloads/

                  which should get you passed any compatibility issues you may have.

                  --Kurt

                  • 6. Re: Problems with CP1
                    Haagen Hasle Novice

                    Oh, I know I can use the 4.2.1GA version, I'm already doing that. I'm trying out the CP1-branch cause I was told to by you guys, to check if the issues I'm having are still there. In fact, "try the CP1-branch" is an answer I've been given a lot lately.. : :-)

                    Regards, Haagen

                    • 7. Re: Problems with CP1
                      Kurt Stam Master

                      ROFL sorry, yeah, if you run the 'ant dist' target one of the things it builds is the jbossesb-server. (Based on CP if that's where you are in). So try that. Sorry lol.

                      --Kurt

                      • 8. Re: Problems with CP1
                        Kevin Conner Master

                        Yep, the one created by the CP1 branch is the server I was referring to. You should find it in product/build/jbossesb-server-4.2.1GA after you have created the distribution.

                        There have been a lot of changes in the CP1 branch, most of which are a consequence of the platform work we have been involved with. We intend to move these across to the trunk very soon and then requalify against the AS.

                        Having said that I am not sure what could be causing your original problem. The fact that you are having to enable the security manager suggests you are trying to download a class from the server which does not exist on the local classpath. If you could let us know what the original failure was (before you enabled the security manager) then it may help.

                        Kev

                        • 9. Re: Problems with CP1
                          Haagen Hasle Novice

                          Using the jbossesb-server worked like a charm, thanks! (I didn't know I could build it from source like that.)

                          Do you still want me to send you the original exception?

                          I see that you have upgraded JBossWS to 2.01 in this version. I installed 2.0.0 in my appserver, I don't know if that might have caused some problems?

                          I have another problem though.. I deploy my application, and all is good. No complaints from the server. But when I try to access one of my services, it fails. As far as I can tell, the couriers pickup always returns null. Has anything been changed in this version when it comes to defining the reply-queues or anything like that?

                          Regards, Haagen

                          • 10. Re: Problems with CP1
                            Kevin Conner Master

                            One question for you. Do you have the jboss-messaging-client.jar in the top level client directory of the AS?

                            Thanks

                            • 11. Re: Problems with CP1
                              Haagen Hasle Novice

                               

                              "Kevin.Conner@jboss.com" wrote:
                              One question for you. Do you have the jboss-messaging-client.jar in the top level client directory of the AS?

                              Thanks


                              I'm not sure if this question is related to the problems I originally had, with the SecurityManager, or the problems I see now, with messages not being picked up?

                              So I'll guess I'll try to answer both cases. In the jbossesb-server-4.2.1.CP1, which I'm now running, I have the jar-file. In the application server that I installed the CP1-esb in before, I see that I did not.

                              Regards, Haagen

                              • 12. Re: Problems with CP1
                                Kevin Conner Master

                                Thanks Haagen.

                                It was a guess as to what may have been causing your original failure. We will look into it in more details shortly but this does seem to be a likely candidate.

                                Thanks again,
                                Kev

                                • 13. Re: Problems with CP1
                                  Haagen Hasle Novice

                                  Any guesses as to what may cause my new problems? I can't get the CP1-esb to work properly, it seems messages are lost when sent with JMS..

                                  Are there any configuration-changes or code-changes to you know of that can cause this, anything I need to do with my code or with my setup that can make things right?

                                  Regards, Haagen

                                  • 14. Re: Problems with CP1
                                    Daniel Bevenius Master

                                    Hi Haagen,

                                    just to recap so that I can try to reproduce the issue you have...

                                    You are using 4_2_1_GA_CP to build and run the quickstart against the esb server in product/build/jbossesb-server-4.2.1GA.
                                    Is that correct?

                                    Which quickstart are you running?

                                    Thanks,

                                    Daniel

                                    1 2 Previous Next