1 2 Previous Next 15 Replies Latest reply on May 5, 2008 12:38 PM by M Le

    Deploy JBossESB to JBoss AS: "can't determine JMS provider"

    Zaiwen Gong Newbie

      I downloaded jbossesb-4.2.1GA.zip and JBoss 4.2.1.GA.zip. Then I tried to following the GettingStarted Guide to deploy JBossESB to JBoss AS.

      I edit jbossesb-{version}/install/deployment.properties to represent the directory where I have installed the JBoss application server and the server configuration you wish.

      Then I run 'ant' (default target) from the install directory. This should deploy JBossESB to myJBossAS instance.

      HOWEVER, I received error message:

      *****Can't determine JMS provider.*****

      Has anyone tested those steps before they are posted? It seems JBoss AS 4.2.1 doesn't have JBoss Message as default JMS provider. How to solve? Thanks a lot!

        • 1. Re: Deploy JBossESB to JBoss AS:
          Kevin Conner Master

          The installation attempts to determine whether you are using JBossMessaging or JBossMQ so that it can install the appropriate JMS configuration.

          This message means that it has been unable to locate the files used as indicators.

          Try running it again with the '-v' flag, this will show you which files ant is looking for.

          • 2. Re: Deploy JBossESB to JBoss AS:
            Zaiwen Gong Newbie

            I figured out why.

            When I specify the JBoss AS Home, I should use double slash instead of single slash.

            \\

            • 3. Re: Deploy JBossESB to JBoss AS:
              M Le Newbie

              Zaiwen,

              has you ever tried the TrailBlazer sample? I'm trying this out but got exactly the same message as yours, "Can't determine JMS provider". If you get the TrailBlazer running successfully, can you please give me some instructions on this. If not, can someone who got it running help me out please.

              Thanks.
              ML

              • 4. Re: Deploy JBossESB to JBoss AS:
                M Le Newbie

                 

                "MLe6644" wrote:
                Zaiwen,

                has you ever tried the TrailBlazer sample? I'm trying this out but got exactly the same message as yours, "Can't determine JMS provider" when I ran "ant deploy". If you get the TrailBlazer running successfully, can you please give me some instructions on this. If not, can someone who got it running help me out please.


                Thanks.
                ML


                • 5. Re: Deploy JBossESB to JBoss AS:
                  Kevin Conner Master

                  It is trying to determine which JMS provider you have by looking for specific files. The error is likely to be in your property file.

                  Are you on Windows by any chance? If so, use a double backslash instead of a single one in the directory names.

                  You could also try running with 'ant -v' and see which files the build is looking for.

                  • 6. Re: Deploy JBossESB to JBoss AS:
                    M Le Newbie

                    Thanks Kevin for your help. I did try \\ but it did not help. First, let me ask you this. Is the jsbesb-4.2.1GA.zip the right zip file for the TrailBlazer sample or should I get the jsbesb-server-4.2.1GA.zip? In fact, I tried both zip files and both I had different types of errors. Also, do I need to get tomcat installed on my computer? I did try "ant -v" option on the jsbesb-4.2.1GA dir and I got the following errors:

                    Apache Ant version 1.7.0 compiled on December 13 2006
                    Buildfile: build.xml
                    Detected Java version: 1.5 in: C:\Program Files\Java\jdk1.5.0_08\jre
                    Detected OS: Windows XP
                    parsing buildfile D:\jbossesb-4.2.1GA\install\build.xml with URI = file:/D:/jbossesb-4.2.1GA/install
                    /build.xml
                    Project base dir set to: D:\jbossesb-4.2.1GA\install
                    [antlib:org.apache.tools.ant] Could not load definitions from resource org/apache/tools/ant/antlib.x
                    ml. It could not be found.
                    [property] Loading D:\jbossesb-4.2.1GA\install\deployment.properties
                    [available] Unable to find D:\jbossesb-4.2.1GA\build-distr.xml
                    [available] Found: D:\jbossesb-4.2.1GA\JBossORG-EULA.txt
                    [available] Unable to find D:\apache-tomcat-5.5.20\common\lib to set property org.jboss.esb.tomcat.l
                    ib
                    [available] Unable to find D:\apache-tomcat-5.5.20\lib to set property org.jboss.esb.tomcat.lib
                    Property "org.jboss.esb.dist.lib" has not been set
                    Property "org.jboss.esb.tomcat.lib" has not been set
                    Build sequence for target(s) `deploy' is [check.deploy.props, dependencies.source, dependencies.jbos
                    sesb, dependencies, jms.config.check, jbmq.config, jbm.config, jms.config, internal.deploy, init.bin
                    dings.props, deploy.bindings, deploy]
                    Complete build sequence is [check.deploy.props, dependencies.source, dependencies.jbossesb, dependen
                    cies, jms.config.check, jbmq.config, jbm.config, jms.config, internal.deploy, init.bindings.props, d
                    eploy.bindings, deploy, undeploy.bindings, undeploy, apply-jbossws-xslt, check.tomcat.props, tomcat.
                    compile, tomcat.war.all.deploy, tomcat, patch-jbossws, deployIntros, ]

                    check.deploy.props:

                    dependencies.source:
                    Skipped because property 'hierarchy.source' not set.

                    dependencies.jbossesb:

                    dependencies:

                    jms.config.check:
                    [available] Unable to find D:\jbossesb-4.2.1GA\server\default\deploy\jboss-messaging to set property
                    jbm.present
                    [available] Unable to find D:\jbossesb-4.2.1GA\server\default\deploy\jboss-messaging.sar to set prop
                    erty jbm.present
                    [available] Unable to find D:\jbossesb-4.2.1GA\server\default\deploy\jms\jbossmq-service.xml to set
                    property jbmq.present
                    [available] Unable to find D:\jbossesb-4.2.1GA\server\default\deploy-hasingleton\jms\jbossmq-service
                    .xml to set property jbmq.present

                    BUILD FAILED
                    D:\jbossesb-4.2.1GA\install\build.xml:67: Could not determine JMS provider
                    at org.apache.tools.ant.taskdefs.Exit.execute(Exit.java:142)
                    at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
                    at sun.reflect.GeneratedMethodAccessor2.invoke(Unknown Source)
                    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                    at java.lang.reflect.Method.invoke(Method.java:585)
                    at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
                    at org.apache.tools.ant.Task.perform(Task.java:348)
                    at org.apache.tools.ant.Target.execute(Target.java:357)
                    at org.apache.tools.ant.Target.performTasks(Target.java:385)
                    at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1329)
                    at org.apache.tools.ant.Project.executeTarget(Project.java:1298)
                    at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
                    at org.apache.tools.ant.Project.executeTargets(Project.java:1181)
                    at org.apache.tools.ant.Main.runBuild(Main.java:698)
                    at org.apache.tools.ant.Main.startAnt(Main.java:199)
                    at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
                    at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)


                    Based on the error messages, it seems like the jbosesb-4.2.1GA has missed the build-distr.xml and the properties jbm.present and jbmq.present must be set? How can I resolve these issues? Please help. Thanks.

                    • 7. Re: Deploy JBossESB to JBoss AS:
                      Zaiwen Gong Newbie

                      Hi MLE6644,

                      I can help you with this question.

                      If you use jbossesb-4.2.1GA.zip, you need to deploy it to your JBoss-4.2.1GA server.

                      It is better you just use the standalone Jbossesb-server-4.2.1GA.zip. This one is complete and you can start it as your JBoss ESB server.

                      However, even this Jbossesb-server-4.2.1GA doesn't have EJB3, which you need to run the sample TrailBlazer. To add EJB3 to standalone JBoss ESB server, you need to install JBoss AS JEMS installer and select the "EJB3" install configuration to get the right one installed.

                      No, you don't need to get tomcat installed on my computer if you use the complete standalone Jboss ESB server. It already contains the JBoss AS.

                      • 8. Re: Deploy JBossESB to JBoss AS:
                        M Le Newbie

                        Zaiwen,

                        Thanks so much for your help. Your response does explain what I have been consfusing so far. I'm going to download the Jboss AS JEMS Installer now to try it out. Just one last question before I try out your suggestion. Is it matter which version of JEMS Installer that I need to download? There are several ones out there on jboss.org, should I just get the latest one, version 1.2.1.CR4?

                        Thanks.

                        ML

                        • 9. Re: Deploy JBossESB to JBoss AS:
                          Zaiwen Gong Newbie

                          I haven't tried JEMS installer yet, because I don't need EJB3 now. I guess the latest one should be ok....

                          • 10. Re: Deploy JBossESB to JBoss AS:
                            M Le Newbie

                            Zaiwen,

                            I got the EJB3 installed but still can't deploy the trailblazer services. When I looked at the build.xml of the trailblazer, I saw the following:




                            However, the install directory did not even come with jbossesb-server-4.2.1GA. I could find install directory in jbossesb-4.2.1GA but then this version does NOT even has run.bat for me to start the JBoss ESB server. This is where my confusion comes.

                            If you have run the TrailBlazer sample, can you please tell me what the steps are, like, what to run and what to build?

                            Thanks very much.

                            ML

                            • 11. Re: Deploy JBossESB to JBoss AS:
                              Kevin Conner Master

                               

                              "MLe6644" wrote:
                              [available] Unable to find D:\jbossesb-4.2.1GA\server\default\deploy\jboss-messaging to set property
                              jbm.present
                              [available] Unable to find D:\jbossesb-4.2.1GA\server\default\deploy\jboss-messaging.sar to set prop
                              erty jbm.present
                              [available] Unable to find D:\jbossesb-4.2.1GA\server\default\deploy\jms\jbossmq-service.xml to set
                              property jbmq.present
                              [available] Unable to find D:\jbossesb-4.2.1GA\server\default\deploy-hasingleton\jms\jbossmq-service
                              .xml to set property jbmq.present

                              The installation script has been told to look in your ESB installation but it should be looking for an application server installation. The property file should refer to the location of the Application Server into which you are trying to install. Check you values in D:\jbossesb-4.2.1GA\install\deployment.properties.

                              "MLe6644" wrote:
                              Based on the error messages, it seems like the jbosesb-4.2.1GA has missed the build-distr.xml and the properties jbm.present and jbmq.present must be set? How can I resolve these issues?

                              The build-distr.xml is only available in the source hierarchy, it is not present in the binary or standalone downloads. One of the properties should be set if you change the org.jboss.esb.server.home property so that it points to your application server installation.


                              • 12. Re: Deploy JBossESB to JBoss AS:
                                M Le Newbie

                                 

                                "MLe6644" wrote:
                                Zaiwen,

                                I got the EJB3 installed but still can't deploy the trailblazer services. When I looked at the build.xml of the trailblazer, I saw the following:

                                property name="install.dir" value="${esb.home.dir}/install"
                                property file="${install.dir}/deployment.properties"

                                However, the install directory did not even come with jbossesb-server-4.2.1GA. I could find install directory in jbossesb-4.2.1GA but then this version does NOT even has run.bat for me to start the JBoss ESB server. This is where my confusion comes.

                                If you have run the TrailBlazer sample, can you please tell me what the steps are, like, what to run and what to build?

                                Thanks very much.

                                ML


                                • 13. Re: Deploy JBossESB to JBoss AS:
                                  Zaiwen Gong Newbie

                                  Sorry for the last update..something wrong with my home computer :)

                                  In trailbrzer's build.xml,




                                  You can ignore these two lines for standalone jbossesb-server-4.2.1GA.

                                  Update this line to point to your jbossesb-server-4.2.1GA directory value.


                                  Actually if you don't move your trailbrzer, it is the same as this value:


                                  The original build.xml should be released in a way that user doesn't need to update it if everything is default.

                                  • 14. Re: Deploy JBossESB to JBoss AS:
                                    Kevin Conner Master

                                    Hiya Zaiwen.

                                    I have deleted the errant posting but we have missed most of your last one.

                                    MLe6644, please use the version with the installer and fix the properties as mentioned earlier.

                                    Zaiwen, the build.xml should have been fixed in the latest release (coming real soon)

                                    1 2 Previous Next