1 2 Previous Next 18 Replies Latest reply on Mar 18, 2010 1:49 PM by christine karman

    source project installation problem

    christine karman Newbie

      I have tried to install the GateIn source project. I have run "mvn install" in the project root dir, but I get the following errors:

       

      [INFO] ------------------------------------------------------------------------
      [INFO] Building GateIn Portal Component Common
      [INFO]    task-segment: [install]
      [INFO] ------------------------------------------------------------------------
      [WARNING] POM for 'org.jboss:jboss-vfs:pom:2.1.0.GA:compile' is invalid.

       

      Its dependencies (if any) will NOT be available to the current build.
      [WARNING] POM for 'commons-httpclient:commons-httpclient:pom:3.0:compile' is invalid.

       

      Its dependencies (if any) will NOT be available to the current build.
      [WARNING] POM for 'org.codehaus.woodstox:wstx-asl:pom:3.2.1:compile' is invalid.

       

      Its dependencies (if any) will NOT be available to the current build.
      [WARNING] POM for 'org.reflext:reflext.api:pom:1.0.0-beta5:test' is invalid.

       

      Its dependencies (if any) will NOT be available to the current build.
      [WARNING] POM for 'org.reflext:reflext.core:pom:1.0.0-beta5:test' is invalid.

       

      Its dependencies (if any) will NOT be available to the current build.
      [WARNING] POM for 'org.reflext:reflext.spi:pom:1.0.0-beta5:test' is invalid.

       

      Its dependencies (if any) will NOT be available to the current build.
      [WARNING] POM for 'org.reflext:reflext.jlr:pom:1.0.0-beta5:test' is invalid.

       

      Its dependencies (if any) will NOT be available to the current build.
      [INFO] ------------------------------------------------------------------------
      [ERROR] BUILD ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] Error building POM (may not be this project's POM).

       


      Project ID: null:reflext.apt:jar:null

       

      Reason: Cannot find parent: org.reflext:reflext.parent for project: null:reflext.apt:jar:null for project null:reflext.apt:jar:null

       

      In eclipse, most of the dependencies are not resolved (after mvn eclipse:eclipse) because mvn apparently hasn't downloaded the proper jar files. Is there anything I can do to fix this? Is there a download containing all jars?

        1 2 Previous Next