2 Replies Latest reply on Apr 14, 2010 5:54 PM by Sten Aksel Heien

    What are needed in settings.xml to run examples?

    Sten Aksel Heien Newbie

      What are needed in settings.xml to run test-examples directly as described in Ref. Guide (1.0.0.Alpha1)?

       

      When I started from Ref. Guide, I had to build Arquillian from trunk first (not mentioned) in this order:

      1 arquillian-build,

      2 arquillian-parent

       

      To run tests described in  Ref. Guide, I also had to build arquillian-example-domain first.

       

      - Sten Aksel

        • 1. Re: What are needed in settings.xml to run examples?
          Aslak Knutsen Master

          I have nothing extra in my settings.xml. Using Maven 2.2.1.

           

          {code}

          svn co http://anonsvn.jboss.org/repos/common/arquillian/tags/1.0.0.Alpha1/ arquillian

          cd arquillian

          mvn install

           

          [INFO] Scanning for projects...
          [INFO] Reactor build order:
          [INFO]   Arquillian Build
          [INFO]   Arquillian API
          [INFO]   Arquillian SPI
          [INFO]   Arquillian Implementation Base
          [INFO]   Arquillian TestRunner JUnit
          [INFO]   Arquillian TestRunner TestNG
          [INFO]   Arquillian Protocol Servlet
          [INFO]   Arquillian Protocol Local
          [INFO]   Arguillian Aggregator
          [INFO]   Arguillian Protocol Aggregator
          [INFO]   Arquillian TestEnricher CDI
          [INFO]   Arquillian TestEnricher EJB
          [INFO]   Arquillian TestEnricher Resource
          [INFO]   Arguillian TestEnricher Aggregator
          [INFO]   Arquillian Packager Java EE
          [INFO]   Arquillian Packager ApplicationArchive
          [INFO]   Arguillian Packager Aggregator
          [INFO]   Arquillian Container Jboss AS Remote 5.1
          [INFO]   Arquillian Container Jboss AS Remote 6.0
          [INFO]   Arquillian Container Glassfish Embedded 3.0
          [INFO]   Arquillian Container Weld Embedded
          [INFO]   Arquillian Container OpenEJB
          [INFO]   Arguillian Container Aggregator
          [INFO]   Arquillian Example Domain
          [INFO]   Arquillian Example JUnit
          [INFO]   Arquillian Example TestNG
          [INFO]   Arguillian Example Aggregator
          [INFO]   Arquillian Reference Guide

          {code}

           

          * start JBoss AS 6.0.0.M2 *

           

           

          {code}

          mvn test -P jbossas-remote-60 -f examples/junit/pom.xml

           

          ------------------------------------------------------- T E S T S ------------------------------------------------------- Running com.acme.cdi.InjectionTestCase Tests run: 1, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 5.2 sec Running com.acme.resource.InjectionTestCase Tests run: 1, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 1.226 sec Running com.acme.ejb.TemperatureConverterTestCase Tests run: 3, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 1.2 sec Running com.acme.jms.InjectionTestCase Tests run: 1, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 2.636 sec Running com.acme.cdi.random.RandomTestCase Tests run: 1, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 2.554 sec Running com.acme.cdi.payment.SynchronousPaymentProcessorTestCase Tests run: 1, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 1.695 sec Running com.acme.ejb.InjectionTestCase Tests run: 1, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 1.121 sec Results : Tests run: 9, Failures: 0, Errors: 0, Skipped: 0

          {code}
          • 2. Re: What are needed in settings.xml to run examples?
            Sten Aksel Heien Newbie

            I confirm that everything now is working fine, and I have the same behaviour as Aslak - nothing needed in settings xml.

            My relativePath patch (see - https://jira.jboss.org/jira/browse/ARQ-100 ) fixed the issues I had.

             

            To find bugs like this Arquillian should have a Hudson task starting with an empty maven repository (use a path to an empty directory configured for <localRepository> in settings.xml)