8 Replies Latest reply on Jul 18, 2010 7:16 AM by Aslak Knutsen

    Problem building Arquillian Trunk

    David Bosschaert Expert

      I'm trying to build Arquillian from trunk but I get a missing dependency...

       

      I'm using Maven 3.0 beta 1 and my settings.xml is as in the Maven Getting Started - Developers page.

       

      Below the error. Help appreciated

       

      $ mvn install
      [INFO] Scanning for projects...
      [ERROR] The build could not read 1 project -> [Help 1]
      [ERROR]   The project org.jboss.arquillian.container:arquillian-weld-ee-embedded-1.1:1.0.0-SNAPSHOT (/home/davidb/checkouts/arquillian/containers/weld-ee-embedded-1.1/pom.xml) has 4 errors
      [ERROR]     Non-resolvable import POM org.jboss.weld:weld-api-bom:1.0-SNAPSHOT: Failed to resolve POM for org.jboss.weld:weld-api-bom:1.0-SNAPSHOT due to Missing:
      ----------
      1) org.jboss.weld:weld-api-bom:pom:1.0-SNAPSHOT
      ----------
      1 required artifact is missing.

       

      for artifact:
        org.jboss.weld:weld-api-bom:pom:1.0-SNAPSHOT

       

      from the specified remote repositories:
        jboss-public-repository-group (http://repository.jboss.org/nexus/content/groups/public/, releases=true, snapshots=true),
        weld-sonatype (https://oss.sonatype.org/content/repositories/jboss-snapshots/, releases=false, snapshots=true),
        jboss-deprecated (https://repository.jboss.org/nexus/content/repositories/deprecated/, releases=true, snapshots=false),
        oss.sonatype.org/jboss-snapshots (http://oss.sonatype.org/content/repositories/jboss-snapshots, releases=false, snapshots=true),
        central (http://repo1.maven.org/maven2, releases=true, snapshots=false)
      @ org.jboss.weld:weld-core-bom:1.0.2-SNAPSHOT
          -> [Help 2]
      [ERROR]     'dependencies.dependency.version' for org.jboss.weld:weld-api:jar is missing.
      [ERROR]     'dependencies.dependency.version' for org.jboss.weld:weld-core:jar is missing.
      [ERROR]     'dependencies.dependency.version' for org.slf4j:slf4j-simple:jar is missing.
      [ERROR]
      [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
      [ERROR] Re-run Maven using the -X switch to enable full debug logging.
      [ERROR]
      [ERROR] For more information about the errors and possible solutions, please read the following articles:
      [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
      [ERROR] [Help 2] http://cwiki.apache.org/confluence/display/MAVEN/UnresolvableModelException