1 Reply Latest reply on Nov 19, 2010 5:14 PM by Felix Gonschorek

    Javassist 3.12.1.GA maven repository checksum error

    Andy Blower Newbie

      I’m not sure this is the right place to ask this, but it’s the closest I could find. Please let me know if there’s a more appropriate place to ask for help with this.

       

      I'm trying to migrate our application to Tapestry 5.2, but I'm getting a checksum error with Javassist 3.12.1.GA which is a dependency.

       

      C:\tmp>fciv -sha1 javassist-3.12.1.GA.jar

      526633327faa61aee448a519e8a4d53ec3057885                  javassist-3.12.1.ga.jar

       

      http://repository.jboss.org/nexus/content/groups/public-jboss/javassist/javassist/3.12.1.GA/javassist-3.12.1.GA.jar.sha1

       

      5e1f0b5574efb7b16be9b1b47195a5be0b65a365

       

       

      Anyone else had this problem? I looked at 3.9.0.GA as used by Tapestry 5.1 and that is fine from the same repository. So is this a mistake in the checksum or am I doing something wrong? Should I be using a different repository? I’ve checked the following:

       

      http://repo2.maven.org/maven2/javassist/javassist/          - only up to 3.8.0.GA

      http://repository.jboss.org/maven2/javassist/javassist/     - only up to 3.11.0.GA

      https://repository.jboss.org/nexus/                                - only 3.13.0 on here it seems

       

      Thanks,

       

      Andy Blower.