6 Replies Latest reply on Sep 1, 2010 9:30 AM by Younes Yahyaoui

    boxgrinder-build failed???

    Younes Yahyaoui Novice

      Hallo,

       

      i have tried to run the BoxGrinder quickstart with the same data http://community.jboss.org/wiki/BoxGrinderBuildQuickStart . I become but the following error:

       

       

      [root@linux appliances]# boxgrinder-build -V --trace  f13-basic.appl 
      D, [2010-09-01T01:47:37.426863 #2740] DEBUG -- : Loading os plugins...
      D, [2010-09-01T01:47:37.427117 #2740] DEBUG -- : We have 1 os plugin(s) registered
      D, [2010-09-01T01:47:37.427244 #2740] DEBUG -- : - fedora plugin for Fedora.
      D, [2010-09-01T01:47:37.427360 #2740] DEBUG -- : Plugins loaded.
      D, [2010-09-01T01:47:37.427472 #2740] DEBUG -- : Loading platform plugins...
      D, [2010-09-01T01:47:37.427583 #2740] DEBUG -- : We have 2 platform plugin(s) registered
      D, [2010-09-01T01:47:37.427697 #2740] DEBUG -- : - vmware plugin for VMware.
      D, [2010-09-01T01:47:37.427816 #2740] DEBUG -- : - ec2 plugin for Amazon Elastic Compute Cloud (Amazon EC2).
      D, [2010-09-01T01:47:37.427925 #2740] DEBUG -- : Plugins loaded.
      D, [2010-09-01T01:47:37.428036 #2740] DEBUG -- : Loading delivery plugins...
      D, [2010-09-01T01:47:37.428172 #2740] DEBUG -- : We have 5 delivery plugin(s) registered
      D, [2010-09-01T01:47:37.428292 #2740] DEBUG -- : - s3 plugin for Amazon Simple Storage Service (Amazon S3).
      D, [2010-09-01T01:47:37.428409 #2740] DEBUG -- : - cloudfront plugin for Amazon Simple Storage Service (Amazon S3).
      D, [2010-09-01T01:47:37.428522 #2740] DEBUG -- : - ami plugin for Amazon Simple Storage Service (Amazon S3).
      D, [2010-09-01T01:47:37.428634 #2740] DEBUG -- : - sftp plugin for SSH File Transfer Protocol.
      D, [2010-09-01T01:47:37.428752 #2740] DEBUG -- : - local plugin for Local file system.
      D, [2010-09-01T01:47:37.428860 #2740] DEBUG -- : Plugins loaded.
      D, [2010-09-01T01:47:37.431940 #2740] DEBUG -- : Reading definition from 'f13-basic.appl' file...
      /usr/lib/ruby/gems/1.8/gems/boxgrinder-core-0.0.22/lib/boxgrinder-core/helpers/appliance-helper.rb:68:in `read_yaml': File 'f13-basic.appl' could not be read. (RuntimeError)
          from /usr/lib/ruby/gems/1.8/gems/boxgrinder-core-0.0.22/lib/boxgrinder-core/helpers/appliance-helper.rb:38:in `read_definitions'
          from /usr/lib/ruby/gems/1.8/gems/boxgrinder-build-0.5.1/lib/boxgrinder-build/appliance.rb:42:in `create'
          from /usr/lib/ruby/gems/1.8/gems/boxgrinder-build-0.5.1/bin/boxgrinder-build:88
          from /usr/lib/ruby/gems/1.8/gems/commander-4.0.3/lib/commander/command.rb:180:in `call'
          from /usr/lib/ruby/gems/1.8/gems/commander-4.0.3/lib/commander/command.rb:180:in `call'
          from /usr/lib/ruby/gems/1.8/gems/commander-4.0.3/lib/commander/command.rb:155:in `run'
          from /usr/lib/ruby/gems/1.8/gems/commander-4.0.3/lib/commander/runner.rb:385:in `run_active_command'
          from /usr/lib/ruby/gems/1.8/gems/commander-4.0.3/lib/commander/runner.rb:74:in `run!'
          from /usr/lib/ruby/gems/1.8/gems/commander-4.0.3/lib/commander/delegates.rb:7:in `run!'
          from /usr/lib/ruby/gems/1.8/gems/commander-4.0.3/lib/commander/import.rb:10
          from /usr/bin/boxgrinder-build:19

       

      can someone please help me? I think that the error is due to the buildenvironemnt and the meta-appliance.

       

      I will appreciate any help.

       

       

      Regards

       

      Younes