1 2 Previous Next 17 Replies Latest reply: Nov 24, 2010 5:40 AM by Michael Musgrove RSS

    btadmin startup gives Application error

    Saravanan A Newbie

      Changes made :-

       

      OS : Windows XP sp3

      Compiler Used: Visual studio 2010 Express edition

       

      In setenv.bat

       

      set BLACKTIE_HOME=C:\Users\Saravanan\Software\blacktie-2.0.0.Final
      set JBOSSAS_IP_ADDR=Saravanan

      set BLACKTIE_HOME=C:\Users\Saravanan\Software\blacktie-2.0.0.Final

      set JBOSSAS_IP_ADDR=Saravanan

      Command used to start the JBOSS AS
      run.bat -c all -b Saravanan
      blacktie-j.log
      2010-11-23 00:26:27,827 [main]           DEBUG (conf.XMLParser           :67  ) - SCHEMA DIR: C:\Users\Saravanan\Software\blacktie-2.0.0.Final\schemas\xsd
      2010-11-23 00:26:27,921 [main]           DEBUG (conf.XMLParser           :116 ) - read configuration from null directory
      2010-11-23 00:26:27,937 [main]           DEBUG (conf.XMLEnvHandler       :322 ) - blacktie.orb.arg.1 is -ORBInitRef
      2010-11-23 00:26:27,937 [main]           DEBUG (conf.XMLEnvHandler       :322 ) - blacktie.orb.arg.2 is NameService=corbaloc::Saravanan:3528/NameService
      2010-11-23 00:26:27,937 [main]           DEBUG (conf.XMLEnvHandler       :325 ) - blacktie.orb.args is 2
      2010-11-23 00:26:27,952 [main]           DEBUG (btadmin.CommandHandler   :152 ) - Command was known
      2010-11-23 00:26:27,952 [main]           DEBUG (commands.Startup         :87  ) - Listing machines
      2010-11-23 00:26:27,952 [main]           INFO  (conf.Server              :51  ) - Checking for host: Saravanan or ip: 192.168.2.3
      2010-11-23 00:26:27,952 [main]           DEBUG (commands.Startup         :94  ) - Found machine
      2010-11-23 00:26:27,968 [main]           DEBUG (commands.Startup         :111 ) - Launched server: C:\Users\Saravanan\Software\blacktie-2.0.0.Final/examples/xatmi/fooapp/server
      2010-11-23 00:26:28,812 [main]           INFO  (commands.Startup         :121 ) -
      When i run the command "btadmin startup", application crashes.  Please find the attached screenshot.
      Saravanan A

        • 1. Re: btadmin startup gives Application error
          Saravanan A Newbie

          2010-11-23 01:36:41,640 [0x00000d90] DEBUG (AtmiBrokerInit           :50  ) - Constructed
          2010-11-23 01:36:41,640 [0x00000d90] DEBUG (AtmiBrokerServer         :127 ) - serverinit getting config
          2010-11-23 01:36:41,640 [0x00000d90] DEBUG (AtmiBrokerServer         :155 ) - serverinit beginning configuration
          2010-11-23 01:36:41,656 [0x00000d90] TRACE (SynchronizableObject     :39  ) - Acquiring mutex: 10054E88
          2010-11-23 01:36:41,656 [0x00000d90] TRACE (SynchronizableObject     :41  ) - acquired: 10054E88
          2010-11-23 01:36:41,656 [0x00000d90] DEBUG (AtmiBrokerEnv            :55  ) - Creating AtmiBrokerEnv
          2010-11-23 01:36:41,656 [0x00000d90] DEBUG (AtmiBrokerEnv            :130 ) - constructor
          2010-11-23 01:36:41,656 [0x00000d90] DEBUG (AtmiBrokerEnv            :109 ) - setting configuration to null
          2010-11-23 01:36:41,656 [0x00000d90] DEBUG (AtmiBrokerEnv            :124 ) - setting configuration to null
          2010-11-23 01:36:41,656 [0x00000d90] DEBUG (AtmiBrokerEnv            :319 ) - readenv
          2010-11-23 01:36:41,656 [0x00000d90] DEBUG (AtmiBrokerEnv            :325 ) - readenv default configuration
          2010-11-23 01:36:41,656 [0x00000d90] TRACE (AtmiBrokerEnvXml         :649 ) - read env from default file
          2010-11-23 01:36:41,656 [0x00000d90] DEBUG (AtmiBrokerEnvXml         :654 ) - BLACKTIE_CONFIGURATION:
          2010-11-23 01:36:41,656 [0x00000d90] DEBUG (AtmiBrokerEnvXml         :670 ) - schemaPath is C:\Users\Saravanan\Software\blacktie-2.0.0.Final\schemas\xsd\btconfig.xsd
          2010-11-23 01:36:41,671 [0x00000d90] DEBUG (XsdValidator             :161 ) - checkFile btconfig.xml: start
          2010-11-23 01:36:41,671 [0x00000d90] DEBUG (XsdValidator             :166 ) - checkFile btconfig.xml: ok
          2010-11-23 01:36:41,671 [0x00000d90] DEBUG (XsdValidator             :104 ) - checkFile C:\Users\Saravanan\Software\blacktie-2.0.0.Final\schemas\xsd\btconfig.xsd: start
          2010-11-23 01:36:41,671 [0x00000d90] DEBUG (XsdValidator             :109 ) - checkFile C:\Users\Saravanan\Software\blacktie-2.0.0.Final\schemas\xsd\btconfig.xsd: ok
          2010-11-23 01:36:41,671 [0x00000d90] DEBUG (XsdValidator             :114 ) - create schema parser
          2010-11-23 01:36:41,687 [0x00000d90] TRACE (XsdValidator             :26  ) - Created MYHandler
          2010-11-23 01:36:41,687 [0x00000d90] DEBUG (XsdValidator             :178 ) - errorCount is 0
          2010-11-23 01:36:41,687 [0x00000d90] DEBUG (XsdValidator             :186 ) - btconfig.xml is validate with C:\Users\Saravanan\Software\blacktie-2.0.0.Final\schemas\xsd\btconfig.xsd
          2010-11-23 01:36:41,687 [0x00000d90] TRACE (XsdValidator             :31  ) - Destroyed MYHandler
          2010-11-23 01:36:41,687 [0x00000d90] DEBUG (XsdValidator             :198 ) - deleting parser
          2010-11-23 01:36:41,687 [0x00000d90] DEBUG (XsdValidator             :200 ) - deleted parser
          2010-11-23 01:36:41,687 [0x00000d90] DEBUG (AtmiBrokerEnvXml         :688 ) - read file %p10311448
          2010-11-23 01:36:41,687 [0x00000d90] DEBUG (AtmiBrokerEnvXml         :703 ) - loadfile: file %s is %d longbtconfig.xml2084
          2010-11-23 01:36:41,687 [0x00000d90] DEBUG (AtmiBrokerEnvXml         :717 ) - loadfile: Allocated enough memory to load file %d2084

          Additional information :-

           

          Blacktie.log

           

          2010-11-23 01:36:41,640 [0x00000d90] DEBUG (AtmiBrokerInit           :50  ) - Constructed

          2010-11-23 01:36:41,640 [0x00000d90] DEBUG (AtmiBrokerServer         :127 ) - serverinit getting config

          2010-11-23 01:36:41,640 [0x00000d90] DEBUG (AtmiBrokerServer         :155 ) - serverinit beginning configuration

          2010-11-23 01:36:41,656 [0x00000d90] TRACE (SynchronizableObject     :39  ) - Acquiring mutex: 10054E88

          2010-11-23 01:36:41,656 [0x00000d90] TRACE (SynchronizableObject     :41  ) - acquired: 10054E88

          2010-11-23 01:36:41,656 [0x00000d90] DEBUG (AtmiBrokerEnv            :55  ) - Creating AtmiBrokerEnv

          2010-11-23 01:36:41,656 [0x00000d90] DEBUG (AtmiBrokerEnv            :130 ) - constructor

          2010-11-23 01:36:41,656 [0x00000d90] DEBUG (AtmiBrokerEnv            :109 ) - setting configuration to null

          2010-11-23 01:36:41,656 [0x00000d90] DEBUG (AtmiBrokerEnv            :124 ) - setting configuration to null

          2010-11-23 01:36:41,656 [0x00000d90] DEBUG (AtmiBrokerEnv            :319 ) - readenv

          2010-11-23 01:36:41,656 [0x00000d90] DEBUG (AtmiBrokerEnv            :325 ) - readenv default configuration

          2010-11-23 01:36:41,656 [0x00000d90] TRACE (AtmiBrokerEnvXml         :649 ) - read env from default file

          2010-11-23 01:36:41,656 [0x00000d90] DEBUG (AtmiBrokerEnvXml         :654 ) - BLACKTIE_CONFIGURATION:

          2010-11-23 01:36:41,656 [0x00000d90] DEBUG (AtmiBrokerEnvXml         :670 ) - schemaPath is C:\Users\Saravanan\Software\blacktie-2.0.0.Final\schemas\xsd\btconfig.xsd

          2010-11-23 01:36:41,671 [0x00000d90] DEBUG (XsdValidator             :161 ) - checkFile btconfig.xml: start

          2010-11-23 01:36:41,671 [0x00000d90] DEBUG (XsdValidator             :166 ) - checkFile btconfig.xml: ok

          2010-11-23 01:36:41,671 [0x00000d90] DEBUG (XsdValidator             :104 ) - checkFile C:\Users\Saravanan\Software\blacktie-2.0.0.Final\schemas\xsd\btconfig.xsd: start

          2010-11-23 01:36:41,671 [0x00000d90] DEBUG (XsdValidator             :109 ) - checkFile C:\Users\Saravanan\Software\blacktie-2.0.0.Final\schemas\xsd\btconfig.xsd: ok

          2010-11-23 01:36:41,671 [0x00000d90] DEBUG (XsdValidator             :114 ) - create schema parser

          2010-11-23 01:36:41,687 [0x00000d90] TRACE (XsdValidator             :26  ) - Created MYHandler

          2010-11-23 01:36:41,687 [0x00000d90] DEBUG (XsdValidator             :178 ) - errorCount is 0

          2010-11-23 01:36:41,687 [0x00000d90] DEBUG (XsdValidator             :186 ) - btconfig.xml is validate with C:\Users\Saravanan\Software\blacktie-2.0.0.Final\schemas\xsd\btconfig.xsd

          2010-11-23 01:36:41,687 [0x00000d90] TRACE (XsdValidator             :31  ) - Destroyed MYHandler

          2010-11-23 01:36:41,687 [0x00000d90] DEBUG (XsdValidator             :198 ) - deleting parser

          2010-11-23 01:36:41,687 [0x00000d90] DEBUG (XsdValidator             :200 ) - deleted parser

          2010-11-23 01:36:41,687 [0x00000d90] DEBUG (AtmiBrokerEnvXml         :688 ) - read file %p10311448

          2010-11-23 01:36:41,687 [0x00000d90] DEBUG (AtmiBrokerEnvXml         :703 ) - loadfile: file %s is %d longbtconfig.xml2084

          2010-11-23 01:36:41,687 [0x00000d90] DEBUG (AtmiBrokerEnvXml         :717 ) - loadfile: Allocated enough memory to load file %d2084

          Saravanan A

          • 2. Re: btadmin startup gives Application error
            Tom Jenkinson Master

            Hi Saravanan A,

             

            I apologise for the problems you are having with BlackTie, I must confess it is rather an unusual problem that you are reporting as we do run builds on the platform you have indicated so it is strange.

             

            According to the log that you have sent, the problem is during Expat evaluation of the btconfig.xml file, I presume you do not have any other copies of expat higher up in your path (say the Windows folder or something).

             

            Assuming not, then I have built a replacement atmibroker-core.lib and .dll which I would appreciate if you could replace the one in your BT_HOME/lib/cxx folder with (*be sure to create a backup of the originals first!*). This just has some more debug around the expat usage.

             

            I have uploaded the patch to:

            http://community.jboss.org/servlet/JiveServlet/download/13243-51-21737/atmibroker-core.zip

             

            By the way, btadmin is just a wrapper to help launch the server (especially useful when dealing with multiple servers on the same machine). For this example you don't actually need to launch the server using btadmin and can just type:

            server.exe -i 1

            This may help with tracking down the issue.

            Also, before running the server each time, please delete the blacktie.log so you can see the result of the run easily.

             

            Thanks for your patience!

            Tom

            • 3. Re: btadmin startup gives Application error
              Michael Musgrove Master

              I don't see any evidence of a problem parsing the config file. I'd like to get a look at the JBossAS log file (up to when it booted) and the BlackTie log.

              • 4. Re: btadmin startup gives Application error
                Tom Jenkinson Master

                Hi,

                 

                I am working on the assumption that Saravanan A has posted the entire blacktie.log. In which case it appears that the application has crashed attempting to parse the btconfig.xml as we would expect the next line of debug to read:

                 

                2010-11-23 09:40:47,724 [0x7f3b9a052760] TRACE (AtmiBrokerEnvXml         :728 ) - reading file

                 

                Saravanan A, please can you also confirm that the blacktie.log you posted was the entire file?

                 

                Thanks,

                Tom

                • 5. Re: btadmin startup gives Application error
                  Saravanan A Newbie

                  Hi

                   

                  blacktie.log that i have posted is a complete file.  Please find the attached log after replacing the atmibroker-core.* in lib folder

                   

                  Saravanan A

                  • 6. Re: btadmin startup gives Application error
                    Tom Jenkinson Master

                    Hi Saravanan A,

                     

                    Thanks for the update, and once again sorry for the problems you are having. I can see from the debug, the problem is definitely creating the expat XML_Parser, can I ask you to confirm you definitely do not have an alternative expat dll.

                     

                    Please can you try the attached atmibroker-core-2.zip? It has the call to creating the parser in a try {} catch block so maybe we will get more information..

                     

                    Thanks,

                    Tom

                    • 7. Re: btadmin startup gives Application error
                      Amos Feng Novice

                      Hi Saravanan A,

                      I also think the problem with expat.dll, can you paste the result of command 'echo %PATH%' ?

                       

                      Thansk,

                      Amos

                      • 8. Re: btadmin startup gives Application error
                        Saravanan A Newbie

                        Hi,

                         

                        Thanks for the quick response.  This problem is due to pointing incorrect expat.dll file.

                         

                        Suggestion:-

                        In setEnv.sh|bat file

                         

                        Instead of

                        set PATH=%PATH%;%BLACKTIE_HOME%\bin

                        set PATH=%PATH%;%BLACKTIE_HOME%\lib\cxx

                        set PATH=%PATH%;.

                        if replaced as below will avoid these problems

                        set PATH=%BLACKTIE_HOME%\bin;%PATH%
                        set PATH=%BLACKTIE_HOME%\lib\cxx;%PATH%;

                        set PATH=.;%PATH%

                         

                        set PATH=%BLACKTIE_HOME%\bin;%PATH%

                        set PATH=%BLACKTIE_HOME%\lib\cxx;%PATH%;

                        set PATH=.;%PATH%

                        Now it proceeds but serverinit failed.
                        Command Prompt output:-
                        2010-11-23 21:56:01,468 [0x000017bc] WARN  (TxLogManager             :75  ) - Failed to connect to ORB for TM: TRANSIENT minor code: 1330446338
                        2010-11-23 21:56:01,468 [0x000017bc] ERROR (AtmiBrokerServer         :373 ) - default transaction configuration error, aborting server startup
                        2010-11-23 21:56:01,468 [0x000017bc] FATAL (AtmiBrokerServer         :201 ) - serverinit failed
                        Saravanan A

                        • 9. Re: btadmin startup gives Application error
                          Michael Musgrove Master

                          This looks like the server is unable to connect to the transaction manager running in the JBossAS instance. Does the value of the environment variable JBOSSAS_IP_ADDR (should have been set when you sourced the setenv script that came with the release) match the interface you started the JBossAS running on?

                          • 10. Re: btadmin startup gives Application error
                            Michael Musgrove Master

                            Suggestion:-

                            In setEnv.sh|bat file

                             

                            Instead of

                             

                            set PATH=%PATH%;%BLACKTIE_HOME%\bin

                            set PATH=%PATH%;%BLACKTIE_HOME%\lib\cxx

                            set PATH=%PATH%;.

                             

                            if replaced as below will avoid these problems

                             

                            set PATH=%BLACKTIE_HOME%\bin;%PATH%
                            set PATH=%BLACKTIE_HOME%\lib\cxx;%PATH%;

                            set PATH=.;%PATH%

                             

                            set PATH=%BLACKTIE_HOME%\bin;%PATH%

                            set PATH=%BLACKTIE_HOME%\lib\cxx;%PATH%;

                            set PATH=.;%PATH%

                            I agree. When sourcing a new environment, it makes sense for the new variables to take precedence over the old ones since it is a conscious decision to apply the changes.

                            • 11. Re: btadmin startup gives Application error
                              Saravanan A Newbie

                              Hi,

                               

                              Throws NullPointer exception in JBoss AS while starting the server.  Please find the attached jBoss AS log

                               

                              Environment values:-

                              HOSTNAME => Saravanan
                              JBOSSAS_IP_ADDR => localhost
                              Command used to start JBoss AS:-
                              bin\run.bat -c all -b localhost

                              HOSTNAME => Saravanan

                              JBOSSAS_IP_ADDR => localhost

                               

                              Command used to start JBoss AS:-

                              bin\run.bat -c all -b localhost

                              Saravanan A

                              • 12. Re: btadmin startup gives Application error
                                Tom Jenkinson Master

                                Hi Saravanan A,

                                 

                                Sorry for not getting back to you yesterday. As the guys have already mentioned, what you proposed is a sound suggestion and I have updated trunk to reflect this (I have also created and resolved a Jira for this: https://jira.jboss.org/browse/BLACKTIE-341)

                                 

                                Now, on to your current issue, this is certainly something we have seen before and is caused by (as Mike points out) the server process not being able to connect to the CORBA name service hosted in JBoss.

                                 

                                Assuming so, please can you send the output from the JBoss console? Also, when JBoss is running, please can you confirm that the name service has been started by issuing the netstat command and checking that port 3526 is bound to interface "Saravanan"?

                                 

                                Thanks,

                                Tom

                                • 13. Re: btadmin startup gives Application error
                                  Tom Jenkinson Master

                                  Sorry, you must have been typing at the same time as me! I am looking at your output now...

                                  • 14. Re: btadmin startup gives Application error
                                    Tom Jenkinson Master

                                    Saravanan A,

                                     

                                    Please can you confirm you have the <BLACKTIE_HOME>/blacktie-admin-services/btconfig.xml copied into <JBOSS_HOME>/server/all/conf

                                     

                                    Thanks,

                                    Tom

                                    1 2 Previous Next