2 Replies Latest reply on Dec 1, 2010 1:41 AM by Praveen Felix

    <internal:lib/rubygems/custom_require>:29:in `require': no such file to load -- guestfs (LoadError)

    Praveen Felix Newbie

      Hi All,

       

      I am new to Boxgrinder and I need your help.
      I am facing an issue when trying to run the boxgrinder build.

       

      On my Fedora 14 machine (though I have the same error on my other 2 machines having Ubuntu 10.10 and Redhat Linux 5 also) I have installed

       

      1. Ruby ->  ruby 1.9.2p0
      2. gem -> 1.3.7
      3. BoxGrinder Build -> 0.6.3

       

      I have created an appliances folder and kept an appliancedefinition file (for each of the machine with the corresponding OS name)

       

      When I run the command to run boxgrinder build, I am getting the following error. (This is happening on all the machines I have)
      I have tried to google and follow the suggestions in the web, but this issue still persisits.

       

      <internal:lib/rubygems/custom_require>:29:in `require': no such file to load -- guestfs (LoadError)
              from <internal:lib/rubygems/custom_require>:29:in `require'

       

      Please let me know how to solve this!

       

      Thanks and Warm Regards,

       

      Praveen Antony Felix

       

      NOTE:

       

      I have already tried the suggestion in

       

      http://community.jboss.org/message/569497#569497