7 Replies Latest reply on Jan 18, 2011 2:49 PM by Marek Goldmann

    Can't build image after clean install

    Marek Goldmann Master

      From our community member:

       

      Hi,

      just installed a fresh F14 laptop and added all boxgrinder packages.

       

      [udo@npe appliances]$ rpm -qa | grep boxgrinder

      rubygem-boxgrinder-build-local-delivery-plugin-doc-0.0.6-1.fc14.noarch

      rubygem-boxgrinder-build-vmware-platform-plugin-0.0.6-1.fc14.noarch

      rubygem-boxgrinder-build-rpm-based-os-plugin-0.0.9-1.fc14.noarch

      rubygem-boxgrinder-build-local-delivery-plugin-0.0.6-1.fc14.noarch

      rubygem-boxgrinder-build-rpm-based-os-plugin-doc-0.0.9-1.fc14.noarch

      rubygem-boxgrinder-build-0.7.0-1.fc14.noarch

      rubygem-boxgrinder-core-doc-0.1.5-1.fc14.noarch

      rubygem-boxgrinder-build-doc-0.7.0-1.fc14.noarch

      rubygem-boxgrinder-core-0.1.5-1.fc14.noarch

      rubygem-boxgrinder-build-fedora-os-plugin-0.0.5-1.fc14.noarch

       

      when trying to build a f14 based kvm image (from the sample for starters) i get

       

      [udo@npe appliances]$ sudo boxgrinder-build -V f14-jeos.appl

      D, [2011-01-08T09:08:01.048698 #24347] DEBUG -- : Loading os plugins...

      D, [2011-01-08T09:08:01.048928 #24347] DEBUG -- : We have 0 os plugin(s) registered

      D, [2011-01-08T09:08:01.049030 #24347] DEBUG -- : Plugins loaded.

      D, [2011-01-08T09:08:01.049133 #24347] DEBUG -- : Loading platform plugins...

      D, [2011-01-08T09:08:01.049236 #24347] DEBUG -- : We have 1 platform plugin(s) registered

      D, [2011-01-08T09:08:01.049340 #24347] DEBUG -- : - vmware plugin for VMware.

      D, [2011-01-08T09:08:01.049473 #24347] DEBUG -- : Plugins loaded.

      D, [2011-01-08T09:08:01.049574 #24347] DEBUG -- : Loading delivery plugins...

      D, [2011-01-08T09:08:01.049682 #24347] DEBUG -- : We have 1 delivery plugin(s) registered

      D, [2011-01-08T09:08:01.049803 #24347] DEBUG -- : - local plugin for Local file system.

      D, [2011-01-08T09:08:01.049901 #24347] DEBUG -- : Plugins loaded.

      D, [2011-01-08T09:08:01.050009 #24347] DEBUG -- : Reading definition from 'f14-jeos.appl' file...

      No operating system plugins installed. Install one or more operating system plugin. Seehttp://community.jboss.org/docs/DOC-15081 and http://community.jboss.org/docs/DOC-15214 for more info

       

      Somehow the app seems to miss the fedora os gem?

       

      i could not find any identical error on the net so i thought i ask here if i'm doing anything wrong

       

      thanks for any input

      udo

        • 1. Re: Can't build image after clean install
          Marek Goldmann Master

          Hi Udo,

           

          I assume you've installed BoxGrinder from Fedora repos. If this is true, could you please run this command to update to latest version available in updates-testing and try again?

           

          yum --enablerepo=updates-testing update rubygem-boxgrinder-*
          

           

          --Marek

          • 2. Re: Can't build image after clean install
            Udo Christ Newbie

            Hi Marek,

             

            thanks for your help.  updated pkgs as per your suggestion. still does not work with the same error reason.

             

            Transaction Test Succeeded

            Running Transaction

              Updating       : rubygem-boxgrinder-build-0.7.1-1.fc14.noarch             1/8

              Updating       : rubygem-boxgrinder-build-rpm-based-os-plugin-0.0.10-1.   2/8

              Updating       : rubygem-boxgrinder-build-rpm-based-os-plugin-doc-0.0.1   3/8

              Updating       : rubygem-boxgrinder-build-doc-0.7.1-1.fc14.noarch         4/8

              Cleanup        : rubygem-boxgrinder-build-doc-0.7.0-1.fc14.noarch         5/8

              Cleanup        : rubygem-boxgrinder-build-rpm-based-os-plugin-doc-0.0.9   6/8

              Cleanup        : rubygem-boxgrinder-build-rpm-based-os-plugin-0.0.9-1.f   7/8

              Cleanup        : rubygem-boxgrinder-build-0.7.0-1.fc14.noarch             8/8

             

             

            Updated:

              rubygem-boxgrinder-build.noarch 0:0.7.1-1.fc14                               

              rubygem-boxgrinder-build-doc.noarch 0:0.7.1-1.fc14                           

              rubygem-boxgrinder-build-rpm-based-os-plugin.noarch 0:0.0.10-1.fc14          

              rubygem-boxgrinder-build-rpm-based-os-plugin-doc.noarch 0:0.0.10-1.fc14      

             

             

            Complete!

            [udo@npe ~]$ cd appliances/

            [udo@npe appliances]$ sudo boxgrinder-build -V f14-jeos.appl

            D, [2011-01-08T18:03:46.025890 #25473] DEBUG -- : Loading os plugins...

            D, [2011-01-08T18:03:46.026104 #25473] DEBUG -- : We have 0 os plugin(s) registered

            D, [2011-01-08T18:03:46.026204 #25473] DEBUG -- : Plugins loaded.

            D, [2011-01-08T18:03:46.026302 #25473] DEBUG -- : Loading platform plugins...

            D, [2011-01-08T18:03:46.026402 #25473] DEBUG -- : We have 1 platform plugin(s) registered

            D, [2011-01-08T18:03:46.026505 #25473] DEBUG -- : - vmware plugin for VMware.

            D, [2011-01-08T18:03:46.026602 #25473] DEBUG -- : Plugins loaded.

            D, [2011-01-08T18:03:46.026700 #25473] DEBUG -- : Loading delivery plugins...

            D, [2011-01-08T18:03:46.026837 #25473] DEBUG -- : We have 1 delivery plugin(s) registered

            D, [2011-01-08T18:03:46.026944 #25473] DEBUG -- : - local plugin for Local file system.

            D, [2011-01-08T18:03:46.027042 #25473] DEBUG -- : Plugins loaded.

            D, [2011-01-08T18:03:46.027148 #25473] DEBUG -- : Reading definition from 'f14-jeos.appl' file...

            No operating system plugins installed. Install one or more operating system plugin. See http://community.jboss.org/docs/DOC-15081 and http://community.jboss.org/docs/DOC-15214 for more info

             

             

             

            cheers Udo

            • 3. Re: Can't build image after clean install
              Marek Goldmann Master

              I'll take a closer look at this and give you answer tomorrow. Thanks for patience!

               

              --Marek

              • 4. Re: Can't build image after clean install
                Marek Goldmann Master

                Sorry for late response. Latest Fedora OS gem in Fedora RPM packages is 0.0.5, but it should be 0.0.6 which has updated gem requirements (which is cause of your error). I'm building now 0.0.6 update and will push it to updates-testing today.

                 

                In the meantime you can use our repository which should contain latest packages too.

                 

                --Marek

                • 6. Can't build image after clean install
                  Udo Christ Newbie

                  Hi, tested and confirmrd working now. Thx for your help. Udo

                  • 7. Can't build image after clean install
                    Marek Goldmann Master

                    Great, I would appreciate a comment for these packages (after you log in to Fedora Account System). This will greatly accelerate the process.

                     

                    --Marek