1 2 Previous Next 16 Replies Latest reply on Apr 6, 2011 5:03 AM by Ilya Shaikovsky

    Richfaces 4 Display Problem

    eldjon Newbie

      i just started working of Richfaces but im having a problem with it as i cannot display any richfaces element. i integrate it with maven and i added those dependencies :

              <dependency>

                  <groupId>org.richfaces.ui</groupId>

                  <artifactId>richfaces-components-api</artifactId>

                  <version>4.0.0.20110209-M6</version>

              </dependency>

              <dependency>

                  <groupId>org.richfaces.ui</groupId>

                  <artifactId>richfaces-components-ui</artifactId>

                  <version>4.0.0.20110209-M6</version>

              </dependency>

       

      i configured the web.xml files accordingly :

          <context-param>

              <param-name>org.richfaces.enableControlSkinning</param-name>

              <param-value>true</param-value>

          </context-param>

          <context-param>

              <param-name>org.richfaces.enableControlSkinningClasses</param-name>

              <param-value>false</param-value>

          </context-param>

          <context-param>

              <param-name>org.richfaces.skin</param-name>

              <param-value>#{skinBean.skin}</param-value>

          </context-param>

       

      But the result is blank page (for richfaces components). I cant see any richface component at all. and no warnings , no errors either

        1 2 Previous Next