1 2 Previous Next 28 Replies Latest reply on Oct 16, 2014 8:03 AM by Abhishek Kumar

    HowTo setup a new GateIN Portal?

    Steffen Kau Newbie

      Hi GateIn-Community,

       

      I am very new in developing portal-solutions.

      The “Is-Situation“is that I need a Portal Solution with CMS for a project with the following specifications:

      • -             Customizing the look and feel to my needs
      • -             Use Single Sign On against shibboleth service provider
      • -             Developing with Eclipse on Windows 7 64
      • -             Use with MySQL database

      Now my question is. Is there someone, who can help me to setup this system?

       

      Thanks

      Steffen

        • 1. HowTo setup a new GateIN Portal?
          Rich Raposa Novice

          Steffen,

           

          You are going to find a lot of your answers in the GateIn Reference Guide and Users Guide:

           

          http://www.jboss.org/gatein/documentation

           

          Specifically, the Users Guide shows how to create a new portal using the web user interface, and the Reference Guide shows how to configure a new portal using XML. The Reference Guide has a Single SignOn section - but nothing on shibboleth. That may the only piece of the puzzle you will have to figure out on your own.

           

          It's easy enough to install Eclipse on Windows and have it point to a GateIn instance. If you get stuck, you will find plenty of help here!

           

          Cheers,

          Rich

          • 2. HowTo setup a new GateIN Portal?
            Steffen Kau Newbie

            Hey Rich,

             

            Thanks for fast reply.

             

            I think my questionwas a little bit too short.

            For my firststep I want to know:

            Which version of Eclipse I shout use?
            At the moment I use Eclipse Helios with the JEE plug-ins, JBoss plug-ins, Maven plug-in.

            How can I add a new project to Eclipse so that I only have one project to deploy? (At themoment I have 70 separate project after I use the “mvn eclipse:ecpipse”command)

            How must I configure Eclipse to debug GateIn?

            In the past I used Netbeans to develop JEE projects. There it was possible to click the debug button and Netbeans create an “ear” or “war”-File and deploy it on the applicationserver automatically.

             

            Thanks,

            Steffen

            • 3. HowTo setup a new GateIN Portal?
              Rich Raposa Novice

              Hi Steffen,

               

              Not sure which version of Eclipse and plug-ins to use because I use Developer Studio - so everything just kind of works out-of-the box. Somebody else want to answer this one for him?

               

              Setting up debugging in Eclipse is pretty straightforward - here's some helpful tips:

              http://stackoverflow.com/questions/516196/jboss-debugging-in-eclipse

               

              Have you tried creating a new project in Eclipse for your application? Just try starting with something simple like a "Dynamic Web Project" and add a couple of portlets to it using the Eclipse wizards.

              • 5. HowTo setup a new GateIN Portal?
                Steffen Kau Newbie

                Thanks for the 2 replies.

                 

                First I try the reply of Rich successfully with my own DynamicWebProject on JBoss AS.

                 

                My first step with GateIn was:

                svn co http://anonsvn.jboss.org/repos/gatein/portal/trunk/

                mvn clean install

                But maven goesin to errors.

                ------------------------------------------------------------------------------------------------------------------------------------------------------------------

                [INFO][clean:clean {execution: default-clean}]

                Downloading:http://repo1.maven.org/maven2/org/gatein/gatein-dep/1.0.3-Beta01/gatein-dep-1.0.3-Beta01.pom

                [INFO]Unable to find resource 'org.gatein:gatein-dep:pom:1.0.3-Beta01' in repository central(http://repo1.maven.org/maven2)

                [INFO]------------------------------------------------------------------------

                [ERROR]BUILD ERROR

                [INFO]------------------------------------------------------------------------

                [INFO]Error building POM (may not be this project's POM).

                Project ID:org.gatein:gatein-dep

                Reason: POM'org.gatein:gatein-dep' not found in repository: Unable to download theartifact from any repository

                  org.gatein:gatein-dep:pom:1.0.3-Beta01

                from thespecified remote repositories:

                  central (http://repo1.maven.org/maven2)

                  for project org.gatein:gatein-dep

                ------------------------------------------------------------------------------------------------------------------------------------------------------------------

                My secondtry was.

                svn co http://anonsvn.jboss.org/repos/gatein/portal/tags/3.1.0-GA

                mvn clean install

                mvn eclipse:eclipse

                 

                open Eclipse --> import --> import existing project in workspace

                Get one project in Eclipse with many libs not found errors.

                The most error is because Eclipse can’t find exo-libraries.
                Where can I get this libraries? Do i really need this libraries?

                 

                So now I want run the project:

                In Eclipse   ---> Debug as “Remote Java Aplication” failed but I don’t know why.

                 

                Cheers,

                Steffen

                • 6. HowTo setup a new GateIN Portal?
                  Thomas Heute Master

                  Can you try trunk with Maven 3 ?

                  We are looking into that issue with Maven 2 which has been reported (about missing gatein-dep which on jboss repo...)

                  • 7. Re: HowTo setup a new GateIN Portal?
                    Steffen Kau Newbie

                    no I get this error:

                     

                    [ERROR] The build could not read 6 projects -> [Help 1]

                    [ERROR]

                    [ERROR]   The project org.gatein.portal.examples.skins:parent:3.2.0-Beta01-SNAPSHOT (D:\Workspace\gateinsrc - Kopie\examples\skins\pom.xml) has 1 error

                    [ERROR]     Non-resolvable parent POM: Could not find artifact org.exoplatform.portal:exo.portal.parent:pom:3.2.0-Beta01-SNAPSHOT and 'parent.relativePath' points at wrong local POM @ line 5, column 12 -> [Help 2]

                    [ERROR]

                    [ERROR]   The project org.exoplatform.portal:exo.portal.sample.extension.root:3.2.0-Beta01-SNAPSHOT (D:\Workspace\gateinsrc - Kopie\examples\extension\pom.xml) has 1 error

                    [ERROR]     Non-resolvable parent POM: Could not find artifact org.exoplatform.portal:exo.portal.parent:pom:3.2.0-Beta01-SNAPSHOT and 'parent.relativePath' points at wrong local POM @ line 24, column 11 -> [Help 2]

                    [ERROR]

                    [ERROR]   The project org.exoplatform.portal:exo.portal.sample.portal.root:3.2.0-Beta01-SNAPSHOT (D:\Workspace\gateinsrc - Kopie\examples\portal\pom.xml) has 1 error

                    [ERROR]     Non-resolvable parent POM: Could not find artifact org.exoplatform.portal:exo.portal.parent:pom:3.2.0-Beta01-SNAPSHOT and 'parent.relativePath' points at wrong local POM @ line 24, column 11 -> [Help 2]

                    [ERROR]

                    [ERROR]   The project org.gatein.portal.examples.portlets:parent:3.2.0-Beta01-SNAPSHOT (D:\Workspace\gateinsrc - Kopie\examples\portlets\pom.xml) has 1 error

                    [ERROR]     Non-resolvable parent POM: Could not find artifact org.exoplatform.portal:exo.portal.parent:pom:3.2.0-Beta01-SNAPSHOT and 'parent.relativePath' points at wrong local POM @ line 5, column 12 -> [Help 2]

                    [ERROR]

                    [ERROR]   The project org.exoplatform.portal:exo.portal.starter.war:3.2.0-Beta01-SNAPSHOT (D:\Workspace\gateinsrc - Kopie\starter\war\pom.xml) has 1 error

                    [ERROR]     Non-resolvable parent POM: Could not find artifact org.exoplatform.portal:exo.portal.parent:pom:3.2.0-Beta01-SNAPSHOT and 'parent.relativePath' points at wrong local POM @ line 23, column 11 -> [Help 2]

                    [ERROR]

                    [ERROR]   The project org.exoplatform.portal:starter-gatein:3.2.0-Beta01-SNAPSHOT (D:\Workspace\gateinsrc - Kopie\starter\ear\pom.xml) has 1 error

                    [ERROR]     Non-resolvable parent POM: Could not find artifact org.exoplatform.portal:exo.portal.parent:pom:3.2.0-Beta01-SNAPSHOT and 'parent.relativePath' points at wrong local POM @ line 23, column 11 -> [Help 2]

                    [ERROR]

                    [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.

                    [ERROR] Re-run Maven using the -X switch to enable full debug logging.

                    [ERROR]

                    [ERROR] For more information about the errors and possible solutions, please read the following articles:

                    [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException

                     

                    or with mvn3 and the old  .m2 folder

                     

                     

                    [ERROR] Failed to execute goal org.apache.maven.plugins:maven-surefire-plugin:2.4.3:test (default-test) on project exo.portal.webui.portal: There are test failures.

                    [ERROR]

                    [ERROR] Please refer to D:\Workspace\gateinsrc - Kopie\webui\portal\target\surefire-reports for the individual test results.

                    [ERROR] -> [Help 1]

                    [ERROR]

                    [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.

                    [ERROR] Re-run Maven using the -X switch to enable full debug logging.

                    [ERROR]

                    [ERROR] For more information about the errors and possible solutions, please read the following articles:

                    [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureException

                    [ERROR]

                    [ERROR] After correcting the problems, you can resume the build with the command

                    [ERROR]   mvn <goals> -rf :exo.portal.webui.portal

                    • 8. HowTo setup a new GateIN Portal?
                      Rich Raposa Novice

                      Steffen,

                       

                      Try this:

                       

                      1. In Eclipse under Window->Preferences, define a new Server->Runtime Environment that points to where you have GateIn installed.

                      2. Click on Project->Properties->Targeted Runtimes and check the box next to your GateIn runtime that you just defined in the previous step.

                       

                      That should add the eXo libraries to your project build path and remove all the "library not found" errors.

                       

                      -Rich

                      • 9. Re: HowTo setup a new GateIN Portal?
                        Steffen Kau Newbie

                        Good Morning Rich,

                         

                        Today I am startingfrom the scratch with 3.1.0GA.

                        “mvn install”

                        Edit file packaging/profiles.xml

                        “mvn install –Ppkg-jbossas”

                        Run Jbossin 3.1.0.GA\packaging\pkg\target\jboss\bin

                        Start Firefox and go to localhost:8080/portal   

                        Get the Portal-Page

                        Start Eclipse-> Window->Preferences, define a new Server->Runtime Environment that points to 3.1.0.GA\packaging\pkg\target\jboss

                        Eclipse  -> Import Project -> Existing Project into Workspace

                        Project->Properties->Targeted Runtimes and check the box next to my GateIn runtime that I just defined in the previous step.

                        But the problem with the missing libraries is don’t be resolved

                         

                        Cheers,

                        Steffen

                        • 10. Re: HowTo setup a new GateIN Portal?
                          Rich Raposa Novice

                          Steffen,

                           

                          Right-click on your Project and select Build Path-> Configure Build Path... and click on the "Libraries" tab. Make sure your Server Runtime is listed and does not have any errors (I think it will be underlined in red if it's not configured properly).

                           

                          If that still does not fix the problem, then click on "Add External JARs..." and you can add the eXo JAR files one-at-a-time to your build path. Then Clean your project - and let us know if that fixes it!

                           

                          -Rich

                          • 11. HowTo setup a new GateIN Portal?
                            Steffen Kau Newbie

                            Hi Rich,

                            Thanks for your reply.

                            You were right in the building path was no Jboss5.1AS.

                            First I at the Jboss from above but this don’t resolve my missing library problem.

                            So I do the second tip and add external jars from

                            “3.1.0-GA -clean\packaging\pkg\target\jboss\server\default\deploy\gatein.ear\lib”

                            This willfix 3/4 of all problems. At last I add the library JUnit and I get a project without errors.

                            Now I reached the second step:
                            How can I run the project.

                            If I select run on Server I get the Error there is no file to run on the server.

                             

                            Cheers

                            Steffen

                            • 12. HowTo setup a new GateIN Portal?
                              Rich Raposa Novice

                              Steffan - it sounds like you haven't deployed your application onto GateIn yet. Try the following:

                               

                              1. From the Eclipse menu, select Window->Open Perspective->Java EE. You should see a tab at the bottom of Eclipse called "Servers".

                              2. On the Servers tab, right-click on your Runtime Server and select "Add and Remove..."

                              3. Add your project to the list of "Configured:" projects.

                              4. Start your server

                               

                              Let me know if that works!

                              Rich

                              • 13. HowTo setup a new GateIN Portal?
                                Steffen Kau Newbie

                                Hi Rich,

                                 

                                I selected my project and choose mark project as deployable.

                                After this it is displayed as configured in the Server -> Add and Remove window.

                                I selectthe project in the server tab and select in context menu “explore”.

                                Is itnormal that eclipse copy the jbossAS to “workspace\.metadata\.plugins\org.jboss.ide.eclipse.as.core\JBoss_5.1_Runtime_Server1300899298705\deploy\3.1.0-GA– eclipse” and try to deploy the project in this folder.

                                I think when I start the Server in eclipse and browse 127.0.0.1:8080/portal the serverlooks in the jbossAS directory

                                “workspace\3.1.0GA\packaging\pkg\target\jboss\server\default\deploy”

                                I think so because:

                                java.lang.ClassNotFoundException:${portal.container.gatein.jcr.datasource.driver} fromBaseClassLoader@3fbf12a3{VFSClassLoaderPolicy@1960ac07{name=vfsfile:/D:/Workspace/3.1.0-GA%20-%20eclipse/packaging/pkg/target/jboss/server/default/deploy/gatein.ear/

                                Do you understand this situation?

                                 

                                Cheers,

                                Steffen

                                • 14. HowTo setup a new GateIN Portal?
                                  Rich Raposa Novice

                                  Have you been able to start GateIn at all yet? And did you change any of the database configurations for the JCR and IDM datasources? (In other words, which database are you using?)

                                  1 2 Previous Next