7 Replies Latest reply: Jun 22, 2011 9:59 AM by Paul Gier RSS

    can't build jboss 6 from sources - Could not find artifact javax.servlet:jstl

    Veit Ullmann Newbie

      I edited the settings.xml for apache-maven-2.2.1:

      <?xml version="1.0" encoding="UTF-8"?>

       

      <settings xmlns="http://maven.apache.org/settings/1.0.0"

                xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

                xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0 http://maven.apache.org/xsd/settings-1.0.0.xsd">

        <localRepository>D:/.m2/repository</localRepository>

        <pluginGroups>

          <pluginGroup>org.jboss.maven.plugins</pluginGroup>

        </pluginGroups>

        <proxies>

        </proxies>

        <servers>

        </servers>

        <mirrors>

        </mirrors>

        <profiles>

          <profile>

            <id>jboss-public-repository</id>

            <repositories>

              <repository>

                <id>jboss-public-repository-group</id>

                <name>JBoss Public Maven Repository Group</name>

                <url>https://repository.jboss.org/nexus/content/groups/public-jboss/</url>

                <layout>default</layout>

                <releases>

                  <enabled>true</enabled>

                  <updatePolicy>never</updatePolicy>

                </releases>

                <snapshots>

                  <enabled>true</enabled>

                  <updatePolicy>never</updatePolicy>

                </snapshots>

              </repository>

            </repositories>

            <pluginRepositories>

              <pluginRepository>

                <id>jboss-public-repository-group</id>

                <name>JBoss Public Maven Repository Group</name>

                <url>https://repository.jboss.org/nexus/content/groups/public-jboss/</url>

                <layout>default</layout>

                <releases>

                  <enabled>true</enabled>

                  <updatePolicy>never</updatePolicy>

                </releases>

                <snapshots>

                  <enabled>true</enabled>

                  <updatePolicy>never</updatePolicy>

                </snapshots>

              </pluginRepository>

            </pluginRepositories>

          </profile>

           <profile>

            <id>jboss-deprecated-repository</id>

            <repositories>

              <repository>

                <id>jboss-deprecated-repository</id>

                <name>JBoss Deprecated Maven Repository</name>

                <url>https://repository.jboss.org/nexus/content/repositories/deprecated/</url>

                <layout>default</layout>

                <releases>

                  <enabled>true</enabled>

                  <updatePolicy>never</updatePolicy>

                </releases>

                <snapshots>

                  <enabled>false</enabled>

                  <updatePolicy>never</updatePolicy>

                </snapshots>

              </repository>

            </repositories>

          </profile>

        </profiles>

        <activeProfiles>

          <activeProfile>jboss-public-repository</activeProfile>

        </activeProfiles>

      </settings>

       

      Then I checked out the sources from http://anonsvn.jboss.org/repos/jbossas/trunk.

       

      In the root dir of the checked out sources I executed "build".

       

      I got the following error:

       

      [INFO] JBoss Application Server Tomcat ................... FAILURE [0.882s]

      [INFO] JBoss Application Server Varia .................... SKIPPED

      [INFO] JBoss Application Server Weld Integration ......... SKIPPED

      [INFO] JBoss Application Server Weld Integration EE services  SKIPPED

      [INFO] JBoss Application Server Weld Integration MC Deployers  SKIPPED

      [INFO] JBoss Application Server Webservices .............. SKIPPED

      [INFO] JBoss Application Server Weld Integration EE Webtier services  SKIPPED

      [INFO] Weld JBoss AS Integration: MC Deployers for injection between Weld and MC  SKIPPED

      [INFO] JBoss Application Server Weld Integration Assembly  SKIPPED

      [INFO] JBoss Application Server Dependency Chain ......... SKIPPED

      [INFO] JBoss Application Server Build .................... SKIPPED

      [INFO] JBoss Application Server EmbeddedAS TestSuite ..... SKIPPED

      [INFO] JBoss Application Server Distribution ............. SKIPPED

      [INFO] JBoss Application Server Profile Service Client ... SKIPPED

      [INFO] JBoss Application Server Resteasy Integration ..... SKIPPED

      [INFO] JBoss Application Server Client POM ............... SKIPPED

      [INFO] JBoss Application Server Testsuite ................ SKIPPED

      [INFO] ------------------------------------------------------------------------

      [INFO] BUILD FAILURE

      [INFO] ------------------------------------------------------------------------

      [INFO] Total time: 49.944s

      [INFO] Finished at: Mon Jun 20 14:35:23 CEST 2011

      [INFO] Final Memory: 112M/780M

      [INFO] ------------------------------------------------------------------------

      [ERROR] Failed to execute goal on project jboss-as-tomcat: Could not resolve dependencies for project org.jboss.jbossas:jboss-as-tomcat:jar:6.1.0-SNAPSHOT: Failure to find javax.servlet:jstl:jar:1.2 i

      n https://repository.jboss.org/nexus/content/groups/public-jboss/ was cached in the local repository, resolution will not be reattempted until the update interval of jboss-public-repository-group has

      elapsed or updates are forced -> [Help 1]

      [ERROR]

      [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.

      [ERROR] Re-run Maven using the -X switch to enable full debug logging.

      [ERROR]

      [ERROR] For more information about the errors and possible solutions, please read the following articles:

      [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException

      [ERROR]

      [ERROR] After correcting the problems, you can resume the build with the command

      [ERROR]   mvn <goals> -rf :jboss-as-tomcat

       

      What do I have to do???