10 Replies Latest reply on Jul 6, 2011 12:19 AM by Tom Cunningham

    JBoss ESB and JBoss AS 6.0.0.Final

    Peter Brewer Novice

      I've been trying to integrate JBoss ESB 4.9 into JBoss AS 6. I've been following the instructions at the end of https://issues.jboss.org/browse/JBESB-2760 - I'm unsuccessful so far, due to the changes in package names as pointed out in the JIRA:

       

      9. Update package name changes in VFS

      org.jboss.virtual.VirtualFile -> org.jboss.vfs.VirtualFile;

      org.jboss.virtual.VirtualFileFilter -> org.jboss.vfs.VirtualFileFilter;

       

      So my questions are:

      1. Has anyone got JBoss AS 6 + the esb working? (if so a how-to guide would be very appreciated).
      2. Can anyone elaborate on how I can change the package names or is this a source code change?
      3. Also I see that this issue is now set to be resolved in the 4.10 release of the esb - can you give an indication of when that version might be released?

       

      Any help or suggestions would be gratefully received.

       

      Thanks in advance,

       

      Pete.

        • 1. Re: JBoss ESB and JBoss AS 6.0.0.Final
          misel Newbie

          Hi Peter,

           

          I stepped on that mine as well, and the only info I've got is that you can checkout the trunk, where the package changes (mentioned in the jira) seem to be fixed. Then build the ESB and deploy it into the AS.

           

          I agree that a roadmap for the 4.10 release would be very useful and interesting.

           

          Cheers,

          ml

          1 of 1 people found this helpful
          • 2. Re: JBoss ESB and JBoss AS 6.0.0.Final
            Tom Cunningham Master

            So my questions are:

            1. Has anyone got JBoss AS 6 + the esb working? (if so a how-to guide would be very appreciated).
            2. Can anyone elaborate on how I can change the package names or is this a source code change?
            3. Also I see that this issue is now set to be resolved in the 4.10 release of the esb - can you give an indication of when that version might be released?

             

            1 Yes.   AS 6.0.0.Final will be supported by the 4.10 release.     If you want to try this out, check out the trunk, build using ant 1.8.1 in conjunction with a 1.6 jdk, point your deployment.properties at a jboss AS 6.0.0.Final instance, and deploy.

             

            2 Don't bother, this has already been taken care of in the trunk.

             

            3 4.10 is coming imminently.     There's still a few issues that are being worked through, but once those are done we'll have a new release up very quickly.

            • 3. Re: JBoss ESB and JBoss AS 6.0.0.Final
              Peter Brewer Novice

              Thanks Misel & Tom for you very quick and helpful responses.

               

              I have now built and deployed the esb into AS6. For those that also want to do this, here is a step-by-step guide:

               

              1. Download the trunk source from http://anonsvn.jboss.org/repos/labs/labs/jbossesb/trunk (I used the subversion eclipse plugin to check this out).
              2. Copy the <ESB_SRC_HOME>/product/install/deployment.properties-example to <ESB_SRC_HOME>/product/install/deployment.properties and update the server path and configuration appropriately for your system.
              3. To integrate into JBoss, change to the <ESB_SRC_HOME>/product/install directory and run ant deploy

               

              @Tom Just one last thing: Are we looking at days, weeks or months for the 4.10 release?

               

              Many thanks, Pete.

              • 4. Re: JBoss ESB and JBoss AS 6.0.0.Final
                Alexandre Barros Newbie

                Hi Peter, since you have already crossed this road, maybe you could help me... i have checked out the latest revision as:

                     $ svn co http://anonsvn.jboss.org/repos/labs/labs/jbossesb/trunk

                     Checked out revision 37236.

                 

                and followed the instructions at trunk/product/Build.txt ( ..."ant dist"... ), but hit a wall, with several unmet dependencies as:

                 

                [java] [ivy:retrieve] :: problems summary ::
                [java] [ivy:retrieve] :::: WARNINGS
                [java] [ivy:retrieve] module not found: hibernate#hibernate3;3.2.4.SP1
                [java] [ivy:retrieve] ==== jboss: tried
                [java] [ivy:retrieve]   -- artifact hibernate#hibernate3;3.2.4.SP1!hibernate3.jar:
                [java] [ivy:retrieve]   http://repository.jboss.org/maven2/hibernate/hibernate3/3.2.4.SP1/hibernate3-3.2.4.SP1.jar
                [java] [ivy:retrieve] ==== jboss-nexus: tried
                [java] [ivy:retrieve]   -- artifact hibernate#hibernate3;3.2.4.SP1!hibernate3.jar:
                [java] [ivy:retrieve]   https://
                [java] BUILD FAILED
                [java] .../jbossESB_4.10_svn/trunk/product/build.xml:174: The following error occurred while executing this line:
                (...)
                (...)
                [java] [ivy:retrieve] ::::::::::::::::::::::::::::::::::::::::::::::
                [java] [ivy:retrieve] ::      UNRESOLVED DEPENDENCIES     ::
                [java] [ivy:retrieve] ::::::::::::::::::::::::::::::::::::::::::::::
                [java] [ivy:retrieve] :: hibernate#hibernate3;3.2.4.SP1: not found
                [java] [ivy:retrieve] :: org.hibernate#ejb3-persistence;1.0.2.GA: not found
                [java] [ivy:retrieve] :: hibernate-entitymanager#hibernate-entitymanager;3.2.1.GA: not found
                [java] [ivy:retrieve] :: apache-bsf#bsf;2.3.0: not found
                [java] [ivy:retrieve] :: beanshell#bsh;1.3.0: not found
                [java] [ivy:retrieve] :: sun-jaxb#jaxb-xjc;2.1.4: not found
                [java] [ivy:retrieve] :: apache-log4j#log4j;1.2.14: not found
                [java] [ivy:retrieve] ::::::::::::::::::::::::::::::::::::::::::::::
                [java] [ivy:retrieve]
                [java] [ivy:retrieve] :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS

                 

                BUILD FAILED

                 

                browsing by hand the URL's pointed by the IVY's errors/warnings shows that actually those resources are not available...

                 

                so, i ask, how did you manage to build this ?... am i doing something utterly stupid ( quite possible, since it's my first time with IVY ) or this build.xml happens to be broken ? ( btw, running apache ant 1.8.1 -- as pointed above by Tom -- on a 32bits Linux, JDK 1.6.0_25 )

                 

                many TIA.

                • 5. Re: JBoss ESB and JBoss AS 6.0.0.Final
                  Peter Brewer Novice

                  Hi Alexandre,

                   

                  Sorry I should have added that problem into my post. Yes, there are problems with the dependencies that I couldn't resolve either - so I the end I trawled the web for the dependencies, downloaded them locally and updated the ivysettings.xml to point to my local dir.

                   

                  To save you (and others) the hassle of finding the required jars I've put them onto our companies website (with a modified ivysettings.xml):

                   

                  http://www.iblocks.co.uk/technical/articles.html#esb_build_issue

                  • 6. Re: JBoss ESB and JBoss AS 6.0.0.Final
                    Tom Cunningham Master

                    I wasn't aware there were unresolved dependencies - my local build has been humming along.      If someone could post a log of the errors they are seeing, that'd be great - I tried the hibernate JAR link above and it worked fine for me.

                     

                    I'll do some testing today after removing my ivy cache.

                    • 7. Re: JBoss ESB and JBoss AS 6.0.0.Final
                      Peter Brewer Novice

                      Perhaps it is only available internally with jboss, but not externally?

                       

                      Accessing:

                      http://repository.jboss.org/maven2/hibernate/hibernate3/3.2.4.SP1/hibernate3-3.2.4.SP1.jar

                       

                      Gives 403 Forbidden:

                      Forbidden

                      You don't have permission to access /maven2/hibernate/hibernate3/3.2.4.SP1/hibernate3-3.2.4.SP1.jar on this server.


                      Apache Server at repository.jboss.org Port 80
                      • 8. Re: JBoss ESB and JBoss AS 6.0.0.Final
                        Tom Cunningham Master

                        I think the issue here is the deprecation of the old JBoss repository.     Working on it now and hopefully I'll have it resolved shortly.

                        • 9. Re: JBoss ESB and JBoss AS 6.0.0.Final
                          Alexandre Barros Newbie

                          Thanks a lot for the zipfile, Peter !

                          I now have a working binary ( haven't bothered fixing the errors on the "build-docs" target, it's not all that important for my testing right now ).

                          However i am a lil'bit worried by the amount of warnings while building... but since it's a work in progress ( svn after all ) i am sure it will all be sorted out by the release.

                           

                          ( just my 2cents: i had to download ejb3-persistence-1.0.2.GA.jar from ibiblio and fix the lowercase-to-uppercase on the "*.GA.jar" file for my building to work on my Linux box )

                          • 10. Re: JBoss ESB and JBoss AS 6.0.0.Final
                            Tom Cunningham Master

                            Trunk should also now be all fixed, including the ejb3-persistence issue and the build-docs error.