9 Replies Latest reply on Aug 25, 2011 9:45 AM by Davide D'Alto

    JBoss 7 AS suddenly no longer shows log in eclipse console view

    Jan Tim Newbie

      Perhaps this was solved before but I didn't find any solution here so far:

       

      I was working in eclipse with my JBoss 7 AS publishing my EAR-project and everything seemed fine, but out of the sudden when I was publishing my EAR once again, there wasn't any output in the console view anymore. First I thought I just messed up with the views and perhaps closed the wrong console, but after a while I realized something must have been broken since no matter what I do the server log doesn't show up any more.

       

      When I rightclick on the server and choose "Show in", the "Console" menu entry is disabled and greyed out. Does that mean I accidently deleted oder disabled any console properties or perhaps closed something that I didn't meant to close? Right now I am very frustrated, because it is difficult to work without a server console view. The server still writes its logs into files, but it is obviously not an option to look into them all the time while coding in eclipse.

       

      Clicking on "Display Selected Console" in the console view pops up three possibilites, but none of them (Java Stack Trace Console, CVS, Host OSGi) is my JBoss 7 server log view. I found an issue that is related to my problem as it seems (https://issues.jboss.org/browse/JBIDE-2700), but performing the given advices didn't help.

       

      I'd appreciate any hints or solutions, thanks in advance!