6 Replies Latest reply on Nov 8, 2011 5:45 AM by abyttner

    Gatein 3.2 and CAS integration, anyone?

    ulfh Newbie

      Hi all,

       

      I had a working SSO installation with GateIn 3.1 and CAS, but recently had to upgrade due to a problem that was resolved in 3.2. Now I have not been able to get my SSO integration to work since, and I am getting desperate. I really hope that anyone here is able to help out.

       

      First, I was trying with my old sso-jars in gatein.ear/lib/ but I got a ClassNotFoundException on org.exoplatforms.web.security.Credentials, and I notice that it had been removed in 3.2.

       

      Then, I tried to get the latest sso-jars from the svn repository and build. I got a bit further, but now it's missing the GenericSSOAgent class referred to in gatein.ear/02Portal.war/WEB-INF/web.xml (InitiateLoginServlet).

       

      And now I am completely stuck, I have tried replacing GenericSSOAgent with CASAgent, but it's a singleton and of course cannot instantiate. The documentation seems to have fallen behind, and frankly I don't know where to look for information.

       

      Is there any kind soul out there who can give me a pointer in the right direction? I would appreciate it a lot!

       

      Thanks in advance,

      Ulf