8 Replies Latest reply on Nov 16, 2011 9:43 AM by shine.arvind

    Issue with running jbpm console 5.1 in websphere 7

    anand.awasthi Newbie

      I am trying to deploy the jbpm 5.1 console in websphere 7. I followed the following wiki link which talks about running jbpm 3.2.2 on was 6.

       

      http://community.jboss.org/wiki/Jbpm32OnWAS61

       

      Here is what i have done to set it up on was:

       

      I have created db2 datasource on was7.

      I have created custom registry, I am able to map the roles with user names.

      deployed both gwt-console and gwt-console-server war on was 7. (please note these are 2 installed as 2 seprarate web applications  via WebSphere Console, they are not packaged inside EAR file)

       

      Start the server

      Start the human task server

      Start the process with local bpn file. No guvonor repository setup

       

       

      Now when I launch JBPM console:

       

      http://localhost:9082/gwt-console/app.html

       

      I get following error:

       

      HTTP 404: Error 404: Could not find resource for relative : /server/status of full path: http://localhost:9082/gwt-console-server/rs/server/status

       

      when i hit

       

      http://localhost:9082/gwt-console-server/rs/server/status , I get 404.

       

       

      By the way I am running it on IE7.

       

      I have been able to deploy the console successfully on JBOSS using install targets,  no issues there.

       

      Not sure what  I am missing  in Websphere setup. Any pointers will be greatly appreciated. (erorr trace attached)

       

       

      thanks

        • 1. Re: Issue with running jbpm console 5.1 in websphere 7
          Mauricio Salatino Master

          So, are you following a very old document for jBPM 3.2 and another version of WebSphere..

          Can you get the stack trace from the application server? so we can understand the problem better..

          Cheers

          • 2. Re: Issue with running jbpm console 5.1 in websphere 7
            anand.awasthi Newbie

            Thanks Mauricio for quick reply.

             

            I realized that the wiki is very old and the steps may not be accurate for jbpm 5.1 and was7.  for example I noticed that 3.2 had only one console war and jbpm db schema was also way different.  I have attached the stack trace from my post.

             

            thanks

            • 3. Re: Issue with running jbpm console 5.1 in websphere 7
              Mauricio Salatino Master

              Did  you try the jBPM5 installer.. that configures all the tools for you?

              Cheers

              • 4. Re: Issue with running jbpm console 5.1 in websphere 7
                anand.awasthi Newbie

                Hi Mauricio,

                 

                I am assuming you are talking about installer  jbpm-5.1.0.Final-installer-full.zip. if my assumption is correct then yes I used that to run console on JBOSS and i have no issues there. But I am running into the issues when I try to install the console war files from JBPM5 installer into WAS7.

                 

                Please correct me if i misinterpreted your response.

                 

                thanks

                 

                 

                 

                • 5. Re: Issue with running jbpm console 5.1 in websphere 7
                  Mauricio Salatino Master

                  so basically you are copying the war files deployed in jboss into the Websphere server and changing the configurations there?

                  My approach to solve this kind of issues will be, just copy the files and start reporting the errors that you have.. right now seeing that stack trace it's impossible for me to give you some advices because I don't know what kind of changes did you applied.

                  Cheers

                  • 6. Re: Issue with running jbpm console 5.1 in websphere 7
                    anand.awasthi Newbie

                    Sure.

                     

                    Here are the exact steps and changes along the way:

                     

                    • Deployed both WAR on Console. each with separate context root. and class loader as parent_last

                     

                    • Change class loader policy to separate for each WAR
                    • Downloaded resteasy-jaxrs-2.2.3.GA.jar and replaced Old JAX-RS jar that came with installer with resteasy-jaxrs-2.2.3.GA (I was getting a class exception)

                    • Set the JVM variables on WAS for Console Directory and Birth Report Engine Installation

                     

                     

                    -Dorg.jbpm.report.engine.dir=D:\temp1 -Djbpm.console.directory=D:\process

                     

                    \resources

                     

                     

                    • Copied hibernate jars , dom4j, javassist jars  in gwt-consoler-server-war/web-inf/lib
                    • Updated persistence.xml with DB2 datasource
                    • Configured Custom User Registry that takes users and group from users.props and groups.props.

                     

                    Following is my user.props

                     

                    # name:passwd:uid:gids:display name
                    # where name   = userId/userName of the user
                    #       passwd = password of the user
                    #       uid    = uniqueId of the user
                    #       gid    = groupIds of the groups that the user belongs to
                    #       display name = a (optional) display name for the user.
                    krisv:krisv:123:789:krisv

                     

                     

                    and groups.props

                     

                    # Format:
                    # name:gid:users:display name
                    # where name   = groupId of the group
                    #       gid    = uniqueId of the group
                    #       users  = list of all the userIds that the group contains
                    #       display name = a (optional) display name for the group.
                    administrator:999:krisv:Administrative group
                    manager:678:krisv:Operators group
                    user:789:krisv:user Group

                     

                     

                    I also wanted to mention:

                     

                    1) that I am not using guvnor for process definition repository, i am using a local folder (

                     

                    D:\process\resources)

                    2) Also I have not installed BIRT run time (i have just added path -Dorg.jbpm.report.engine.dir=D:\temp1 to bypass servlet initialization exception), my understanding is that it only comes in picture when i want to geenrate reports. For initial logon and process management BIRT is not required. Please correct me if I am missing here

                     

                    so after making above changes when I  start server (and I am using IE7, the client does not allow any other browsers).

                     

                    and logon to console :

                     

                    http://localhost:9082/gwt-console/app.html

                     

                    my screen just stays there  on logon page itself and Server Logs Isee following error message:

                     

                     

                     

                     

                    [11/9/11 19:13:12:992 EST] 00000015 SystemOut O 2011-11-09 19:13:12,992 DEBUG [WebContainer : 0] impl.Log4jLogger - PathInfo: /identity/secure/j_security_check

                    [11/9/11 19:13:12:993 EST] 00000015 SystemOut O 2011-11-09 19:13:12,992 DEBUG [WebContainer : 0] impl.Log4jLogger - Failed executing POST /identity/secure/j_security_check

                    org.jboss.resteasy.spi.NotFoundException

                    : Could not find resource for relative : /identity/secure/j_security_check of full path: http://localhost:9082/gwt-console-server/rs/identity/secure/j_security_check

                    at org.jboss.resteasy.core.registry.RootSegment.matchChildren(

                    RootSegment.java:360

                    )
                    • 7. Re: Issue with running jbpm console 5.1 in websphere 7
                      anand.awasthi Newbie

                      alirght folks, i am able to by pass the security error mentioned earlier ( I will post full solution , once i finally get it to work completely). Now when  i start server, I get following BIRT error:

                       

                       

                       

                       

                       

                       

                       

                       

                       

                       

                       

                       

                      R Exception in thread "BirtService-Init"

                       

                      java.lang.RuntimeException

                      : Failed to create birt engine

                      [11/11/11 15:32:03:039 EST] 00000012 SystemErr R at org.jboss.bpm.report.BirtEngineFactory.newInstance(

                       

                      BirtEngineFactory.java:53

                      )

                      [11/11/11 15:32:03:039 EST] 00000012 SystemErr R at org.jboss.bpm.report.BirtService.create(

                      As I mentioned I have not installed birt runtime. My question is it required to start the console server properly. What if I dont want to view reports.

                      How do i get around above error.

                      thanks

                      • 8. Re: Issue with running jbpm console 5.1 in websphere 7
                        shine.arvind Newbie

                        Hello Anand,

                         

                        Did you manage to deploy jBPM Console on WAS 7. Can you post the solution?

                         

                        Regards,