1 Reply Latest reply on Dec 21, 2011 11:11 AM by Matt Wringe

    Error in deploying portlet

    Anitha Ramaiah Newbie

      Hi all,

       

      I have deployed java portlets and all are working fine. Now I have developed spring mvc portlet and tried to deploy. While adding that portlet to some page it shows the error as "The requested resource (/AccountDetails/WEB-INF/servlet/view/FGB/accountsView) is not available" where FGB is the portal that I created.

       

      I even tried adding this portlet to the default portal and got the error as 

      "The requested resource (/AccountDetails/WEB-INF/servlet/view/classic/accountsView) is not available". I don't know why the portal name gets appended to the path.

       

      I read from http://community.jboss.org/wiki/PortletDeployInGateIn and even tried adding the

      <servlet>

        <servlet-name>GateInServlet</servlet-name>

        <servlet-class>org.gatein.wci.api.GateInServlet</servlet-class>

        <load-on-startup>0</load-on-startup>

      </servlet>

      <servlet-mapping>

        <servlet-name>GateInServlet</servlet-name>

        <url-pattern>/gateinservlet</url-pattern>

      </servlet-mapping>

      to the web.xml, but still I am getting the error.

      Please find the xml files attached and help me as soon as possible as it is very urgent.

        • 1. Re: Error in deploying portlet
          Matt Wringe Master

          The portlet is getting deployed properly (you don't need the GateInServlet stuff added to your web.xml). If the portlet wasn't getting deployed properly then you would have gotten a portlet not found exception.

           

          It looks like there is something wrong with your portlet/application itself or with your spring setup.