4 Replies Latest reply on Feb 2, 2009 10:22 PM by Ingo Jobling

    SSL settings? Whither ports?

    Pradeep Singh Newbie

      Need some help configuring SSL for login into Seam application. SSL/JAAS is new to me. I am working with default settings for JBoss, Tomcat and Seam. I created a sample application using JBossTools and it is absolutely awesome. I was trying to knockout the SSL based login which I was really delighted to see already exists and I ran into some issues -


      When I click on the Login link it tries to use https:// protocol but uses the same port number of 8080 and never calls the login page. When I manually change the port number in the link to 8443 the login form opens and I can login. But now when I click on any other link on the main page the protocol changes to http:// however the port remains at 8443. What am I doing wrong? Do I have to provide jaas-config-name element to security:identity in componnets.xml? Will it even be used if I do so? Anything else I have to set?


      I have edited the file - default/deploy/jboss-web.deployer/server.xml and added the section -


      <Connector port="8443" protocol="HTTP/1.1" SSLEnabled="true" maxThreads="150" scheme="https" secure="true" keystoreFile="${jboss.server.home.dir}/conf/keystore" keystorePass="rmi+ssl" clientAuth="false" sslProtocol="TLS"/>




      pages.xml has these elements -


      <page view-id="*" scheme="http"/>



      <page view-id="/login.xhtml" scheme="https"/>



      authenticator.authenticate method has been updated. It is getting called correctly and validating in the database.


      All help is welcome.