+1 from me.
ClientSession and ServerSession is definitely better than the Facade naming.
I too think that JSFClientSession and JSFServerSession are better names than Facade.
Another option would be to use 'JSFClientConversation' and 'JSFServerConversation', like it is used in HttpUnit. I'm not sure about the name ServerConversation though, as it doesn't seem to be a real 'conversation' on the server side.