4 Replies Latest reply on Oct 24, 2008 2:34 PM by Phil Haigh

    Cannot configure richfaces url-pattern using web:ajax4jsf-filter

    Phil Haigh Novice


      In the Seam documentation, it states richfaces can  be configured in components.xml as follows:



      <web:ajax4jsf-filter force-parser="true" 
      enable-cache="true" 
      log4j-init-file="custom-log4j.xml"
      url-pattern="*.seam"/>



      This doesn't seem to actually work: including the url-pattern parameter disables all richfaces ui functionality.


      Can this either be resolved, or some other option put in place for not using the RichFaces filter on everything that you use the Seam filter for?


      Here is an example: you have an XML driven flash slideshow, and you want the XML to be dynamic. You naturally would like to make use of Seam/JSF access to your Entity objects, so you create a slideshowimages.xhtml file, and tell your Flash movie to look at slideshowimages.xml for it's markup. (You add .xml to the url pattern for your Faces servlet).


      However, because you have the RichFaces jars present, Seam configures RichFaces run to on .xml requests too, and RichFaces 'decorates' your nice clean XML with RichFaces/Ajax stuff - which is clearly not wanted in this example.


      Any ideas?


      cheers


      phil