1 2 Previous Next 15 Replies Latest reply on Oct 17, 2012 11:36 AM by Tomaz Cerar

    JSP debug does not work with 7.1.1.Final

    Aleš Bregar Newbie

      Hi,

       

      I am doing some legacy webapp porting to as7 and it is comprised of lots of jsp/servlet pair.

      I have tried to debug those by using as 7.1.1.Final, eclipse 3.7.2 and Jboss tools 3.3.0.Beta1. Putting breakpoint to JSP file in eclipse and starting as7 in debug mode is ok.

      But at runtime call does not suspend on breakpoint.

       

      Playing with settings in web subsystem (http://docs.jboss.org/jbossweb/7.0.x/config/jsp.html) was not of any help. Maybe is there missing something like 'classdebuginfo' setting?

      I have also tried remote socket debugging and starting as7 out of jboss tools, but still no suspend on breakpoint.

       

       

      It is not a critical issue but would be really helpful if I clarify about this - first if debug is even possible in as7 and what I am missing to setup.

       

       

      Thank you in advance,

      A

        1 2 Previous Next