2 Replies Latest reply on Mar 14, 2012 10:00 PM by ianfeldberg

    JBoss starts up but port 8080 not working in web browser


      Hi all. We're in the process of upgrading our neglected J2EE application, running in JBoss 3.2.6, to a more modern version. I got it working in JBoss 4.0.5 but then realized I needed at least JBoss 4.2.3 to run EJB3. When I installed JBoss 4.2.3 and started it up (without my application's ear file) it seems to work and I get the proper printlns to the console that tell me that port 8080 is working, such as:


          21:24:33,393 INFO   [Http11Protocol] Starting Coyote AJP/1.3 on http:


      But when I try to open http://localhost:8080/ in Firefox I get a "Failed to Connect" screen. It works fine in JBoss 3.2.6 and 4.0.5 but not JBoss 4.2.3. I then tried installing and running JBoss 5.1.0, 6.1.0 and 7.1.0 and they all do the same thing! I've tried all of them on Redhat 4.6 and 5.4 - same problem! I see no errors in the boot.log or server.log files.


      I've tried all these things to no avail:


      - set JAVA_HOME and PATH correctly to use Java 1.5.0_09

      - set JBOSS_HOME and PATH to where JBoss is located

      - started run.sh with the all and standard server configurations instead of "default"

      - tried going to localhost:8080,, and <the actual ip of the machine>:8080 in Firefox


      I don't get it. Did something change between 4.0.5 and 4.2.3 that would cause such a strange error?