12 Replies Latest reply on Jul 10, 2012 1:00 AM by Robbie Shen

    argument disappear in BPM

    Robbie Shen Newbie


      my application just like above, i don't know why after i do some operate at frontend and the argument still exit at the step 1 , but when i check at the web page(step 2) again, the argument disappear.

      anybody knows why? thank you!

        • 1. Re: argument disappear in BPM
          Robbie Shen Newbie

          Is there anybody can help me

          • 2. Re: argument disappear in BPM
            David Ward Master

            Robbie, I downloaded your example app yesterday, but haven't had a chance to debug it yet. I will most likely be able to later today.

            • 4. Re: argument disappear in BPM
              David Ward Master



              Sorry it took me a bit to get to this.  I was not able to run your example, as there is a missing dependency, com.ac.refapp.hybris:refapp-api-hybris:1.0.1-SNAPSHOT.  So, I had to just poke around and eyeball things rather than being able to actually debug it in a debugger.


              A couple things you might want to try:

              1. Your "unfinish" switchyard service is the only one that doesn't specifcy a ticket output parameter. Again, I can't debug it with the build issue, but maybe you could add that and give it another shot?
              2. I noticed your screenshot looks like the old bpmn eclipse plugin.  You should update to to latest version [1] as well as the latest switchyard plugin version [2], open up your bpmn2 file, right-click on the background, and click "Update". Then save and try again.  A longshot, but it might make jBPM happier.
              3. If after doing the above 2 things don't help, please re-attach a new version of your project with a pom.xml that references a repository fulfilling all the required dependencies (including the missing one I mentioned above).  I will then be able to properly debug it for you.





              [1] http://download.eclipse.org/bpmn2-modeler/site/

              [2] http://download.jboss.org/jbosstools/updates/nightly/soa-tooling/3.3.x/

              • 5. Re: argument disappear in BPM
                Robbie Shen Newbie

                hi David

                     Thank you, I have already try the first step befor, but doesn't work, i saw the jbmp demo also don't have a output parameter, i don't know why


                     I will try the step two today, if still does't work ,i will upload com.ac.refapp.hybris:refapp-api-hybris:1.0.1-SNAPSHOT later


                     PS: are you an employee of jboss? you guys are so kind to spend so much time to answer every question at this community.

                • 6. Re: argument disappear in BPM
                  Robbie Shen Newbie

                  hi david

                       i had tried the step two, still doesn't work.

                       could you also take a look for me at the last question i asked about guvnor


                       thank you!

                  • 7. Re: argument disappear in BPM
                    Robbie Shen Newbie

                    are you still there doing some help for me ?

                    • 8. Re: argument disappear in BPM
                      Keith Babo Master

                      Hey Robbie,


                      We are a week away from the 0.5.0.Final release, so everyone is running at their limit to get the release out the door.  We make every attempt to reply quickly to issues and questions, but for questions that require deeper debugging and analysis into an application the wait is going to be a bit longer.


                      ~ keith

                      • 9. Re: argument disappear in BPM
                        David Ward Master



                        I came back to this this morning and figured out what was going on.  I'm going to attach a fixed project for you (refapp-jbpm-console-2.zip).  I made quite a few changes for it to work for me (including path to watched Camel directory, H2 db instead of MySQL, lots of debugging printlns, etc.), however the actual problem and fix were easy:


                        In your process flow, your "unfinish" switchyard service task should NOT have had a result parameter of "ticket". The reason is that the method returns void, and so "null" was being set BACK into the process to fill in the "ticket" variable at the process scope.  Then, your Order List Check had nothing to work with the second time around.


                        Thanks for your patience and sorry it took so long for me to be able to focus on it.


                        Best regards,


                        PS: Yes, I am JBoss (Red Hat) employee.


                        Message was edited by: David Ward

                        • 10. Re: argument disappear in BPM
                          Robbie Shen Newbie


                               i don't know what's your mean

                               i don't know what your have changed for me to make this program work. my "unfinish" switchyard service don't have had a result parameter of "ticket", it just has a parameter mapping 


                               have your change anything else?



                          • 11. Re: argument disappear in BPM
                            David Ward Master

                            Yes, as I said there were lots of things I had to change to make it work.  I'm attaching a diff file that shows all the differences, but here's a re-cap of the changes:

                            1. pom.xml: Removed unecessary property definitions and unecessary and incorrect pom and manifest dependencies.
                            2. HelpDesk.java: Ensure getting proper task and ticket objects via storing and retrieving tickets in the map keyed by the task id, NOT the process instance id, only claim a task if the task status is ready, added refresh capability in addition to submit, added debug printlns.
                            3. MonitorMangementServiceImpl: added debug printlns.
                            4. OrderService.bpmn: Added <itemDefinitions/> for the tickets, graphical layout changes.
                            5. switchyard.xml: Changed the camel binding to point to a file on my filesystem (Mac path vs. Windoze path)
                            6. orders.xhtml: Changed view so that userTickets are keyed off of task id vs. process instance id (see #2 above), added refresh capability (see #2 above)
                            7. tasks.xhtml: Removed unecessary Details link.
                            8. persistence.xml (for the taskserver): Changed from mysql to h2.


                            • 12. Re: argument disappear in BPM
                              Robbie Shen Newbie

                              hi David

                                   thanks, i misunderstood what you said , i thougt you just change node unfinish of "orderservice.bpmn", then it works


                                   thanks for your patience!